summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-25 17:51:52 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-25 17:51:52 +0000
commite77e7658d8b0df2057d9153cce4cbdf48af5aa10 (patch)
tree7e62300369bbee30026a0ce625d14c24bc97b94c /sys-apps/lm_sensors
parentRefix completion dir using eclass (#477820 by Alexander Tsoy and poncho) (diff)
downloadgentoo-2-e77e7658d8b0df2057d9153cce4cbdf48af5aa10.tar.gz
gentoo-2-e77e7658d8b0df2057d9153cce4cbdf48af5aa10.tar.bz2
gentoo-2-e77e7658d8b0df2057d9153cce4cbdf48af5aa10.zip
sys-apps/lm_sensors: Version BUmp, #474490
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-apps/lm_sensors')
-rw-r--r--sys-apps/lm_sensors/ChangeLog8
-rw-r--r--sys-apps/lm_sensors/files/lm_sensors-3.3.4-sensors-detect-gentoo.patch118
-rw-r--r--sys-apps/lm_sensors/lm_sensors-3.3.4.ebuild109
-rw-r--r--sys-apps/lm_sensors/metadata.xml14
4 files changed, 241 insertions, 8 deletions
diff --git a/sys-apps/lm_sensors/ChangeLog b/sys-apps/lm_sensors/ChangeLog
index 8c841e1eaa98..8a74206c89f8 100644
--- a/sys-apps/lm_sensors/ChangeLog
+++ b/sys-apps/lm_sensors/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/lm_sensors
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.136 2013/07/13 11:25:30 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/ChangeLog,v 1.137 2013/07/25 17:51:52 jlec Exp $
+
+*lm_sensors-3.3.4 (25 Jul 2013)
+
+ 25 Jul 2013; Justin Lecher <jlec@gentoo.org> +lm_sensors-3.3.4.ebuild,
+ +files/lm_sensors-3.3.4-sensors-detect-gentoo.patch, metadata.xml:
+ Version BUmp, #474490
13 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/fancontrol.service,
+files/sensord.service, lm_sensors-3.3.3-r2.ebuild:
diff --git a/sys-apps/lm_sensors/files/lm_sensors-3.3.4-sensors-detect-gentoo.patch b/sys-apps/lm_sensors/files/lm_sensors-3.3.4-sensors-detect-gentoo.patch
new file mode 100644
index 000000000000..215969af2cb6
--- /dev/null
+++ b/sys-apps/lm_sensors/files/lm_sensors-3.3.4-sensors-detect-gentoo.patch
@@ -0,0 +1,118 @@
+diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect
+index fb17481..bb324c2 100755
+--- a/prog/detect/sensors-detect
++++ b/prog/detect/sensors-detect
+@@ -20,6 +20,9 @@
+ # MA 02110-1301 USA.
+ #
+
++# Gentoo specific modifications based on a patch from Rudo Thomas
++# <thomr9am@ss1000.ms.mff.cuni.cz>
++
+ require 5.004;
+
+ use strict;
+@@ -6671,26 +6674,33 @@ sub write_config
+ print MODPROBE_D $configfile;
+ close(MODPROBE_D);
+ } else {
++ print "\nIf you want to load the modules at startup, generate a config file\n",
++ "below and make sure lm_sensors gets started at boot time; e.g\n",
++ "\$ rc-update add lm_sensors default\n";
+ print "To make the sensors modules behave correctly, add these lines to\n".
+- "/etc/modprobe.conf:\n\n";
++ "/etc/modules.d/lm_sensors and run modules-update:\n\n";
+ print "#----cut here----\n".
+ $configfile.
+ "#----cut here----\n\n";
+ }
+ }
+
+- my $have_sysconfig = -d '/etc/sysconfig';
+- printf "Do you want to \%s /etc/sysconfig/lm_sensors? (\%s): ",
+- (-e '/etc/sysconfig/lm_sensors' ? 'overwrite' : 'generate'),
+- ($have_sysconfig ? 'YES/no' : 'yes/NO');
+- $_ = <STDIN>;
+- if (($have_sysconfig and not m/^\s*n/i) or m/^\s*y/i) {
+- unless ($have_sysconfig) {
+- mkdir('/etc/sysconfig', 0777)
+- or die "Sorry, can't create /etc/sysconfig ($!)";
++ my $have_config = -f '/etc/conf.d/lm_sensors';
++ print "\nDo you want to ".($have_config?"overwrite":"generate").
++ " /etc/conf.d/lm_sensors? Enter s to specify other file name?\n",
++ " (".($have_config?"yes/NO":"YES/no")."/s): ";
++ my $reply = <STDIN>;
++
++ if (($have_config and $reply =~ /^\s*[Yy]/) or
++ (not $have_config and not $reply =~ /^\s*[Nn]/) or
++ $reply =~ /^\s*[Ss]/) {
++ my $filename = "/etc/conf.d/lm_sensors";
++ if ($reply =~ /^\s*[Ss]/) {
++ print "Specify the file to store the configuration to: ";
++ $filename = <STDIN>;
+ }
+- open(local *SYSCONFIG, ">/etc/sysconfig/lm_sensors")
+- or die "Sorry, can't create /etc/sysconfig/lm_sensors ($!)";
++ open(local *SYSCONFIG, ">".$filename)
++ or die "Sorry, can't create $filename ($!).";
+ print SYSCONFIG "# Generated by sensors-detect on " . scalar localtime() . "\n";
+ print SYSCONFIG <<'EOT';
+ # This file is sourced by /etc/init.d/lm_sensors and defines the modules to
+@@ -6701,30 +6711,17 @@ sub write_config
+ # BUS_MODULES for any required bus driver module (for example for I2C or SPI).
+
+ EOT
++ print SYSCONFIG
++ "# Load modules at startup\n".
++ "LOADMODULES=yes\n\n".
++ "# Initialize sensors at startup\n".
++ "INITSENSORS=yes\n\n";
+ print SYSCONFIG "BUS_MODULES=\"", join(" ", @{$bus_modules}), "\"\n"
+ if @{$bus_modules};
+ print SYSCONFIG "HWMON_MODULES=\"", join(" ", @{$hwmon_modules}), "\"\n";
+ close(SYSCONFIG);
+
+- if (-x "/bin/systemctl" && -d "/lib/systemd/system" &&
+- ! -f "/lib/systemd/system/lm_sensors.service") {
+- print "Copy prog/init/lm_sensors.service to /lib/systemd/system\n".
+- "and run 'systemctl enable lm_sensors.service'\n".
+- "for initialization at boot time.\n";
+- return;
+- }
+-
+- if (-x "/bin/systemctl" &&
+- -f "/lib/systemd/system/lm_sensors.service") {
+- system("/bin/systemctl", "enable", "lm_sensors.service");
+- system("/bin/systemctl", "start", "lm_sensors.service");
+- # All done, don't check for /etc/init.d/lm_sensors
+- return;
+- }
+-
+- print "Copy prog/init/lm_sensors.init to /etc/init.d/lm_sensors\n".
+- "for initialization at boot time.\n"
+- unless -f "/etc/init.d/lm_sensors";
++ print "Done.\n";
+
+ if (-x "/sbin/insserv" && -f "/etc/init.d/lm_sensors") {
+ system("/sbin/insserv", "/etc/init.d/lm_sensors");
+@@ -6738,20 +6735,6 @@ EOT
+ "kernel modules.\n\n";
+ }
+ } else {
+- print "To load everything that is needed, add this to one of the system\n".
+- "initialization scripts (e.g. /etc/rc.d/rc.local):\n\n";
+- print "#----cut here----\n";
+- if (@{$bus_modules}) {
+- print "# Adapter drivers\n";
+- print "modprobe $_\n" foreach (@{$bus_modules});
+- }
+- print "# Chip drivers\n";
+- print "modprobe $_\n" foreach (@{$hwmon_modules});
+- print((-e '/usr/bin/sensors' ?
+- "/usr/bin/sensors -s\n" :
+- "/usr/local/bin/sensors -s\n").
+- "#----cut here----\n\n");
+-
+ print "If you have some drivers built into your kernel, the list above will\n".
+ "contain too many modules. Skip the appropriate ones! You really\n".
+ "should try these commands right now to make sure everything is\n".
diff --git a/sys-apps/lm_sensors/lm_sensors-3.3.4.ebuild b/sys-apps/lm_sensors/lm_sensors-3.3.4.ebuild
new file mode 100644
index 000000000000..47e4dcf7a979
--- /dev/null
+++ b/sys-apps/lm_sensors/lm_sensors-3.3.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-3.3.4.ebuild,v 1.1 2013/07/25 17:51:52 jlec Exp $
+
+EAPI=5
+
+inherit eutils linux-info multilib systemd toolchain-funcs
+
+DESCRIPTION="Hardware Monitoring user-space utilities"
+HOMEPAGE="http://www.lm-sensors.org/"
+SRC_URI="http://dl.lm-sensors.org/lm-sensors/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="sensord static-libs"
+
+RDEPEND="
+ dev-lang/perl
+ sensord? (
+ net-analyzer/rrdtool
+ virtual/logger
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+CONFIG_CHECK="~HWMON ~I2C_CHARDEV ~I2C"
+WARNING_HWMON="${PN} requires CONFIG_HWMON to be enabled for use."
+WARNING_I2C_CHARDEV="sensors-detect requires CONFIG_I2C_CHARDEV to be enabled."
+WARNING_I2C="${PN} requires CONFIG_I2C to be enabled for most sensors."
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sensors-detect-gentoo.patch
+
+ use sensord && { sed -i -e 's:^#\(PROG_EXTRA.*\):\1:' Makefile || die; }
+
+ # Respect LDFLAGS
+ sed -i -e 's/\$(LIBDIR)$/\$(LIBDIR) \$(LDFLAGS)/g' Makefile || die
+
+ # Fix shipped unit file paths
+ sed -i -e 's:\(^EnvironmentFile=\).*:\1/etc/conf.d/lm_sensors:' \
+ prog/init/lm_sensors.service || die
+
+ use static-libs || { sed -i -e '/^BUILD_STATIC_LIB/d' Makefile || die; }
+}
+
+src_compile() {
+ einfo
+ einfo "You may safely ignore any errors from compilation"
+ einfo "that contain \"No such file or directory\" references."
+ einfo
+
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ MANDIR="${EPREFIX}/usr/share/man" \
+ ETCDIR="${EPREFIX}/etc" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ newinitd "${FILESDIR}"/${PN}-3-init.d ${PN}
+ systemd_dounit prog/init/lm_sensors.service
+
+ newinitd "${FILESDIR}"/fancontrol-init.d-2 fancontrol
+ systemd_dounit "${FILESDIR}"/fancontrol.service
+
+ if use sensord; then
+ newconfd "${FILESDIR}"/sensord-conf.d sensord
+ newinitd "${FILESDIR}"/sensord-4-init.d sensord
+ systemd_dounit "${FILESDIR}"/sensord.service
+ fi
+
+ dodoc CHANGES CONTRIBUTORS INSTALL README \
+ doc/{donations,fancontrol.txt,fan-divisors,libsensors-API.txt,progs,temperature-sensors,vid}
+
+ docinto developers
+ dodoc doc/developers/applications
+}
+
+pkg_postinst() {
+ echo
+ elog "Please run \`/usr/sbin/sensors-detect' in order to setup"
+ elog "/etc/conf.d/${PN}."
+ echo
+ elog "/etc/conf.d/${PN} is vital to the init-script."
+ elog "Please make sure you also add ${PN} to the desired"
+ elog "runlevel. Otherwise your I2C modules won't get loaded"
+ elog "on the next startup."
+ echo
+ elog "You will also need to run the above command if you're upgrading from"
+ elog "<=${PN}-2, as the needed entries in /etc/conf.d/${PN} has"
+ elog "changed."
+ echo
+ elog "Be warned, the probing of hardware in your system performed by"
+ elog "sensors-detect could freeze your system. Also make sure you read"
+ elog "the documentation before running ${PN} on IBM ThinkPads."
+ echo
+ elog "Also make sure you have read:"
+ elog "http://www.lm-sensors.org/wiki/FAQ/Chapter3#Mysensorshavestoppedworkinginkernel2.6.31"
+ echo
+ elog "Please refer to the ${PN} documentation for more information."
+ elog "(http://www.lm-sensors.org/wiki/Documentation)"
+ echo
+}
diff --git a/sys-apps/lm_sensors/metadata.xml b/sys-apps/lm_sensors/metadata.xml
index d15de0652abe..59f84f21b45e 100644
--- a/sys-apps/lm_sensors/metadata.xml
+++ b/sys-apps/lm_sensors/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jdhore@gentoo.org</email>
- <name>Jeff Horelick</name>
- </maintainer>
- <use>
- <flag name='sensord'>Enable sensord - a daemon that can be used to
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ </maintainer>
+ <use>
+ <flag name="sensord">Enable sensord - a daemon that can be used to
periodically log sensor readings from hardware health-monitoring
chips</flag>
- </use>
+ </use>
</pkgmetadata>