summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-01 22:12:56 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-01 22:12:56 +0000
commit30ebf7db2d6deaee4a8439488f44d83511532604 (patch)
tree4f1faee1026c125cfa57daa51a2ba76d04ada759 /sys-apps/isapnptools
parentstable amd64 (diff)
downloadgentoo-2-30ebf7db2d6deaee4a8439488f44d83511532604.tar.gz
gentoo-2-30ebf7db2d6deaee4a8439488f44d83511532604.tar.bz2
gentoo-2-30ebf7db2d6deaee4a8439488f44d83511532604.zip
Touchup building #117333 and remove old sed line.
(Portage version: 2.1_pre3)
Diffstat (limited to 'sys-apps/isapnptools')
-rw-r--r--sys-apps/isapnptools/ChangeLog10
-rw-r--r--sys-apps/isapnptools/files/digest-isapnptools-1.26-r21
-rw-r--r--sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch41
-rw-r--r--sys-apps/isapnptools/isapnptools-1.26-r2.ebuild35
4 files changed, 85 insertions, 2 deletions
diff --git a/sys-apps/isapnptools/ChangeLog b/sys-apps/isapnptools/ChangeLog
index 274d06eb63b1..1b01f6f2d501 100644
--- a/sys-apps/isapnptools/ChangeLog
+++ b/sys-apps/isapnptools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/isapnptools
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/isapnptools/ChangeLog,v 1.7 2005/04/22 00:19:27 wormo Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/isapnptools/ChangeLog,v 1.8 2006/01/01 22:12:56 vapier Exp $
+
+*isapnptools-1.26-r2 (01 Jan 2006)
+
+ 01 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/isapnptools-1.26-gcc.patch, +isapnptools-1.26-r2.ebuild:
+ Touchup building #117333 and remove old sed line.
21 Apr 2005; Stephanie Lockwood-Childs <wormo@gentoo.org>
isapnptools-1.26-r1.ebuild:
diff --git a/sys-apps/isapnptools/files/digest-isapnptools-1.26-r2 b/sys-apps/isapnptools/files/digest-isapnptools-1.26-r2
new file mode 100644
index 000000000000..b499926c6700
--- /dev/null
+++ b/sys-apps/isapnptools/files/digest-isapnptools-1.26-r2
@@ -0,0 +1 @@
+MD5 26def2016548edeafe383113f0bc8ac6 isapnptools-1.26.tgz 231098
diff --git a/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch b/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch
new file mode 100644
index 000000000000..3d1f2cee9f80
--- /dev/null
+++ b/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/117333
+
+--- isapnptools/src/isapnp_main.l
++++ isapnptools/src/isapnp_main.l
+@@ -363,7 +363,6 @@
+ return 0;
+ }
+
+-static unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
+ static char *boardid[NUM_CARDS+1];
+ static unsigned long serno[NUM_CARDS+1];
+
+--- isapnptools/src/callbacks.c
++++ isapnptools/src/callbacks.c
+@@ -49,6 +49,7 @@
+ #include <isapnp/callbacks.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <errno.h>
+ #include <string.h>
+
+--- isapnptools/src/resource.c
++++ isapnptools/src/resource.c
+@@ -12,6 +12,7 @@
+ alloc_in_range_list() reordered to handle source name by P.Fox
+ */
+
++#define _GNU_SOURCE
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+@@ -285,7 +286,7 @@
+ void allocate_pci_resources( void )
+ {
+ char *line = 0;
+- int lineMax = 0;
++ size_t lineMax = 0;
+
+ FILE *fp = fopen( "/proc/bus/pci/devices", "rt" );
+ if( !fp )
diff --git a/sys-apps/isapnptools/isapnptools-1.26-r2.ebuild b/sys-apps/isapnptools/isapnptools-1.26-r2.ebuild
new file mode 100644
index 000000000000..e34df1e1f8e3
--- /dev/null
+++ b/sys-apps/isapnptools/isapnptools-1.26-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/isapnptools/isapnptools-1.26-r2.ebuild,v 1.1 2006/01/01 22:12:56 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Tools for configuring ISA PnP devices"
+HOMEPAGE="http://www.roestock.demon.co.uk/isapnptools/"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /sbin
+ mv "${D}"/usr/sbin/isapnp "${D}"/sbin/ || die "couldnt relocate isapnp"
+
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto txt
+ dodoc doc/README* doc/*.txt test/*.txt
+ dodoc etc/isapnp.*
+
+ newinitd "${FILESDIR}"/isapnp.rc isapnp
+}