summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-11-05 16:47:36 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-11-05 16:47:36 +0000
commit9f18f8a9b38b43e52d9d79e7767aff18e019fd9d (patch)
treee7a439be34ae2754eef1f8b8a01fc21c9618bfea /sys-apps/i2c
parentkeywording as ~amd64, ~ppc64, ~ia64, and ~x86. added ~ppc keyword thanks to t... (diff)
downloadgentoo-2-9f18f8a9b38b43e52d9d79e7767aff18e019fd9d.tar.gz
gentoo-2-9f18f8a9b38b43e52d9d79e7767aff18e019fd9d.tar.bz2
gentoo-2-9f18f8a9b38b43e52d9d79e7767aff18e019fd9d.zip
CC=${CC} >> CC=$(tc-getCC); bug #70120.
Diffstat (limited to 'sys-apps/i2c')
-rw-r--r--sys-apps/i2c/ChangeLog6
-rw-r--r--sys-apps/i2c/i2c-2.8.1.ebuild8
-rw-r--r--sys-apps/i2c/i2c-2.8.2.ebuild8
-rw-r--r--sys-apps/i2c/i2c-2.8.3.ebuild8
-rw-r--r--sys-apps/i2c/i2c-2.8.4.ebuild8
-rw-r--r--sys-apps/i2c/i2c-2.8.7.ebuild8
-rw-r--r--sys-apps/i2c/i2c-2.8.8.ebuild8
7 files changed, 29 insertions, 25 deletions
diff --git a/sys-apps/i2c/ChangeLog b/sys-apps/i2c/ChangeLog
index 5d6843c2c13d..6f90dd5ee47f 100644
--- a/sys-apps/i2c/ChangeLog
+++ b/sys-apps/i2c/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/i2c
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.25 2004/10/23 22:40:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.26 2004/11/05 16:47:36 plasmaroo Exp $
+
+ 05 Nov 2004; <plasmaroo@gentoo.org> i2c-2.8.1.ebuild, i2c-2.8.2.ebuild,
+ i2c-2.8.3.ebuild, i2c-2.8.4.ebuild, i2c-2.8.7.ebuild, i2c-2.8.8.ebuild:
+ CC=${CC} >> CC=$(tc-getCC); bug #70120.
*i2c-2.8.8 (23 Oct 2004)
diff --git a/sys-apps/i2c/i2c-2.8.1.ebuild b/sys-apps/i2c/i2c-2.8.1.ebuild
index 16da3df403c3..7fd1b4f65d6b 100644
--- a/sys-apps/i2c/i2c-2.8.1.ebuild
+++ b/sys-apps/i2c/i2c-2.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.1.ebuild,v 1.10 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.1.ebuild,v 1.11 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -87,7 +87,7 @@ src_compile () {
echo -n ' '; einfo "that contain 'No such file' references."
echo; echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -100,7 +100,7 @@ src_compile () {
src_install() {
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \
diff --git a/sys-apps/i2c/i2c-2.8.2.ebuild b/sys-apps/i2c/i2c-2.8.2.ebuild
index e6827686be20..ce0520816658 100644
--- a/sys-apps/i2c/i2c-2.8.2.ebuild
+++ b/sys-apps/i2c/i2c-2.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.2.ebuild,v 1.7 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.2.ebuild,v 1.8 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -87,7 +87,7 @@ src_compile () {
echo -n ' '; einfo "that contain 'No such file' references."
echo; echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -100,7 +100,7 @@ src_compile () {
src_install() {
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \
diff --git a/sys-apps/i2c/i2c-2.8.3.ebuild b/sys-apps/i2c/i2c-2.8.3.ebuild
index 17c080b8d4cb..8c0944b226a2 100644
--- a/sys-apps/i2c/i2c-2.8.3.ebuild
+++ b/sys-apps/i2c/i2c-2.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.3.ebuild,v 1.6 2004/09/03 21:03:23 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.3.ebuild,v 1.7 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -87,7 +87,7 @@ src_compile () {
echo -n ' '; einfo "that contain 'No such file' references."
echo; echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -100,7 +100,7 @@ src_compile () {
src_install() {
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \
diff --git a/sys-apps/i2c/i2c-2.8.4.ebuild b/sys-apps/i2c/i2c-2.8.4.ebuild
index 7a955e629757..4538aee165ad 100644
--- a/sys-apps/i2c/i2c-2.8.4.ebuild
+++ b/sys-apps/i2c/i2c-2.8.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.4.ebuild,v 1.10 2004/10/23 22:40:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.4.ebuild,v 1.11 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -83,7 +83,7 @@ src_compile () {
einfo "that contain 'No such file' references."
echo; echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -97,7 +97,7 @@ src_install() {
echo ${KV} | grep -q 2.4.
if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \
diff --git a/sys-apps/i2c/i2c-2.8.7.ebuild b/sys-apps/i2c/i2c-2.8.7.ebuild
index 049fa01327b2..a4b8bdc2229f 100644
--- a/sys-apps/i2c/i2c-2.8.7.ebuild
+++ b/sys-apps/i2c/i2c-2.8.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.7.ebuild,v 1.8 2004/10/23 22:40:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.7.ebuild,v 1.9 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -83,7 +83,7 @@ src_compile () {
einfo "that contain 'No such file' references."
echo; echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -97,7 +97,7 @@ src_install() {
echo ${KV} | grep -q 2.4.
if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \
diff --git a/sys-apps/i2c/i2c-2.8.8.ebuild b/sys-apps/i2c/i2c-2.8.8.ebuild
index b6c4bfd5692f..ef2d3807fcb6 100644
--- a/sys-apps/i2c/i2c-2.8.8.ebuild
+++ b/sys-apps/i2c/i2c-2.8.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.8.ebuild,v 1.1 2004/10/23 22:40:37 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.8.ebuild,v 1.2 2004/11/05 16:47:36 plasmaroo Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -83,7 +83,7 @@ src_compile () {
einfo "that contain 'No such file' references."
echo '>>> Compiling...'
- emake CC=${CC} LINUX=$LINUX clean all
+ emake CC=$(tc-getCC) LINUX=$LINUX clean all
if [ $? != 0 ]; then
eerror "I2C requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -97,7 +97,7 @@ src_install() {
echo ${KV} | grep -q 2.4.
if [ "$?" -eq '0' -o "$LINUX" != '' ]; then
emake \
- CC=${CC} \
+ CC=$(tc-getCC) \
LINUX=$LINUX \
LINUX_INCLUDE_DIR=/usr/include/linux \
DESTDIR=${D} \