summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-31 17:00:53 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-31 17:00:53 +0000
commit21ebce2860e64fe64e101dc05464d9b97b1e8701 (patch)
tree407816d0a7b753732aba51d22f115e059be6a720 /sys-apps/hwsetup
parentIt helps if I actually add the patch to the ebuild. Closing bug #127023 and ... (diff)
downloadgentoo-2-21ebce2860e64fe64e101dc05464d9b97b1e8701.tar.gz
gentoo-2-21ebce2860e64fe64e101dc05464d9b97b1e8701.tar.bz2
gentoo-2-21ebce2860e64fe64e101dc05464d9b97b1e8701.zip
Updated patch to work properly for detecting cards. Thanks to Jochen Spang <jochen.spang@freenet.de> for doing the work on finding this bug and reporting it to me.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog8
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch11
2 files changed, 8 insertions, 11 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 64c236334b56..0ca1d294f020 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.40 2006/02/09 19:43:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.41 2006/03/31 17:00:53 wolf31o2 Exp $
+
+ 31 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/hwsetup-1.1-gentoo.patch:
+ Updated patch to work properly for detecting cards. Thanks to Jochen Spang
+ <jochen.spang@freenet.de> for doing the work on finding this bug and
+ reporting it to me.
09 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org> hwsetup-1.1.ebuild:
Removing dependency on hwdata-knoppix and closing bug #122248.
diff --git a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
index cff145434b78..a91246b093ca 100644
--- a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
+++ b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
@@ -13,7 +13,7 @@ diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
-#define XPATH "/usr/X11R6/bin/"
-#define XMODPATH "/usr/X11R6/lib/modules/drivers/"
+#define XPATH "/usr/bin/"
-+#define XMODPATH "/usr/lib/xorg/modules/drivers/"
++#define XMODPATH "/usr/lib/modules/drivers/"
#define VERBOSE_PRINT 1
-#define VERBOSE_PROMPT 2
@@ -43,15 +43,6 @@ diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
if(!strncasecmp(d->driver,"Card:",5)) /* RedHat Cards-DB */
{ /* Kudzu "Cards" format */
FILE *cardsdb;
-@@ -255,7 +256,7 @@
- char xmodule[32];
- char fullpath[128];
- sscanf(&buffer[7],"%31s",xmodule);
-- sprintf(fullpath,XMODPATH"%.31s_drv.o",xmodule);
-+ sprintf(fullpath,XMODPATH"%.31s_drv.so",xmodule);
- if(exists(fullpath))
- {
- strncpy(xi.xmodule,xmodule,sizeof(xi.xmodule));
@@ -279,9 +280,9 @@
if(*xfree3server&&!*xi.xmodule)
strncpy(xi.xserver,xfree3server,sizeof(xi.xserver));