summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-30 23:15:06 +0000
commitb795ef40f29871a83d01839ee8ad432968396763 (patch)
treea61528cb587cc81b06df6960f98eafdf2f236a84 /sys-apps/fileutils
parentcute little gnome-vfs fix (diff)
downloadgentoo-2-b795ef40f29871a83d01839ee8ad432968396763.tar.gz
gentoo-2-b795ef40f29871a83d01839ee8ad432968396763.tar.bz2
gentoo-2-b795ef40f29871a83d01839ee8ad432968396763.zip
Prepared for rc3
Diffstat (limited to 'sys-apps/fileutils')
-rw-r--r--sys-apps/fileutils/fileutils-4.0.32.ebuild28
-rw-r--r--sys-apps/fileutils/fileutils-4.0.33.ebuild8
2 files changed, 33 insertions, 3 deletions
diff --git a/sys-apps/fileutils/fileutils-4.0.32.ebuild b/sys-apps/fileutils/fileutils-4.0.32.ebuild
new file mode 100644
index 000000000000..a8b9184cb009
--- /dev/null
+++ b/sys-apps/fileutils/fileutils-4.0.32.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.0.32.ebuild,v 1.3 2000/11/30 23:14:32 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ #we are waiting for GNU fileutils 4.0.30 which will become standard in Gentoo 1.0
+ #until then, we wait.
+ try ./configure --prefix=/usr
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ dodoc COPYING NEWS README* THANKS TODO ChangeLog ChangeLog-1997 AUTHORS
+ make prefix=${D}/usr install
+ cd ${D}
+ mv usr/bin .
+
+}
+
diff --git a/sys-apps/fileutils/fileutils-4.0.33.ebuild b/sys-apps/fileutils/fileutils-4.0.33.ebuild
index f1fb85a40330..d2d96bb613de 100644
--- a/sys-apps/fileutils/fileutils-4.0.33.ebuild
+++ b/sys-apps/fileutils/fileutils-4.0.33.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.0.33.ebuild,v 1.1 2000/11/28 19:30:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fileutils/fileutils-4.0.33.ebuild,v 1.2 2000/11/30 23:14:32 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,11 +9,13 @@ DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls, etc)"
SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
HOMEPAGE="http://www.gnu.org/software/fileutils/fileutils.html"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
src_compile() {
#we are waiting for GNU fileutils 4.0.30 which will become standard in Gentoo 1.0
#until then, we wait.
try ./configure --prefix=/usr
- try make
+ try make ${MAKEOPTS}
}
src_install() {
@@ -21,6 +23,6 @@ src_install() {
make prefix=${D}/usr install
cd ${D}
mv usr/bin .
- prepall
+ rm -rf usr/lib
}