summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-07-09 20:37:34 +0000
committerSven Wegener <swegener@gentoo.org>2006-07-09 20:37:34 +0000
commit1e0b555a4b0e5fd13f83beb63311f259ab55b17e (patch)
tree8558016390e50a9349407cd8ddfef09a1f799959 /sys-apps/dstat
parenteinfo -> elog (diff)
downloadgentoo-2-1e0b555a4b0e5fd13f83beb63311f259ab55b17e.tar.gz
gentoo-2-1e0b555a4b0e5fd13f83beb63311f259ab55b17e.tar.bz2
gentoo-2-1e0b555a4b0e5fd13f83beb63311f259ab55b17e.zip
Version bump.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/ChangeLog9
-rw-r--r--sys-apps/dstat/dstat-0.6.3.ebuild43
-rw-r--r--sys-apps/dstat/files/digest-dstat-0.6.0-r12
-rw-r--r--sys-apps/dstat/files/digest-dstat-0.6.12
-rw-r--r--sys-apps/dstat/files/digest-dstat-0.6.33
5 files changed, 57 insertions, 2 deletions
diff --git a/sys-apps/dstat/ChangeLog b/sys-apps/dstat/ChangeLog
index 60fef23d43dc..0a023c2fae20 100644
--- a/sys-apps/dstat/ChangeLog
+++ b/sys-apps/dstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dstat
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.15 2005/09/09 11:48:17 swegener Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/ChangeLog,v 1.16 2006/07/09 20:37:34 swegener Exp $
+
+*dstat-0.6.3 (09 Jul 2006)
+
+ 09 Jul 2006; Sven Wegener <swegener@gentoo.org> +dstat-0.6.3.ebuild:
+ Version bump.
*dstat-0.6.1 (09 Sep 2005)
*dstat-0.6.0-r1 (09 Sep 2005)
diff --git a/sys-apps/dstat/dstat-0.6.3.ebuild b/sys-apps/dstat/dstat-0.6.3.ebuild
new file mode 100644
index 000000000000..12e13f9982f1
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.6.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.3.ebuild,v 1.1 2006/07/09 20:37:34 swegener Exp $
+
+inherit python
+
+DESCRIPTION="Dstat is a versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python"
+DEPEND=""
+
+src_compile() {
+ true
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO dstat.conf \
+ examples/{mstat,read}.py docs/*.txt \
+ || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+
+ einfo
+ einfo "See the included dstat.conf in the doc directory for"
+ einfo "an example on how to setup a custom /etc/dstat.conf"
+ einfo
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}
diff --git a/sys-apps/dstat/files/digest-dstat-0.6.0-r1 b/sys-apps/dstat/files/digest-dstat-0.6.0-r1
index e3fbc8aba76f..ea5be88c1bbd 100644
--- a/sys-apps/dstat/files/digest-dstat-0.6.0-r1
+++ b/sys-apps/dstat/files/digest-dstat-0.6.0-r1
@@ -1 +1,3 @@
MD5 14f1fa4841a672d0000f906231a51497 dstat-0.6.0.tar.bz2 36169
+RMD160 ae205b79c9b30d5c9702e1dbcad1367dd55662ca dstat-0.6.0.tar.bz2 36169
+SHA256 9bb76fb391e1dcb675a7e197e14773b242d51635467c03ae499cab23b5f2d0f5 dstat-0.6.0.tar.bz2 36169
diff --git a/sys-apps/dstat/files/digest-dstat-0.6.1 b/sys-apps/dstat/files/digest-dstat-0.6.1
index 8760007a0ab6..eab23b009b95 100644
--- a/sys-apps/dstat/files/digest-dstat-0.6.1
+++ b/sys-apps/dstat/files/digest-dstat-0.6.1
@@ -1 +1,3 @@
MD5 bb3d57d91fa6d04e382dc8eea764d044 dstat-0.6.1.tar.bz2 41870
+RMD160 02319553d72f80160a907f08071cb086933ce5a9 dstat-0.6.1.tar.bz2 41870
+SHA256 df15b3ffdaaf5096a031a177cbf8f40971a13c9bcc3cdf68b36f568194a09e0c dstat-0.6.1.tar.bz2 41870
diff --git a/sys-apps/dstat/files/digest-dstat-0.6.3 b/sys-apps/dstat/files/digest-dstat-0.6.3
new file mode 100644
index 000000000000..c56b8033c027
--- /dev/null
+++ b/sys-apps/dstat/files/digest-dstat-0.6.3
@@ -0,0 +1,3 @@
+MD5 a2df5d7fecc0115f8eef84141a068e86 dstat-0.6.3.tar.bz2 48622
+RMD160 22c0dcee9d320feb305a43935b88851d07bc273f dstat-0.6.3.tar.bz2 48622
+SHA256 c053c6a3a804bdaa3d6897775b2d7e4a6d6b3c8299f9c6c8cd04162511030134 dstat-0.6.3.tar.bz2 48622