summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-22 18:46:22 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-22 18:46:22 +0000
commita23619b9111cb8ace096e537f52b9f89cdb9d1fd (patch)
tree58b6ad7cb678ddd9c46482100f530950ab61b7ba /sys-apps/dmapi/dmapi-2.2.9.ebuild
parentBump sys-cluster/pbs-python-3.0.1. #257931. (diff)
downloadgentoo-2-a23619b9111cb8ace096e537f52b9f89cdb9d1fd.tar.gz
gentoo-2-a23619b9111cb8ace096e537f52b9f89cdb9d1fd.tar.bz2
gentoo-2-a23619b9111cb8ace096e537f52b9f89cdb9d1fd.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dmapi/dmapi-2.2.9.ebuild')
-rw-r--r--sys-apps/dmapi/dmapi-2.2.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.9.ebuild b/sys-apps/dmapi/dmapi-2.2.9.ebuild
new file mode 100644
index 000000000000..6f31fec6c997
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-2.2.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-2.2.9.ebuild,v 1.1 2009/02/22 18:46:22 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="XFS data management API library"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/xfsprogs"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf --libexecdir=/usr/$(get_libdir) || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev || die
+ gen_usr_ldscript -a dm
+ prepalldocs
+}