summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-23 11:21:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-23 11:21:42 +0000
commit855850da10496d788e3fb45339e3350c03aed764 (patch)
tree872a10c903461a042cfbf35be5675a7ee497d612 /sys-apps/coreutils
parentVersion bump. (diff)
downloadgentoo-2-855850da10496d788e3fb45339e3350c03aed764.tar.gz
gentoo-2-855850da10496d788e3fb45339e3350c03aed764.tar.bz2
gentoo-2-855850da10496d788e3fb45339e3350c03aed764.zip
Add ~x86-fbsd keyword. Change strategy for non-GNU userlands, instead of prefixing with 'g' (that might collide with other binaries as in FreeBSD), install in /usr/libexec/gnu. Don't force external regex on non-glibc/non-uclibc systems. Remove man pages when on non-GNU userland as they would collide with system's manpages.
(Portage version: 2.1_rc2)
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog9
-rw-r--r--sys-apps/coreutils/coreutils-5.96.ebuild19
2 files changed, 20 insertions, 8 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 19afcc0c2285..700f848fe160 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.170 2006/05/22 22:33:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.171 2006/05/23 11:21:42 flameeyes Exp $
+
+ 23 May 2006; Diego Pettenò <flameeyes@gentoo.org> coreutils-5.96.ebuild:
+ Add ~x86-fbsd keyword. Change strategy for non-GNU userlands, instead of
+ prefixing with 'g' (that might collide with other binaries as in FreeBSD),
+ install in /usr/libexec/gnu. Don't force external regex on
+ non-glibc/non-uclibc systems. Remove man pages when on non-GNU userland as
+ they would collide with system's manpages.
*coreutils-5.96 (22 May 2006)
diff --git a/sys-apps/coreutils/coreutils-5.96.ebuild b/sys-apps/coreutils/coreutils-5.96.ebuild
index be6a36a66ba2..37d906ae0138 100644
--- a/sys-apps/coreutils/coreutils-5.96.ebuild
+++ b/sys-apps/coreutils/coreutils-5.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.96.ebuild,v 1.2 2006/05/23 06:17:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.96.ebuild,v 1.3 2006/05/23 11:21:42 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="acl nls selinux static"
RDEPEND="selinux? ( sys-libs/libselinux )
@@ -63,9 +63,9 @@ src_unpack() {
EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
chmod a+rx tests/sort/sort-mb-tests
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
# a native binary, so let's just install outdated man-pages.
tc-is-cross-compiler && touch man/*.1
# There's no reason for this crap to use the private version
@@ -90,12 +90,14 @@ src_compile() {
local myconf=""
[[ ${USERLAND} == "GNU" ]] \
&& myconf="${myconf} --bindir=/bin" \
- || myconf="${myconf} --program-prefix=g"
+ || myconf="${myconf} --bindir=/usr/libexec/gnu"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] \
+ && myconf="${myconf} --without-included-regex"
use static && append-ldflags -static
econf \
--enable-largefile \
- --without-included-regex \
$(use_enable nls) \
$(use_enable selinux) \
${myconf} \
@@ -144,5 +146,8 @@ src_install() {
for x in * ; do
dosym /bin/${x} /usr/bin/${x}
done
+ else
+ # For now, drop the man pages, collides with the ones of the system.
+ rm -rf ${D}/usr/share/man
fi
}