summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-07 20:56:20 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-07 20:56:20 +0000
commit0e9a99bca755cbd177b05b4b28e783e002e9b464 (patch)
treea02ee749cab607f61c1882e6358a9ca94442992a /sys-apps/console-tools
parentcleanup (diff)
downloadgentoo-2-0e9a99bca755cbd177b05b4b28e783e002e9b464.tar.gz
gentoo-2-0e9a99bca755cbd177b05b4b28e783e002e9b464.tar.bz2
gentoo-2-0e9a99bca755cbd177b05b4b28e783e002e9b464.zip
version bump
Diffstat (limited to 'sys-apps/console-tools')
-rw-r--r--sys-apps/console-tools/ChangeLog8
-rw-r--r--sys-apps/console-tools/console-tools-0.3.2.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/console-tools/ChangeLog b/sys-apps/console-tools/ChangeLog
index 0964830f692f..423254efecda 100644
--- a/sys-apps/console-tools/ChangeLog
+++ b/sys-apps/console-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/console-tools
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/ChangeLog,v 1.8 2003/02/24 22:34:58 dragon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/ChangeLog,v 1.9 2003/03/07 20:56:20 seemant Exp $
+
+*console-tools-0.3.2 (07 Mar 2003)
+
+ 07 Mar 2003; Seemant Kulleen <seemant@gentoo.org>
+ console-tools-0.3.2.ebuild:
+ version bump
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/sys-apps/console-tools/console-tools-0.3.2.ebuild b/sys-apps/console-tools/console-tools-0.3.2.ebuild
new file mode 100644
index 000000000000..5e73debde414
--- /dev/null
+++ b/sys-apps/console-tools/console-tools-0.3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/console-tools/console-tools-0.3.2.ebuild,v 1.1 2003/03/07 20:56:20 seemant Exp $
+
+inherit libtool
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Console and font utilities"
+HOMEPAGE="http://lct.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lct/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ find ./ -name 'Makefile.*' | xargs sed -i "s:doc ::"
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ [ "$DEBUG" ] && myconf="--enable-debugging"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+
+ econf \
+ ${myconf} || die
+ make ${MAKEOPTS} all || die
+}
+
+src_install() {
+ # DESTDIR does not work correct
+ make DESTDIR=${D} install || die
+
+ dodoc BUGS COPYING* CREDITS ChangeLog NEWS README RELEASE TODO
+ docinto txt
+ dodoc doc/*.txt doc/README.*
+ docinto sgml
+ dodoc doc/*.sgml
+ docinto txt/contrib
+ dodoc doc/contrib/*
+ docinto txt/dvorak
+ dodoc doc/dvorak/*
+ docinto txt/file-formats
+ dodoc doc/file-formats/*
+ doman doc/man/*.[1-8]
+}