summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-03 00:14:07 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-03 00:14:07 +0000
commitf5b5b544ce1a2496291dc9757ea7fb7e36765d1d (patch)
tree695f4fa0003230c0612792751b4effb6ae403d92 /sys-apps/busybox
parentAdded latest upstream release to address shared library and API issues (diff)
downloadgentoo-2-f5b5b544ce1a2496291dc9757ea7fb7e36765d1d.tar.gz
gentoo-2-f5b5b544ce1a2496291dc9757ea7fb7e36765d1d.tar.bz2
gentoo-2-f5b5b544ce1a2496291dc9757ea7fb7e36765d1d.zip
Revert some changes while keeping others.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-1.8.2.ebuild73
-rw-r--r--sys-apps/busybox/files/busybox-1.8.2-flags-strip.patch16
3 files changed, 43 insertions, 52 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 56d4e40df1f1..fb39187595c8 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.166 2007/12/02 23:33:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.167 2007/12/03 00:14:07 vapier Exp $
+
+ 03 Dec 2007; Mike Frysinger <vapier@gentoo.org>
+ -files/busybox-1.8.2-flags-strip.patch, busybox-1.8.2.ebuild:
+ Revert some changes while keeping others.
*busybox-1.7.4 (02 Dec 2007)
diff --git a/sys-apps/busybox/busybox-1.8.2.ebuild b/sys-apps/busybox/busybox-1.8.2.ebuild
index 9320fd865857..5b9ac55f8b0a 100644
--- a/sys-apps/busybox/busybox-1.8.2.ebuild
+++ b/sys-apps/busybox/busybox-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.8.2.ebuild,v 1.2 2007/11/30 21:49:34 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.8.2.ebuild,v 1.3 2007/12/03 00:14:07 vapier Exp $
inherit eutils flag-o-matic savedconfig toolchain-funcs
@@ -58,7 +58,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="debug pam static make-symlinks selinux uclibc"
+IUSE="debug make-symlinks pam selinux static"
RESTRICT="test"
DEPEND="selinux? ( sys-libs/libselinux )
@@ -88,18 +88,22 @@ src_unpack() {
# patches go here!
epatch "${FILESDIR}"/busybox-1.7.0-bb.patch
- # set build environment
- MAKE_CONFIG="CROSS_COMPILE=${CHOST}- ARCH=$(tc-arch-kernel) HOSTCC=${CBUILD}-gcc"
-
# work around broken ass powerpc compilers
use ppc64 && append-flags -mminimal-toc
- if ! use uclibc; then
- epatch "${FILESDIR}/${P}-flags-strip.patch"
- sed -i 's:-Wl,--gc-sections::' scripts/trylink
- sed -i '/^#error Aborting compilation./d' applets/applets.c
- fi
+ # flag cleanup
+ sed -i -r \
+ -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
+ Makefile.flags || die
+ sed -i '/^#error Aborting compilation./d' applets/applets.c || die
+ use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
+ cat <<-EOF >> Makefile.flags
+ CROSS_COMPILE := ${CHOST}-
+ HOSTCC := $(tc-getBUILD_CC)
+ SKIP_STRIP = y
+ EOF
# check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
restore_config .config
if [ -f .config ]; then
@@ -107,30 +111,20 @@ src_unpack() {
return 0
else
ewarn "Could not locate user configfile, so we will save a default one"
-
- # setup the config file
- make allyesconfig > /dev/null
- busybox_config_option n DMALLOC
- busybox_config_option n FEATURE_SUID_CONFIG
- busybox_config_option n BUILD_AT_ONCE
- busybox_config_option n BUILD_LIBBUSYBOX
-
- # If these are not set and we are using a uclibc/busybox setup
- # all calls to system() will fail.
- busybox_config_option y FEATURE_SH_IS_ASH
- busybox_config_option n FEATURE_SH_IS_NONE
-
- # default a bunch of uncommon options to off
- for opt in LOCALE_SUPPORT TFTP FTP{GET,PUT} IPCALC TFTP HUSH \
- LASH MSH INETD DPKG RPM2CPIO RPM FOLD LOGNAME OD CRONTAB \
- UUDECODE UUENCODE SULOGIN DC DEBUG_INIT \
- DEBUG_CROND_OPTION FEATURE_UDHCP_DEBUG TASKSET \
- WERROR
- do
- busybox_config_option n ${opt}
- done
fi
+ # setup the config file
+ make allyesconfig > /dev/null
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+ busybox_config_option n BUILD_AT_ONCE
+ busybox_config_option n BUILD_LIBBUSYBOX
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y FEATURE_SH_IS_ASH
+ busybox_config_option n FEATURE_SH_IS_NONE
+
if use static && use pam ; then
ewarn "You cannot have USE='static pam'. Assuming static is more important."
fi
@@ -146,16 +140,25 @@ src_unpack() {
busybox_config_option selinux SELINUX
+ # default a bunch of uncommon options to off
+ for opt in LOCALE_SUPPORT TFTP FTP{GET,PUT} IPCALC TFTP HUSH \
+ LASH MSH INETD DPKG RPM2CPIO RPM FOLD LOGNAME OD CRONTAB \
+ UUDECODE UUENCODE SULOGIN DC DEBUG_YANK_SUSv2 DEBUG_INIT \
+ DEBUG_CROND_OPTION FEATURE_UDHCP_DEBUG TASKSET
+ do
+ busybox_config_option n ${opt}
+ done
+
make oldconfig > /dev/null
}
src_compile() {
unset KBUILD_OUTPUT #88088
- emake busybox ${MAKE_CONFIG} || die "build failed"
+ emake busybox || die "build failed"
if ! use static && ! use pam ; then
mv busybox_unstripped{,.bak}
- emake busybox CONFIG_STATIC=y ${MAKE_CONFIG} || die "static build failed"
+ emake CONFIG_STATIC=y busybox || die "static build failed"
mv busybox_unstripped bb
mv busybox_unstripped{.bak,}
fi
@@ -178,7 +181,7 @@ src_install() {
doins "${FILESDIR}"/mdev-start.sh || die
# bundle up the symlink files for use later
- emake install ${MAKE_CONFIG} || die
+ emake install || die
rm _install/bin/busybox
tar cf busybox-links.tar -C _install . || : #;die
insinto /usr/share/${PN}
diff --git a/sys-apps/busybox/files/busybox-1.8.2-flags-strip.patch b/sys-apps/busybox/files/busybox-1.8.2-flags-strip.patch
deleted file mode 100644
index 64aed46661e9..000000000000
--- a/sys-apps/busybox/files/busybox-1.8.2-flags-strip.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -urNp busybox-1.8.2.org/Makefile.flags busybox-1.8.2/Makefile.flags
---- busybox-1.8.2.org/Makefile.flags 2007-11-10 03:40:54.000000000 +0200
-+++ busybox-1.8.2/Makefile.flags 2007-11-26 12:02:27.000000000 +0200
-@@ -41,12 +41,10 @@ ifneq ($(CONFIG_WERROR),y)
- CFLAGS += $(call cc-option,-Wmissing-prototypes -Wmissing-declarations,)
- endif
-
--CFLAGS += $(call cc-option,-Os -fno-builtin-strlen -finline-limit=0 -fomit-frame-pointer -ffunction-sections -fdata-sections,)
- # -fno-guess-branch-probability: prohibit pseudo-random guessing
- # of branch probabilities (hopefully makes bloatcheck more stable):
- CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
- CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
--CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
-
- # FIXME: These warnings are at least partially to be concerned about and should
- # be fixed..