summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-03-17 02:58:37 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-03-17 02:58:37 +0000
commite5503eebf31594a2646039a89a7715cd9fa26be8 (patch)
tree51dd2280f862ec3a5422a485ac0574471c7e6d23 /sys-apps/busybox
parentInitial Import, especially for dmwaters ;) (Manifest recommit) (diff)
downloadgentoo-2-e5503eebf31594a2646039a89a7715cd9fa26be8.tar.gz
gentoo-2-e5503eebf31594a2646039a89a7715cd9fa26be8.tar.bz2
gentoo-2-e5503eebf31594a2646039a89a7715cd9fa26be8.zip
added devfs use flag thanks to David Bryson <mutex@cryptobackpack.org> in bug #43404
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r2.ebuild28
2 files changed, 24 insertions, 10 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 12c1c2d39b78..ef04be3745d1 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.25 2004/03/05 15:20:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.26 2004/03/17 02:58:37 dragonheart Exp $
+
+ 17 Mar 2004; Daniel Black <dragonheart@gentoo.org> busybox-0.60.5-r2.ebuild:
+ added devfs use flag thanks to David Bryson <mutex@cryptobackpack.org> in bug
+ #43404
*busybox-1.00_pre8 (02 Mar 2004)
diff --git a/sys-apps/busybox/busybox-0.60.5-r2.ebuild b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
index a4defee8a1d4..ddaef3ecc09a 100644
--- a/sys-apps/busybox/busybox-0.60.5-r2.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.3 2004/02/04 00:07:15 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.4 2004/03/17 02:58:37 dragonheart Exp $
inherit flag-o-matic
@@ -12,11 +12,16 @@ HOMEPAGE="http://www.busybox.net"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64 -alpha"
-IUSE="static uclibc diet"
+IUSE="static uclibc diet devfs"
DEPEND="virtual/glibc
- diet? ( dev-libs/dietlibc )"
-RDEPEND="!static? ${DEPEND}"
+ diet? ( dev-libs/dietlibc )
+ >=sys-apps/sed-4"
+
+RDEPEND="!static? (
+ !diet? ( virtual/glibc )
+ diet? ( dev-libs/dietlibc )
+ )"
src_unpack() {
unpack ${A}
@@ -24,15 +29,20 @@ src_unpack() {
# I did not include the msh patch since I don't know if it will
# break stuff, I compile ash anyway, and it's in CVS
+ if [ `use devfs` ]; then
+ einfo "Disabling devfs in busybox"
+ sed -i -e "s:#define.*BB_FEATURE_DEVFS://#define BB_FEATURE_DEVFS:g" \
+ ${S}/Config.h
+ fi
+
# Add support for dietlibc - solar@gentoo.org
- if [ "`use diet`" != "" ]; then
+ if [ `use diet` ]; then
[ "${PV}" == "0.60.5" ] &&
- sed \
+ sed -i \
-e "s://#define.*BB_TTY:#define BB_TTY:g" \
-e "s://#define.*BB_WATCH:#define BB_WATCH:g" \
-e "s:BB_TRACEROUTE:BB_TRACEROUTE_${RANDOM}:g" \
- < ${S}/Config.h > ${S}/Config.h.new &&
- mv ${S}/Config.h{.new,}
+ ${S}/Config.h
[ -f ${FILESDIR}/${PN}-${PV}-dietlibc.diff ] &&
epatch ${FILESDIR}/${PN}-${PV}-dietlibc.diff ||
ewarn "No dietlibc patch found for ${PN}-${PV}"
@@ -50,7 +60,7 @@ src_compile() {
unset CFLAGS
fi
- if [ "`use diet`" != "" ] ; then
+ if [ `use diet` ] ; then
append-flags -D_BSD_SOURCE
emake CC="diet ${CC}" CLFAGS="${CFLAGS}" ${myconf} ||
die "Failed to make diet ${PN}"