summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-09-06 21:26:41 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-09-06 21:26:41 +0000
commit9237d8376a4e584731ea18968fe47ecc76ccc80e (patch)
tree719ceb94dc56b3a6f363e96f23e6fde4eb173b60 /sec-policy
parentMarked ~amd64. (diff)
downloadgentoo-2-9237d8376a4e584731ea18968fe47ecc76ccc80e.tar.gz
gentoo-2-9237d8376a4e584731ea18968fe47ecc76ccc80e.tar.bz2
gentoo-2-9237d8376a4e584731ea18968fe47ecc76ccc80e.zip
new release
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog9
-rw-r--r--sec-policy/selinux-base-policy/files/digest-selinux-base-policy-200409061
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20040906.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index e87ae4ec0f4d..3d0e2eff3c52 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.29 2004/09/06 01:13:57 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.30 2004/09/06 21:26:41 pebenito Exp $
+
+*selinux-base-policy-20040906 (06 Sep 2004)
+
+ 06 Sep 2004; Chris PeBenito <pebenito@gentoo.org>
+ +selinux-base-policy-20040906.ebuild:
+ New release with 1.14 merge, which has policy 18 (fine-grained netlink)
+ features.
05 Sep 2004; Chris PeBenito <pebenito@gentoo.org>
selinux-base-policy-20040225.ebuild, -selinux-base-policy-20040509.ebuild,
diff --git a/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040906 b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040906
new file mode 100644
index 000000000000..52b9b64d8623
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040906
@@ -0,0 +1 @@
+MD5 51494724a78860531984403a4bc047aa selinux-base-policy-20040906.tar.bz2 70966
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20040906.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20040906.ebuild
new file mode 100644
index 000000000000..949ff36810c1
--- /dev/null
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20040906.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20040906.ebuild,v 1.1 2004/09/06 21:26:41 pebenito Exp $
+
+IUSE="build"
+
+inherit eutils
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+DEPEND="build? ( sys-devel/make
+ sys-devel/m4 )"
+RDEPEND="sys-devel/m4
+ sys-devel/make"
+
+S=${WORKDIR}/base-policy
+
+[ -z ${POLICYDIR} ] && POLICYDIR="/etc/security/selinux/src/policy"
+
+# deprecated policies:
+DEPRECATED="domains/program/devfsd.te domains/program/opt.te
+ file_contexts/program/devfsd.fc file_contexts/program/opt.fc
+ file_contexts/users.fc"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ if use build; then
+ # generate a file_contexts
+ dodir ${POLICYDIR}/file_contexts
+ einfo "Ignore the checkpolicy error on the next line."
+ make -C ${S} \
+ FC=${D}/${POLICYDIR}/file_contexts/file_contexts \
+ ${D}/${POLICYDIR}/file_contexts/file_contexts
+
+ [ ! -f ${D}/${POLICYDIR}/file_contexts/file_contexts ] && \
+ die "file_contexts was not generated."
+ else
+ # install full policy
+ dodir /etc/security/selinux/src
+
+ insinto /etc/security
+ doins ${S}/appconfig/*
+
+ cp -a ${S} ${D}/${POLICYDIR}
+ rm -fR ${D}/${POLICYDIR}/appconfig
+ fi
+}
+
+pkg_postinst() {
+ local isdeprecated
+ echo
+ einfo "This is the base policy for SELinux on Gentoo. This policy"
+ einfo "package only covers the applications in the system profile."
+ einfo "More policy may need to be added according to your requirements."
+ echo
+ eerror "It is STRONGLY suggested that you evaluate and merge the"
+ eerror "policy changes. If any of the file contexts (*.fc) have"
+ eerror "changed, you should also relabel."
+ echo
+ ewarn "Please check the Changelog, there may be important information."
+ echo
+ echo
+
+ einfo "Checking for deprecated policy..."
+ for i in $DEPRECATED; do
+ if [ -f "${POLICYDIR}/${i}" ]; then
+ eerror "${POLICYDIR}/${i}"
+ isdeprecated="y"
+ fi
+ done
+ [ "${isdeprecated}" ] && \
+ eerror "The above policy file(s) should be removed if possible." || \
+ einfo "None found."
+
+ ebeep 4
+ epause 4
+}