summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-02-26 14:22:33 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-02-26 14:22:33 +0000
commite5484639b832f2cff311dc83ac397a2c2502fb6d (patch)
tree061a594eec8dc04d01cf2559b010cc6ddfb9a754 /sci-visualization
parentVersion bumped. (diff)
downloadgentoo-2-e5484639b832f2cff311dc83ac397a2c2502fb6d.tar.gz
gentoo-2-e5484639b832f2cff311dc83ac397a2c2502fb6d.tar.bz2
gentoo-2-e5484639b832f2cff311dc83ac397a2c2502fb6d.zip
Added patch to fix problems with failing tests on amd64 (see bug #159653).
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gnuplot/ChangeLog9
-rw-r--r--sci-visualization/gnuplot/files/digest-gnuplot-4.0-r23
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-4.0-filled-arrow.patch41
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.0-r2.ebuild143
4 files changed, 195 insertions, 1 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index a43e28759a05..40c44ea09859 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/gnuplot
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.9 2007/01/17 19:39:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/ChangeLog,v 1.10 2007/02/26 14:22:33 markusle Exp $
+
+*gnuplot-4.0-r2 (26 Feb 2007)
+
+ 26 Feb 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/gnuplot-4.0-filled-arrow.patch, +gnuplot-4.0-r2.ebuild:
+ Added patch to fix problems with failing tests on amd64
+ (see bug #159653).
17 Jan 2007; Fabian Groffen <grobian@gentoo.org> gnuplot-4.0-r1.ebuild,
gnuplot-4.2_rc1.ebuild:
diff --git a/sci-visualization/gnuplot/files/digest-gnuplot-4.0-r2 b/sci-visualization/gnuplot/files/digest-gnuplot-4.0-r2
new file mode 100644
index 000000000000..81d4b623b0c0
--- /dev/null
+++ b/sci-visualization/gnuplot/files/digest-gnuplot-4.0-r2
@@ -0,0 +1,3 @@
+MD5 66258443d9f93cc4f46b147dac33e63a gnuplot-4.0.0.tar.gz 2160918
+RMD160 7b1fc84c161c132c776269b6e9a49abd29251a18 gnuplot-4.0.0.tar.gz 2160918
+SHA256 a77ad7cb08b2551dacbaa0bb02e561fddb6b9f4a0f3d45eb1c38be219955ea48 gnuplot-4.0.0.tar.gz 2160918
diff --git a/sci-visualization/gnuplot/files/gnuplot-4.0-filled-arrow.patch b/sci-visualization/gnuplot/files/gnuplot-4.0-filled-arrow.patch
new file mode 100644
index 000000000000..f20970926355
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-4.0-filled-arrow.patch
@@ -0,0 +1,41 @@
+diff -Naur gnuplot-4.0.0/src/term.c gnuplot-4.0.0-new/src/term.c
+--- gnuplot-4.0.0/src/term.c 2004-04-13 13:24:02.000000000 -0400
++++ gnuplot-4.0.0-new/src/term.c 2007-01-21 12:14:08.000000000 -0500
+@@ -927,7 +927,7 @@
+ ym = (int) (dy2 + backlen * sin( phi + beta ));
+ }
+ #ifdef PM3D
+- if (curr_arrow_headfilled==2) {
++ if (curr_arrow_headfilled==2 && !clip_point(ex,ey)) {
+ /* draw filled forward arrow head */
+ filledhead[0].x = ex + xm;
+ filledhead[0].y = ey + ym;
+@@ -939,7 +939,8 @@
+ filledhead[3].y = ey + y2;
+ filledhead[4].x = ex + xm;
+ filledhead[4].y = ey + ym;
+- (*t->filled_polygon) (5, filledhead);
++ if (t->filled_polygon)
++ (*t->filled_polygon) (5, filledhead);
+ }
+ #endif
+ /* draw outline of forward arrow head */
+@@ -956,7 +957,7 @@
+ }
+ if (head == 2) { /* backward arrow head */
+ #ifdef PM3D
+- if (curr_arrow_headfilled==2) {
++ if (curr_arrow_headfilled==2 && !clip_point(sx,sy)) {
+ /* draw filled backward arrow head */
+ filledhead[0].x = sx - xm;
+ filledhead[0].y = sy - ym;
+@@ -968,7 +969,8 @@
+ filledhead[3].y = sy - y2;
+ filledhead[4].x = sx - xm;
+ filledhead[4].y = sy - ym;
+- (*t->filled_polygon) (5, filledhead);
++ if (t->filled_polygon)
++ (*t->filled_polygon) (5, filledhead);
+ }
+ #endif
+ /* draw outline of backward arrow head */
diff --git a/sci-visualization/gnuplot/gnuplot-4.0-r2.ebuild b/sci-visualization/gnuplot/gnuplot-4.0-r2.ebuild
new file mode 100644
index 000000000000..ef439a5c3483
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-4.0-r2.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.0-r2.ebuild,v 1.1 2007/02/26 14:22:33 markusle Exp $
+
+inherit eutils elisp-common
+
+MY_P="${P}.0"
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
+
+LICENSE="gnuplot"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc emacs gd ggi pdf plotutils png readline svga X xemacs"
+
+DEPEND="
+ xemacs? ( virtual/xemacs )
+ emacs? ( virtual/emacs !app-emacs/gnuplot-mode )
+ pdf? ( media-libs/pdflib )
+ ggi? ( media-libs/libggi )
+ png? ( media-libs/libpng )
+ gd? ( >=media-libs/gd-2 )
+ doc? ( virtual/tetex )
+ X? ( || ( x11-libs/libXaw virtual/x11 ) )
+ svga? ( media-libs/svgalib )
+ readline? ( >=sys-libs/readline-4.2 )
+ plotutils? ( media-libs/plotutils )"
+
+S=${WORKDIR}/${MY_P}
+
+E_SITEFILE="50gnuplot-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/header-order.patch
+ epatch "${FILESDIR}"/pdflib-6-compat.patch
+ epatch "${FILESDIR}"/${P}-filled-arrow.patch
+}
+
+src_compile() {
+ local myconf="--with-gihdir=/usr/share/${PN}/gih"
+
+ myconf="${myconf} $(use_with X x)"
+ myconf="${myconf} $(use_with svga linux-vga)"
+ myconf="${myconf} $(use_with gd)"
+ myconf="${myconf} $(use_with plotutils plot /usr/lib)"
+ myconf="${myconf} $(use_with png png /usr/lib)"
+ myconf="${myconf} $(use_with pdf pdf /usr/lib)"
+
+ use ggi \
+ && myconf="${myconf} --with-ggi=/usr/lib --with-xmi=/usr/lib" \
+ || myconf="${myconf} --without-ggi"
+
+ use readline \
+ && myconf="${myconf} --with-readline=gnu --enable-history-file" \
+ || myconf="${myconf} --with-readline"
+
+ myconf="${myconf} --without-lisp-files"
+
+ # This is a hack to avoid sandbox violations when using the Linux console.
+ # Creating the DVI and PDF tutorials require /dev/svga to build the
+ # example plots.
+ addwrite /dev/svga:/dev/mouse:/dev/tts/0
+
+ econf ${myconf} || die
+ emake || die
+
+ if use doc ; then
+ cd docs
+ make pdf || die
+ cd ../tutorial
+ make pdf || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if use emacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for emacs..."
+ EMACS="emacs" lispdir="/usr/share/emacs/site-lisp/${PN}" econf || die
+ make DESTDIR=${D} install || die
+ make clean
+ cd ..
+
+ # Gentoo emacs site-lisp configuration
+ string="(add-to-list 'load-path \"/usr/share/emacs/site-lisp/${PN}\")"
+ echo -e ";;; Gnuplot site-lisp configuration\n\n${string}\n" > ${E_SITEFILE}
+ sed '/^;; move/,+4 d' lisp/dotemacs >> ${E_SITEFILE}
+ elisp-site-file-install ${E_SITEFILE}
+ fi
+
+ if use xemacs; then
+ cd lisp
+ einfo "Configuring gnuplot-mode for xemacs..."
+ EMACS="xemacs" lispdir="/usr/lib/xemacs/site-packages/${PN}" econf || die
+ make DESTDIR=${D} install || {
+ ewarn "Compiling/installing gnuplot-mode for xemacs has failed."
+ ewarn "I need xemacs-base to be installed before I can compile"
+ ewarn "the gnuplot-mode lisp files for xemacs successfully."
+ ewarn "Please try re-emerging me after app-xemacs/xemacs-base"
+ ewarn "has been successfuly emerged."
+ die
+ }
+ cd ..
+ fi
+
+
+ dodoc BUGS ChangeLog FAQ NEWS PATCHLEVEL PGPKEYS PORTING README* TODO VERSION
+
+ if use doc; then
+ # Demo files
+ insinto /usr/share/${PN}/demo
+ doins demo/*
+ # Manual
+ insinto /usr/share/doc/${PF}/manual
+ doins docs/gnuplot.pdf
+ # Tutorial
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/{tutorial.dvi,tutorial.pdf}
+ # Documentation for making PostScript files
+ insinto /usr/share/doc/${PF}/psdoc
+ doins docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use svga ; then
+ einfo "In order to enable ordinary users to use SVGA console graphics"
+ einfo "gnuplot needs to be set up as setuid root. Please note that"
+ einfo "this is usually considered to be a security hazard."
+ einfo "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}