summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-04-25 04:33:44 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-04-25 04:33:44 +0000
commit4173def38db91e96bc32a721a187ca9a872faa48 (patch)
tree5c357f7a29f7dfb866307986d9fc547e062a7039 /sci-visualization
parentVersion bump and cleanup. Should also fix bug 321399 and bug 290432 (diff)
downloadgentoo-2-4173def38db91e96bc32a721a187ca9a872faa48.tar.gz
gentoo-2-4173def38db91e96bc32a721a187ca9a872faa48.tar.bz2
gentoo-2-4173def38db91e96bc32a721a187ca9a872faa48.zip
Version bump
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/gwyddion/ChangeLog9
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.27.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/sci-visualization/gwyddion/ChangeLog b/sci-visualization/gwyddion/ChangeLog
index ef9b7f7369ae..a328d508d4d5 100644
--- a/sci-visualization/gwyddion/ChangeLog
+++ b/sci-visualization/gwyddion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/gwyddion
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.34 2011/10/17 16:11:33 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/ChangeLog,v 1.35 2012/04/25 04:33:44 bicatali Exp $
+
+*gwyddion-2.27 (25 Apr 2012)
+
+ 25 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org> +gwyddion-2.27.ebuild:
+ Version bump
17 Oct 2011; Justin Lecher <jlec@gentoo.org> ChangeLog:
Cleaned old
diff --git a/sci-visualization/gwyddion/gwyddion-2.27.ebuild b/sci-visualization/gwyddion/gwyddion-2.27.ebuild
new file mode 100644
index 000000000000..80b04a5a8bdf
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.27.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gwyddion/gwyddion-2.27.ebuild,v 1.1 2012/04/25 04:33:44 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+
+inherit eutils fdo-mime gnome2-utils python autotools-utils
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fftw gnome kde nls opengl perl python ruby sourceview xml X"
+
+RDEPEND="media-libs/libpng
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/pango
+ fftw? ( >=sci-libs/fftw-3 )
+ gnome? ( gnome-base/gconf:2 )
+ kde? ( >=kde-base/kdelibs-4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? ( dev-python/pygtk:2 )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.25-libpng15.patch
+}
+
+src_configure() {
+ myeconfargs+=(
+ --disable-desktop-file-update
+ --disable-rpath
+ --enable-library-bloat
+ --enable-plugin-proxy
+ $(use_enable doc gtk-doc)
+ $(use_enable nls)
+ $(use_enable python pygwy)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with ruby)
+ $(use_with fftw fftw3)
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview)
+ $(use_with xml spml)
+ $(use_with X x)
+ $(use_with kde kde4-thumbnailer)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}