summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-19 20:22:38 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-19 20:22:38 +0000
commit8b668c89f498bf9ddef0ed13bdee436a7080f9a9 (patch)
treee886819ee89750019b865e0eb600dabf928768f5 /sci-physics
parents390 stable wrt #294958 (diff)
downloadgentoo-2-8b668c89f498bf9ddef0ed13bdee436a7080f9a9.tar.gz
gentoo-2-8b668c89f498bf9ddef0ed13bdee436a7080f9a9.tar.bz2
gentoo-2-8b668c89f498bf9ddef0ed13bdee436a7080f9a9.zip
Added patch for tests and gcc 4.3, and a fix for random parallel build failures, thanks Xarthisius for his work , bug #301491
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/clhep/ChangeLog9
-rw-r--r--sci-physics/clhep/clhep-2.0.4.5.ebuild14
-rw-r--r--sci-physics/clhep/files/clhep-2.0.4.5-gcc4.3.patch12
3 files changed, 30 insertions, 5 deletions
diff --git a/sci-physics/clhep/ChangeLog b/sci-physics/clhep/ChangeLog
index 99c77e4db591..fa1a49e3e552 100644
--- a/sci-physics/clhep/ChangeLog
+++ b/sci-physics/clhep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/clhep
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.14 2009/12/13 17:51:06 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/ChangeLog,v 1.15 2010/01/19 20:22:38 bicatali Exp $
+
+ 19 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> clhep-2.0.4.5.ebuild,
+ +files/clhep-2.0.4.5-gcc4.3.patch:
+ Added patch for tests and gcc 4.3, and a fix for random parallel build
+ failures, thanks Xarthisius for his work , bug #301491
*clhep-2.0.4.5 (13 Dec 2009)
diff --git a/sci-physics/clhep/clhep-2.0.4.5.ebuild b/sci-physics/clhep/clhep-2.0.4.5.ebuild
index 7d14916faccb..b4a35e8ad0e7 100644
--- a/sci-physics/clhep/clhep-2.0.4.5.ebuild
+++ b/sci-physics/clhep/clhep-2.0.4.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.5.ebuild,v 1.1 2009/12/13 17:51:06 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/clhep/clhep-2.0.4.5.ebuild,v 1.2 2010/01/19 20:22:38 bicatali Exp $
EAPI=2
-inherit autotools
+inherit autotools eutils
DESCRIPTION="High Energy Physics C++ library"
HOMEPAGE="http://www.cern.ch/clhep"
@@ -29,6 +29,14 @@ src_prepare() {
# need to rebuild because original configurations
# have buggy detection
done
+ for d in $(find . -name Makefile.am | xargs grep -l ": %\.cc"); do
+ sed -i \
+ -e 's|: %\.cc|: %\.cc \$(shareddir)|' \
+ -e 's|all-local: \$(shareddir)|all-local: |' \
+ ${d} || die
+ # fixing parallel build
+ done
+ epatch "${FILESDIR}/${P}-gcc4.3.patch"
eautoreconf
}
diff --git a/sci-physics/clhep/files/clhep-2.0.4.5-gcc4.3.patch b/sci-physics/clhep/files/clhep-2.0.4.5-gcc4.3.patch
new file mode 100644
index 000000000000..453c76e0e2e6
--- /dev/null
+++ b/sci-physics/clhep/files/clhep-2.0.4.5-gcc4.3.patch
@@ -0,0 +1,12 @@
+--- 2.0.4.5.orig/CLHEP/Random/test/testBug58950.cc 2009-12-07 18:49:51.000000000 +0000
++++ 2.0.4.5/CLHEP/Random/test/testBug58950.cc 2010-01-19 17:25:07.493351325 +0000
+@@ -9,6 +9,9 @@
+ #include <iostream>
+ #include <stdexcept>
+ #include <cmath>
++#if __GNUC__ >=4 && __GNUC_MINOR__ >=3
++#include <cstdlib>
++#endif
+ #include "CLHEP/Random/RanecuEngine.h"
+ #include "CLHEP/Random/Random.h"
+