summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-08-22 15:55:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-08-22 15:55:41 +0000
commit6dc86ac0541a014f06670190e5782bd0bd8633f8 (patch)
treebd3633b60b04eef8a63b3676b19aeec9febb2b61 /sci-physics
parentInitial commit. Based on ebuild by Michael Stringer in bug #220045 (diff)
downloadgentoo-2-6dc86ac0541a014f06670190e5782bd0bd8633f8.tar.gz
gentoo-2-6dc86ac0541a014f06670190e5782bd0bd8633f8.tar.bz2
gentoo-2-6dc86ac0541a014f06670190e5782bd0bd8633f8.zip
Version bump. Closing bug #231171
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/xfoil/ChangeLog10
-rw-r--r--sci-physics/xfoil/files/xfoil-6.97-overflow.patch22
-rw-r--r--sci-physics/xfoil/xfoil-6.97.ebuild76
3 files changed, 106 insertions, 2 deletions
diff --git a/sci-physics/xfoil/ChangeLog b/sci-physics/xfoil/ChangeLog
index dfc69bf52471..585208f0eabd 100644
--- a/sci-physics/xfoil/ChangeLog
+++ b/sci-physics/xfoil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/xfoil
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.7 2007/09/27 08:12:16 bicatali Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/ChangeLog,v 1.8 2008/08/22 15:55:40 bicatali Exp $
+
+*xfoil-6.97 (22 Aug 2008)
+
+ 22 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/xfoil-6.97-overflow.patch, +xfoil-6.97.ebuild:
+ Version bump. Closing bug #231171
27 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org>
-xfoil-6.94-r1.ebuild, xfoil-6.96.ebuild:
diff --git a/sci-physics/xfoil/files/xfoil-6.97-overflow.patch b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
new file mode 100644
index 000000000000..d86b52a4aaa1
--- /dev/null
+++ b/sci-physics/xfoil/files/xfoil-6.97-overflow.patch
@@ -0,0 +1,22 @@
+--- src/pplot.f.orig 2008-08-21 20:21:08.000000000 +0100
++++ src/pplot.f 2008-08-21 20:21:42.000000000 +0100
+@@ -36,7 +36,7 @@
+ PROGRAM PPLOT
+ INCLUDE 'PPLOT.INC'
+ C
+- LOGICAL ERROR, LGETFN
++ LOGICAL ERROR, LGETFN, LERR
+ REAL RINP(10)
+ REAL CPOLO(NAX,IPTOT,NPX), VPOLO(NAX,2,NPX)
+ C
+--- src/xoper.f.orig 2008-08-22 15:55:27.000000000 +0100
++++ src/xoper.f 2008-08-22 15:53:36.000000000 +0100
+@@ -114,7 +114,7 @@
+ C---- don't try to read integers, since might get integer overflow
+ DO I=1, NINPUT
+ IF(ABS(RINPUT(I)) .GT. 2.1E9) THEN
+- IINPUT(I) = 2**31
++ IINPUT(I) = 1.99**31
+ ELSE
+ IINPUT(I) = INT(RINPUT(I))
+ ENDIF
diff --git a/sci-physics/xfoil/xfoil-6.97.ebuild b/sci-physics/xfoil/xfoil-6.97.ebuild
new file mode 100644
index 000000000000..d04d3f7e769c
--- /dev/null
+++ b/sci-physics/xfoil/xfoil-6.97.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/xfoil/xfoil-6.97.ebuild,v 1.1 2008/08/22 15:55:41 bicatali Exp $
+
+inherit eutils fortran
+
+DESCRIPTION="Design and analysis of subsonic isolated airfoils"
+HOMEPAGE="http://raphael.mit.edu/xfoil/"
+SRC_URI="http://web.mit.edu/drela/Public/web/${PN}/${PN}${PV}.tar.gz
+ doc? ( http://web.mit.edu/drela/Public/web/${PN}/dataflow.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc examples"
+
+DEPEND="x11-libs/libX11"
+
+S="${WORKDIR}/Xfoil"
+FORTRAN="gfortran ifc g77"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/-O3//g' \
+ plotlib/config.make || die "sed plotlib/config.make failed"
+ cat >> plotlib/config.make <<-EOF
+ FC = ${FORTRANC}
+ CFLAGS += ${CFLAGS}
+ FFLAGS += ${FFLAGS:--O2}
+ EOF
+
+ sed -i \
+ -e '/^FC/d' \
+ -e '/^FFLAGS/d' \
+ -e '/^CC/d' \
+ -e 's/^\(FFLOPT .*\)/FFLOPT = $(FFLAGS)/g' \
+ bin/Makefile orrs/bin/Makefile \
+ || die "sed for flags and compilers failed"
+
+ # fix bug #147033
+ [[ ${FORTRANC} == gfortran ]] && \
+ epatch "${FILESDIR}"/${PN}-6.96-gfortran.patch
+ epatch "${FILESDIR}"/${P}-overflow.patch
+ sed -i \
+ -e 's:/var/local/codes/orrs/osmap.dat:/usr/share/xfoil/orrs/osmap.dat:' \
+ orrs/src/osmap.f || die "sed osmap.f failed"
+}
+
+src_compile() {
+ cd "${S}"/orrs/bin
+ emake FLG="${FFLAGS}" FTNLIB="" OS || die "failed to build orrs"
+ cd "${S}"/orrs
+ bin/osgen osmaps_ns.lst
+ cd "${S}"/plotlib
+ emake || die "failed to build plotlib"
+ cd "${S}"/bin
+ for i in xfoil pplot pxplot; do
+ emake \
+ PLTOBJ="../plotlib/libPlt.a" \
+ CFLAGS="${CFLAGS} -DUNDERSCORE" \
+ ${i} || die "failed to build ${i}"
+ done
+}
+
+src_install() {
+ dobin bin/pplot bin/pxplot bin/xfoil || die "dobin failed"
+ insinto /usr/share/xfoil/orrs
+ doins orrs/osm*.dat || die "orrs data install failed"
+ dodoc *.txt README || die "dodoc failed"
+ insinto /usr/share/doc/${PF}/
+ use examples && { doins -r runs || die "examples install failed"; }
+ use doc && { doins "${DISTDIR}"/dataflow.pdf || die "doc install failed"; }
+}