summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-27 18:49:33 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-27 18:49:33 +0000
commit0079f4751d0e7b2f1ce758254906ba5e99fa131f (patch)
tree34e40ec5afb504852caa613c30added67927c89d /sci-physics
parentRemove check for polkit-backend-1 which is now marked as "noinst" in polkit >... (diff)
downloadgentoo-2-0079f4751d0e7b2f1ce758254906ba5e99fa131f.tar.gz
gentoo-2-0079f4751d0e7b2f1ce758254906ba5e99fa131f.tar.bz2
gentoo-2-0079f4751d0e7b2f1ce758254906ba5e99fa131f.zip
Version bump, fixing bug #423311, thanks Jauhien Piatlicki
(Portage version: 2.2.01.20430-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet/ChangeLog8
-rw-r--r--sci-physics/fastjet/fastjet-3.0.2.ebuild46
-rw-r--r--sci-physics/fastjet/fastjet-3.0.3.ebuild (renamed from sci-physics/fastjet/fastjet-3.0.1.ebuild)13
3 files changed, 17 insertions, 50 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
index fc62f87214c7..075d8db73204 100644
--- a/sci-physics/fastjet/ChangeLog
+++ b/sci-physics/fastjet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/fastjet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.2 2012/01/20 00:39:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.3 2012/06/27 18:49:32 bicatali Exp $
+
+*fastjet-3.0.3 (27 Jun 2012)
+
+ 27 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> +fastjet-3.0.3.ebuild,
+ -fastjet-3.0.1.ebuild, -fastjet-3.0.2.ebuild:
+ Version bump, fixing bug #423311, thanks Jauhien Piatlicki
*fastjet-3.0.2 (20 Jan 2012)
diff --git a/sci-physics/fastjet/fastjet-3.0.2.ebuild b/sci-physics/fastjet/fastjet-3.0.2.ebuild
deleted file mode 100644
index e5111520ed29..000000000000
--- a/sci-physics/fastjet/fastjet-3.0.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.2.ebuild,v 1.1 2012/01/20 00:39:52 bicatali Exp $
-
-EAPI=4
-inherit autotools-utils fortran-2 flag-o-matic
-
-DESCRIPTION="Fast implementation of several recombination jet algorithms"
-HOMEPAGE="http://www.fastjet.fr/"
-SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
-
-LICENSE="GPL-2 QPL"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cgal doc examples +plugins static-libs"
-
-RDEPEND="cgal? ( sci-mathematics/cgal )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- plugins? ( virtual/fortran )"
-
-src_configure() {
- use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
- myeconfargs+=(
- $(use_enable cgal)
- $(use_enable plugins allplugins)
- $(use_enable plugins allcxxplugins)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && doxygen Doxyfile
-}
-
-src_install() {
- autotools-utils_src_install
- use doc && dohtml html/*
- if use examples; then
- insinto /usr/share/doc/${PF}
- find example \
- -name Makefile -or Makefile.in -or Makefile.am -delete
- doins -r example/*
- fi
-}
diff --git a/sci-physics/fastjet/fastjet-3.0.1.ebuild b/sci-physics/fastjet/fastjet-3.0.3.ebuild
index fd02fa20ca9f..af987763c162 100644
--- a/sci-physics/fastjet/fastjet-3.0.1.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.1.ebuild,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.3.ebuild,v 1.1 2012/06/27 18:49:32 bicatali Exp $
EAPI=4
+
inherit autotools-utils fortran-2 flag-o-matic
DESCRIPTION="Fast implementation of several recombination jet algorithms"
@@ -19,6 +20,10 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
plugins? ( virtual/fortran )"
+pkg_setup() {
+ use plugins && fortran-2_pkg_setup
+}
+
src_configure() {
use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
myeconfargs+=(
@@ -31,12 +36,14 @@ src_configure() {
src_compile() {
autotools-utils_src_compile
- use doc && doxygen Doxyfile
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
}
src_install() {
autotools-utils_src_install
- use doc && dohtml html/*
+ use doc && dohtml -r html/*
if use examples; then
insinto /usr/share/doc/${PF}
find example \