summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-01-17 19:15:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-01-17 19:15:39 +0000
commit13e9251cd70613472993d12dbc3488dc4218e23f (patch)
treea2c57421c5dd1c5b61761e529c6e6980c1d39a2b /sci-physics/paw
parentBump. Also fix cosmetic bug #219280 that rmmod of a static kernel returns a f... (diff)
downloadgentoo-2-13e9251cd70613472993d12dbc3488dc4218e23f.tar.gz
gentoo-2-13e9251cd70613472993d12dbc3488dc4218e23f.tar.bz2
gentoo-2-13e9251cd70613472993d12dbc3488dc4218e23f.zip
Updated Debian patch. Keyworded amd64-linux and x86-linux
(Portage version: 2.2.01.21580-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics/paw')
-rw-r--r--sci-physics/paw/ChangeLog11
-rw-r--r--sci-physics/paw/metadata.xml4
-rw-r--r--sci-physics/paw/paw-2.14.04-r4.ebuild67
3 files changed, 77 insertions, 5 deletions
diff --git a/sci-physics/paw/ChangeLog b/sci-physics/paw/ChangeLog
index 0cb3231a1376..b242eafe8fb2 100644
--- a/sci-physics/paw/ChangeLog
+++ b/sci-physics/paw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/paw
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.25 2012/10/24 19:43:50 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.26 2013/01/17 19:15:39 bicatali Exp $
+
+*paw-2.14.04-r4 (17 Jan 2013)
+
+ 17 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> +paw-2.14.04-r4.ebuild,
+ metadata.xml:
+ Updated Debian patch. Keyworded amd64-linux and x86-linux
24 Oct 2012; Ulrich Müller <ulm@gentoo.org> paw-2.14.04-r2.ebuild,
paw-2.14.04-r3.ebuild:
@@ -102,4 +108,3 @@
24 Aug 2007; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+paw-2.14.04.ebuild:
Initial import.
-
diff --git a/sci-physics/paw/metadata.xml b/sci-physics/paw/metadata.xml
index d3ab764eea38..9450758ff229 100644
--- a/sci-physics/paw/metadata.xml
+++ b/sci-physics/paw/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-physics</herd>
- <longdescription lang="en">
+<herd>sci-physics</herd>
+<longdescription lang="en">
PAW is an interactive program providing interactive graphical
presentation and statistical and mathematical analysis tools. It is
designed to work on objects familiar to physicists such as histograms,
diff --git a/sci-physics/paw/paw-2.14.04-r4.ebuild b/sci-physics/paw/paw-2.14.04-r4.ebuild
new file mode 100644
index 000000000000..9c3635aa6706
--- /dev/null
+++ b/sci-physics/paw/paw-2.14.04-r4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r4.ebuild,v 1.1 2013/01/17 19:15:39 bicatali Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs fortran-2
+
+DEB_PN=paw
+DEB_PV=${PV}.dfsg.2
+DEB_PR=8
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/paw/index.html"
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.debian.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2 BSD"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-physics/cernlib
+ x11-libs/libXaw
+ >=x11-libs/motif-2.3:0
+ x11-libs/xbae"
+DEPEND="${RDEPEND}
+ dev-lang/cfortran
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+src_prepare() {
+ mv ../debian . && cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
+
+ # fix some path stuff and collision for comis.h,
+ # already installed by cernlib and replace hardcoded fortran compiler
+ sed -i \
+ -e "s:/usr/local:${EROOT}/usr:g" \
+ -e '/comis.h/d' \
+ -e "s/gfortran/$(tc-getFC)/g" \
+ Makefile || die
+
+ einfo "Applying Debian patches"
+ emake -j1 patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ # since we depend on cfortran, do not use the one from cernlib
+ rm src/include/cfortran/cfortran.h || die
+}
+
+src_compile() {
+ VARTEXFONTS="${T}"/fonts
+ emake -j1 cernlib-indep cernlib-arch
+}
+
+src_install() {
+ default
+ cd debian
+ dodoc changelog README.* deadpool.txt copyright
+ newdoc add-ons/README README.add-ons
+}