summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2012-05-21 04:49:12 +0000
committerBenda XU <heroxbd@gentoo.org>2012-05-21 04:49:12 +0000
commit2a5521e017761fe681c8345311fd75419e2b2a5c (patch)
treee2bcdea9d6c69e748b461dbd8976245bd8d83150 /sci-physics/geant-python
parentUpdate dependencies for Zabbix 2.0rc6 per Installation Guide Requirements Doc... (diff)
downloadgentoo-2-2a5521e017761fe681c8345311fd75419e2b2a5c.tar.gz
gentoo-2-2a5521e017761fe681c8345311fd75419e2b2a5c.tar.bz2
gentoo-2-2a5521e017761fe681c8345311fd75419e2b2a5c.zip
fix VisManager c++ signature mismatch, upstream http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1318
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/geant-python')
-rw-r--r--sci-physics/geant-python/ChangeLog9
-rw-r--r--sci-physics/geant-python/files/geant-python-4.9.5-vis-fix.patch31
-rw-r--r--sci-physics/geant-python/geant-python-4.9.5.ebuild6
3 files changed, 42 insertions, 4 deletions
diff --git a/sci-physics/geant-python/ChangeLog b/sci-physics/geant-python/ChangeLog
index a85d39812cb4..d2813f560d1f 100644
--- a/sci-physics/geant-python/ChangeLog
+++ b/sci-physics/geant-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/geant-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant-python/ChangeLog,v 1.2 2012/05/20 17:06:17 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant-python/ChangeLog,v 1.3 2012/05/21 04:49:12 heroxbd Exp $
+
+ 21 May 2012; Benda Xu <heroxbd@gentoo.org>
+ +files/geant-python-4.9.5-vis-fix.patch, files/geant-python-4.9.5-build.patch,
+ files/geant-python-4.9.5-visverbose.patch, geant-python-4.9.5.ebuild,
+ geant-python-4.9.5_p01.ebuild, metadata.xml:
+ fix VisManager c++ signature mismatch, upstream http://bugzilla-
+ geant4.kek.jp/show_bug.cgi?id=1318
20 May 2012; Benda Xu <heroxbd@gentoo.org> +geant-python-4.9.5.ebuild
geant-python-4.9.5_p01.ebuild:
diff --git a/sci-physics/geant-python/files/geant-python-4.9.5-vis-fix.patch b/sci-physics/geant-python/files/geant-python-4.9.5-vis-fix.patch
new file mode 100644
index 000000000000..1826764b2996
--- /dev/null
+++ b/sci-physics/geant-python/files/geant-python-4.9.5-vis-fix.patch
@@ -0,0 +1,31 @@
+fix the C++ signature, upstream http://bugzilla-geant4.kek.jp/show_bug.cgi?id=1318
+diff --git a/source/visualization/pyG4VisManager.cc b/source/visualization/pyG4VisManager.cc
+index 33bb0d4..bbd9e0a 100644
+--- a/source/visualization/pyG4VisManager.cc
++++ b/source/visualization/pyG4VisManager.cc
+@@ -39,7 +39,7 @@ using namespace boost::python;
+ // ====================================================================
+ // wrappers
+ // ====================================================================
+-class PyG4VisManager : public G4VisManager {
++struct PyG4VisManager : G4VisManager, wrapper<G4VisManager> {
+ public:
+ PyG4VisManager() { SetVerboseLevel(quiet); }
+ ~PyG4VisManager() { }
+@@ -62,7 +62,7 @@ void (PyG4VisManager::*f1_SetVerboseLevel)(G4int)
+ = &PyG4VisManager::SetVerboseLevel;
+ void (PyG4VisManager::*f2_SetVerboseLevel)(const G4String&)
+ = &PyG4VisManager::SetVerboseLevel;
+- void (PyG4VisManager::*f3_SetVerboseLevel)(G4VisManager::Verbosity)
++void (PyG4VisManager::*f3_SetVerboseLevel)(G4VisManager::Verbosity)
+ = &PyG4VisManager::SetVerboseLevel;
+
+ }
+@@ -87,6 +87,7 @@ void export_G4VisManager()
+ .def("SetVerboseLevel", f2_SetVerboseLevel)
+ .def("SetVerboseLevel", f3_SetVerboseLevel)
+ .def("GetVerbosity", &PyG4VisManager::GetVerbosity)
++ .staticmethod("GetVerbosity")
+ .def("Initialize", &PyG4VisManager::Initialize)
+ .def("RegisterGraphicsSystem", &PyG4VisManager::RegisterGraphicsSystem)
+ ;
diff --git a/sci-physics/geant-python/geant-python-4.9.5.ebuild b/sci-physics/geant-python/geant-python-4.9.5.ebuild
index 0bb456c0ae8a..71d0c1cf3146 100644
--- a/sci-physics/geant-python/geant-python-4.9.5.ebuild
+++ b/sci-physics/geant-python/geant-python-4.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant-python/geant-python-4.9.5.ebuild,v 1.1 2012/05/20 16:48:17 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant-python/geant-python-4.9.5.ebuild,v 1.2 2012/05/21 04:49:12 heroxbd Exp $
EAPI=4
@@ -27,8 +27,8 @@ src_prepare() {
# DISTDIR and python path patch
epatch "${FILESDIR}"/${PN}-4.9.5-build.patch
- # set to the highest verbose for visManager
- epatch "${FILESDIR}"/${PN}-4.9.5-visverbose.patch
+ # fix the visManager wrapper
+ epatch "${FILESDIR}"/${PN}-4.9.5-vis-fix.patch
# let Geant4 module installed into python sitedir instead of default
sed -i "/G4PY_LIBDIR :=/cG4PY_LIBDIR := $\(DESTDIR\)$(python_get_sitedir)/Geant4" \