summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-29 16:42:46 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-29 16:42:46 +0000
commite76dfe6afe1d5616befdd9c33f1561df09b04762 (patch)
treede6190791876f884a11000f3e7d12b6ad5d0e5a2 /sci-misc
parentVersion bump for security #271786, thanks to Robert Buchholz. (diff)
downloadgentoo-2-e76dfe6afe1d5616befdd9c33f1561df09b04762.tar.gz
gentoo-2-e76dfe6afe1d5616befdd9c33f1561df09b04762.tar.bz2
gentoo-2-e76dfe6afe1d5616befdd9c33f1561df09b04762.zip
Apply patch for cuda detection. Per bug #270292. Thanks to Poly-C for patch.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog7
-rw-r--r--sci-misc/boinc/boinc-6.4.5-r2.ebuild11
-rw-r--r--sci-misc/boinc/files/boinc.init4
3 files changed, 11 insertions, 11 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 676f5e607410..1db5ef72affb 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.64 2009/05/20 17:02:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.65 2009/05/29 16:42:45 scarabeus Exp $
+
+ 29 May 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ boinc-6.4.5-r2.ebuild, files/boinc.init:
+ Apply patch for cuda detection. Per bug #270292. Thanks to Poly-C for
+ patch.
20 May 2009; Tomas Chvatal <scarabeus@gentoo.org> boinc-6.4.5-r2.ebuild:
Move from Education;Science; to Math;Science; Per bug #269858.
diff --git a/sci-misc/boinc/boinc-6.4.5-r2.ebuild b/sci-misc/boinc/boinc-6.4.5-r2.ebuild
index 736d16a5cda5..6222df1eb21a 100644
--- a/sci-misc/boinc/boinc-6.4.5-r2.ebuild
+++ b/sci-misc/boinc/boinc-6.4.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.4.5-r2.ebuild,v 1.2 2009/05/20 17:02:02 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-6.4.5-r2.ebuild,v 1.3 2009/05/29 16:42:45 scarabeus Exp $
#
# Don't forget to keep things in sync with binary boinc package!
@@ -8,7 +8,7 @@
EAPI="2"
-inherit flag-o-matic depend.apache eutils wxwidgets multilib
+inherit flag-o-matic depend.apache eutils wxwidgets
DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
HOMEPAGE="http://boinc.ssl.berkeley.edu/"
@@ -124,12 +124,7 @@ src_install() {
rm "${D}"/usr/bin/ca-bundle.crt
rm -rf "${D}"/etc/
- # initd script needs to be multilib aware
- cp "${FILESDIR}"/${PN}.init "${T}"
- sed -i \
- -e "s:%LIBDIR%:$(get_libdir):g" \
- "${T}"/${PN}.init || die "sed for multilib in init script failed"
- newinitd "${T}"/${PN}.init ${PN}
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
newconfd "${FILESDIR}"/${PN}.conf ${PN}
}
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index 6e31db676682..88bf507201cf 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -30,9 +30,9 @@ generate_logs() {
}
cuda_check() {
- if [[ -f /opt/cuda/%LIBDIR%/libcudart.so ]]; then
+ if [[ -f /opt/cuda/lib/libcudart.so ]]; then
# symlink wont harm :]
- ln -snf /opt/cuda/%LIBDIR%/libcudart.so ${RUNTIMEDIR}/libcudart.so
+ ln -snf /opt/cuda/lib/libcudart.so ${RUNTIMEDIR}/libcudart.so
fi
}