summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-08 05:38:44 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-08 05:38:44 +0000
commit7b7de5dbf2d500edb93611130044d82058c4746d (patch)
tree91926d86ac07ea27253024589c2d3fdda06b87c9 /sci-misc
parentFix slot-deps on gtk+ and other libs (diff)
downloadgentoo-2-7b7de5dbf2d500edb93611130044d82058c4746d.tar.gz
gentoo-2-7b7de5dbf2d500edb93611130044d82058c4746d.tar.bz2
gentoo-2-7b7de5dbf2d500edb93611130044d82058c4746d.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/fitsverify/ChangeLog10
-rw-r--r--sci-misc/fitsverify/fitsverify-20110304.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/sci-misc/fitsverify/ChangeLog b/sci-misc/fitsverify/ChangeLog
index f69051079b94..4d9c387ab6db 100644
--- a/sci-misc/fitsverify/ChangeLog
+++ b/sci-misc/fitsverify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/fitsverify
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/fitsverify/ChangeLog,v 1.1 2010/01/31 21:48:15 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/fitsverify/ChangeLog,v 1.2 2011/03/08 05:38:44 bicatali Exp $
+
+*fitsverify-20110304 (08 Mar 2011)
+
+ 08 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +fitsverify-20110304.ebuild:
+ Version bump
*fitsverify-20100129 (31 Jan 2010)
diff --git a/sci-misc/fitsverify/fitsverify-20110304.ebuild b/sci-misc/fitsverify/fitsverify-20110304.ebuild
new file mode 100644
index 000000000000..eb94dd818835
--- /dev/null
+++ b/sci-misc/fitsverify/fitsverify-20110304.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/fitsverify/fitsverify-20110304.ebuild,v 1.1 2011/03/08 05:38:44 bicatali Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="FITS file format checker"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/fitsverify/"
+SRC_URI="${HOMEPAGE}/${PN}.tar -> ${P}.tar"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-libs/cfitsio-3"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) -DSTANDALONE ${CFLAGS} ${LDFLAGS} $(pkg-config --cflags cfitsio) \
+ ftverify.c fvrf*.c \
+ $(pkg-config --libs cfitsio) -o ${PN} || die "compiled failed"
+}
+
+src_install() {
+ dobin fitsverify || die
+ dodoc README
+}