summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-27 10:18:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-27 10:18:52 +0000
commit7aa318f760e7330bf11f1ce91b54773196cdbcd1 (patch)
tree4df3bf825a55cdc34b9c62889ee9d2e6155aaaf4 /sci-misc
parentHonor C[XX]FLAGS+LDFLAGS, many thanks to jakub in bug #211581 (diff)
downloadgentoo-2-7aa318f760e7330bf11f1ce91b54773196cdbcd1.tar.gz
gentoo-2-7aa318f760e7330bf11f1ce91b54773196cdbcd1.tar.bz2
gentoo-2-7aa318f760e7330bf11f1ce91b54773196cdbcd1.zip
forcing detection of X libraries and include directories, now really fixing bug #205257
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/ncview/ChangeLog10
-rw-r--r--sci-misc/ncview/metadata.xml10
-rw-r--r--sci-misc/ncview/ncview-1.93c.ebuild7
3 files changed, 14 insertions, 13 deletions
diff --git a/sci-misc/ncview/ChangeLog b/sci-misc/ncview/ChangeLog
index ab6bf44fe587..7111518fed37 100644
--- a/sci-misc/ncview/ChangeLog
+++ b/sci-misc/ncview/ChangeLog
@@ -1,14 +1,14 @@
# ChangeLog for sci-misc/ncview
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.11 2008/01/11 09:51:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ChangeLog,v 1.12 2008/02/27 10:18:52 bicatali Exp $
- 11 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> -ncview-1.93b.ebuild,
- ncview-1.93c.ebuild:
- added --with-x, possibly fixing bug #205257
+ 27 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org> ncview-1.93c.ebuild:
+ forcing detection of X libraries and include directories, now really fixing
+ bug #205257
11 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> -ncview-1.93b.ebuild,
ncview-1.93c.ebuild:
- Added libICE dependency (bug #205257), removed older version.
+ added --with-x, possibly fixing bug #205257
*ncview-1.93c (20 Aug 2007)
diff --git a/sci-misc/ncview/metadata.xml b/sci-misc/ncview/metadata.xml
index 195a55b8a3be..a4c406ecfd48 100644
--- a/sci-misc/ncview/metadata.xml
+++ b/sci-misc/ncview/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-Ncview is a visual browser for netCDF format files. Typically you
-would use ncview to get a quick and easy, push-button look at your
-netCDF files. You can view simple movies of the data, view along
-various dimensions, take a look at the actual data values, change
-color maps, invert the data, etc.
+ Ncview is a visual browser for netCDF format files. Typically you
+ would use ncview to get a quick push-button look at your netCDF
+ files. You can view movies of the data, view along various
+ dimensions, take a look at the actual data values, change color
+ maps, invert the data, etc.
</longdescription>
</pkgmetadata>
diff --git a/sci-misc/ncview/ncview-1.93c.ebuild b/sci-misc/ncview/ncview-1.93c.ebuild
index 47e58b3ac187..8f299ca6734a 100644
--- a/sci-misc/ncview/ncview-1.93c.ebuild
+++ b/sci-misc/ncview/ncview-1.93c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ncview-1.93c.ebuild,v 1.2 2008/01/11 09:51:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/ncview/ncview-1.93c.ebuild,v 1.3 2008/02/27 10:18:52 bicatali Exp $
inherit multilib
@@ -21,7 +21,8 @@ DEPEND="sci-libs/netcdf
src_compile() {
# force netpbm (could be a use flag, but worth it?)
econf \
- --with-x \
+ --x-libraries=/usr/$(get_libdir) \
+ --x-include=/usr/include \
--with-libppm \
$(use_with udunits) \
|| die "econf failed"
@@ -45,5 +46,5 @@ src_install() {
install || "emake install failed"
insinto /usr/share/${PN}
doins *.ncmap nc_overlay* || die "doins failed"
- dodoc README README_WISH_LIST RELEASE_NOTES
+ dodoc README README_WISH_LIST RELEASE_NOTES || die
}