summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 16:20:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 16:20:34 +0000
commit396bbc3bab66be6ad19eaefec33eeb34d823a3a2 (patch)
tree4854df35464b89064053d9c27775da381184e88d /sci-misc
parentSet SUPPORT_PYTHON_ABIS (bug #316237). (diff)
downloadgentoo-2-396bbc3bab66be6ad19eaefec33eeb34d823a3a2.tar.gz
gentoo-2-396bbc3bab66be6ad19eaefec33eeb34d823a3a2.tar.bz2
gentoo-2-396bbc3bab66be6ad19eaefec33eeb34d823a3a2.zip
Use Python 2 (bug #316239).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/gato/ChangeLog8
-rw-r--r--sci-misc/gato/gato-0.99c.ebuild36
2 files changed, 32 insertions, 12 deletions
diff --git a/sci-misc/gato/ChangeLog b/sci-misc/gato/ChangeLog
index 9a473ccccf90..55adb1593368 100644
--- a/sci-misc/gato/ChangeLog
+++ b/sci-misc/gato/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/gato
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.11 2008/10/27 12:06:52 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.12 2010/06/04 16:20:34 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ gato-0.99c.ebuild:
+ Use Python 2 (bug #316239).
27 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org>
-files/gato-0.99-python.patch, -files/gato-python2.4-gentoo.patch,
diff --git a/sci-misc/gato/gato-0.99c.ebuild b/sci-misc/gato/gato-0.99c.ebuild
index 3797259fb9b9..94d5b3bd8480 100644
--- a/sci-misc/gato/gato-0.99c.ebuild
+++ b/sci-misc/gato/gato-0.99c.ebuild
@@ -1,25 +1,35 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.4 2008/10/27 12:06:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.5 2010/06/04 16:20:34 arfrever Exp $
-EAPI=2
-inherit python eutils multilib
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+
+inherit eutils python
MY_PN="Gato"
MY_PV=$(echo ${PV} | tr '[:lower:]' '[:upper:]')
DESCRIPTION="Graph Animation Toolbox"
-LICENSE="LGPL-2"
HOMEPAGE="http://gato.sourceforge.net/"
SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz
doc? ( http://gato.sourceforge.net/Download/${MY_PN}-Doc-${MY_PV}.tar.gz )"
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc"
-DEPEND="dev-lang/python[tk]"
-S="${WORKDIR}"/${MY_PN}
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
src_prepare() {
# convert to python >=2.4
@@ -31,10 +41,8 @@ src_prepare() {
}
src_install() {
-
# install python code
- python_version
- local instdir=/usr/$(get_libdir)/python${PYVER}/${PN}
+ local instdir=$(python_get_sitedir)/${PN}
insinto ${instdir}
doins *.py || die "Failed to install python files"
fperms 755 ${instdir}/{Gato,Gred}.py
@@ -50,3 +58,11 @@ src_install() {
use doc && dohtml -r "${WORKDIR}"/Doc/*
}
+
+pkg_postinst() {
+ python_mod_optimize gato
+}
+
+pkg_postrm() {
+ python_mod_cleanup gato
+}