summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-07-15 02:39:54 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-07-15 02:39:54 +0000
commitcf2fd1207a758d177599b67291ddfed7089664ab (patch)
tree614122495a30e3e3b22ef8fc1deb5a7c16002162 /sci-mathematics
parentamd64 stable, bug #231667. Removed dodoc COPYING (diff)
downloadgentoo-2-cf2fd1207a758d177599b67291ddfed7089664ab.tar.gz
gentoo-2-cf2fd1207a758d177599b67291ddfed7089664ab.tar.bz2
gentoo-2-cf2fd1207a758d177599b67291ddfed7089664ab.zip
Ebuild cleanup.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-SENTINEL-4 i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/axiom/ChangeLog6
-rw-r--r--sci-mathematics/axiom/axiom-200805.ebuild28
2 files changed, 20 insertions, 14 deletions
diff --git a/sci-mathematics/axiom/ChangeLog b/sci-mathematics/axiom/ChangeLog
index eac339026e3c..f31ca6624bfb 100644
--- a/sci-mathematics/axiom/ChangeLog
+++ b/sci-mathematics/axiom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/axiom
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.20 2008/07/13 10:52:18 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/ChangeLog,v 1.21 2008/07/15 02:39:54 markusle Exp $
+
+ 15 Jul 2008; Markus Dittrich <markusle@gentoo.org> axiom-200805.ebuild:
+ Ebuild cleanup. Thanks much to <dberkholz@gentoo.org> for pointing
+ out improvements.
13 Jul 2008; Markus Dittrich <markusle@gentoo.org> axiom-200805.ebuild:
Switched linux-info based brk randomization check to a run-time
diff --git a/sci-mathematics/axiom/axiom-200805.ebuild b/sci-mathematics/axiom/axiom-200805.ebuild
index 8f078816887b..bb0882bae254 100644
--- a/sci-mathematics/axiom/axiom-200805.ebuild
+++ b/sci-mathematics/axiom/axiom-200805.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-200805.ebuild,v 1.3 2008/07/13 13:44:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/axiom/axiom-200805.ebuild,v 1.4 2008/07/15 02:39:54 markusle Exp $
inherit eutils multilib flag-o-matic
@@ -24,25 +24,25 @@ DEPEND="virtual/latex-base
S="${WORKDIR}"/${PN}
pkg_setup() {
- # for 2.6.25 kernels and higher we need to have
+ # for 2.6.25 kernels and higher we need to have
# /proc/sys/kernel/randomize_va_space set to somthing other
# than 2, otherwise gcl fails to compile (see bug #186926).
local current_setting=$(/sbin/sysctl kernel.randomize_va_space 2>/dev/null | cut -d' ' -f3)
if [[ ${current_setting} == 2 ]]; then
echo
- eerror "You kernel has brk randomization enabled. This will"
- eerror "cause compilation to fail (see bug #186926). You can"
- eerror "issue:"
+ eerror "Your kernel has brk randomization enabled. This will"
+ eerror "cause axiom to fail to compile *and* run (see bug #186926)."
+ eerror "You can issue:"
eerror
eerror " /sbin/sysctl -w kernel.randomize_va_space=1"
eerror
eerror "as root to turn brk randomization off temporarily."
- eerror "Please remember to turn it back on via"
+ eerror "However, when not using axiom you may want to turn"
+ eerror "brk randomization back on via"
eerror
eerror " /sbin/sysctl -w kernel.randomize_va_space=2"
eerror
- eerror "once axiom is done compiling since turning brk"
- eerror "randomization off results in a less secure kernel."
+ eerror "since it results in a less secure kernel."
die "Kernel brk randomization detected"
fi
}
@@ -65,7 +65,7 @@ src_compile() {
# lots of strict-aliasing badness
append-flags -fno-strict-aliasing
- ./configure || die "Failed to configure"
+ econf || die "Failed to configure"
# use gcl 2.6.7
sed -e "s:GCLVERSION=gcl-2.6.8pre$:GCLVERSION=gcl-2.6.7:" \
-i Makefile.pamphlet Makefile \
@@ -76,15 +76,17 @@ src_compile() {
|| die "Failed to fix libXpm lib paths"
# Let the fun begin...
- AXIOM="${S}"/mnt/linux emake -j1 || die
+ AXIOM="${S}"/mnt/linux emake -j1 || die "emake failed"
}
src_install() {
- make DESTDIR="${D}"/opt/axiom COMMAND="${D}"/opt/axiom/mnt/linux/bin/axiom install \
+ emake DESTDIR="${D}"/opt/axiom COMMAND="${D}"/opt/axiom/mnt/linux/bin/axiom install \
|| die 'Failed to install Axiom!'
- mv "${D}"/opt/axiom/mnt/linux/* "${D}"/opt/axiom
- rm -fr "${D}"/opt/axiom/mnt
+ mv "${D}"/opt/axiom/mnt/linux/* "${D}"/opt/axiom \
+ || die "Failed to mv axiom into its final destination path."
+ rm -fr "${D}"/opt/axiom/mnt \
+ || die "Failed to remove old directory."
dodir /usr/bin
dosym /opt/axiom/bin/axiom /usr/bin/axiom