summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-08-25 01:48:08 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-08-25 01:48:08 +0000
commitf063930a1d213ff2a01421faac400cea94817116 (patch)
tree09f5e589824575abe0f20313ebd90a020d1ee27a /sci-mathematics/qtoctave
parentFix building of Python 2.6.2-r1 with USE=-threads (bug #282518). Fix building... (diff)
downloadgentoo-2-f063930a1d213ff2a01421faac400cea94817116.tar.gz
gentoo-2-f063930a1d213ff2a01421faac400cea94817116.tar.bz2
gentoo-2-f063930a1d213ff2a01421faac400cea94817116.zip
Version bump (see bug #263872).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog7
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index b25cacd81d57..93219ff154d3 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/qtoctave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.5 2009/07/31 13:12:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.6 2009/08/25 01:48:08 markusle Exp $
+
+*qtoctave-0.8.2 (25 Aug 2009)
+
+ 25 Aug 2009; Markus Dittrich <markusle@gentoo.org> +qtoctave-0.8.2.ebuild:
+ Version bump (see bug #263872).
31 Jul 2009; Markus Dittrich <markusle@gentoo.org> qtoctave-0.8.1.ebuild,
+files/qtoctave-0.8.1-gcc4.4.patch:
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
new file mode 100644
index 000000000000..766ae3de5899
--- /dev/null
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.2.ebuild,v 1.1 2009/08/25 01:48:08 markusle Exp $
+
+EAPI="2"
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake-utils
+
+DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
+HOMEPAGE="http://forja.rediris.es/projects/csl-qtoctave/"
+SRC_URI="http://forja.rediris.es/frs/download.php/1383/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-svg:4"
+
+RDEPEND="${DEPEND}
+ >=sci-mathematics/octave-3.0.0"
+
+S="${WORKDIR}"/${P}/${PN}
+
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.1-gcc4.4.patch
+}
+
+src_compile() {
+ mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme.txt news.txt
+}