summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-03-02 13:46:24 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-03-02 13:46:24 +0000
commitd8aa8056ab84934a3f44da4f87829b91100e0e39 (patch)
tree8d2a41a1db3ed7919cb88b79dce7802fe723f9a2 /sci-mathematics/octave
parentStable on ppc wrt bug 211923 (diff)
downloadgentoo-2-d8aa8056ab84934a3f44da4f87829b91100e0e39.tar.gz
gentoo-2-d8aa8056ab84934a3f44da4f87829b91100e0e39.tar.bz2
gentoo-2-d8aa8056ab84934a3f44da4f87829b91100e0e39.zip
Exported VARTEXFONT variable to avoid sandboxviolations by latex (see bug #160015).
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r1.ebuild7
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r2.ebuild5
-rw-r--r--sci-mathematics/octave/octave-2.1.73.ebuild7
4 files changed, 20 insertions, 6 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 246ba2508ccd..b69dc456039b 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.53 2008/02/27 20:30:08 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.54 2008/03/02 13:46:24 markusle Exp $
+
+ 02 Mar 2008; Markus Dittrich <markusle@gentoo.org> octave-2.1.73.ebuild,
+ octave-2.1.73-r1.ebuild, octave-2.1.73-r2.ebuild:
+ Exported VARTEXFONT variable to avoid sandboxviolations by latex (see
+ bug #160015).
27 Feb 2008; Markus Dittrich <markusle@gentoo.org>
octave-2.1.73-r2.ebuild:
diff --git a/sci-mathematics/octave/octave-2.1.73-r1.ebuild b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
index ed67a7b038b0..592f57005c0f 100644
--- a/sci-mathematics/octave/octave-2.1.73-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.7 2007/12/25 01:46:56 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.8 2008/03/02 13:46:24 markusle Exp $
inherit flag-o-matic fortran autotools
@@ -91,6 +91,9 @@ src_compile() {
}
src_install() {
+ # needed to avoid possible sandbox violations by latex
+ export VARTEXFONTS="${T}/fonts"
+
make install DESTDIR="${D}" || die "make install failed"
if use doc; then
octave-install-doc || die "Octave doc install failed"
diff --git a/sci-mathematics/octave/octave-2.1.73-r2.ebuild b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
index ff6107f295d8..0ed6f870ecef 100644
--- a/sci-mathematics/octave/octave-2.1.73-r2.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.6 2008/02/27 20:30:08 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r2.ebuild,v 1.7 2008/03/02 13:46:24 markusle Exp $
inherit flag-o-matic fortran autotools xemacs-elisp-common
@@ -99,6 +99,9 @@ src_compile() {
}
src_install() {
+ # needed to avoid possible sandbox violations by latex
+ export VARTEXFONTS="${T}/fonts"
+
make install DESTDIR="${D}" || die "make install failed"
if use doc; then
octave-install-doc || die "Octave doc install failed"
diff --git a/sci-mathematics/octave/octave-2.1.73.ebuild b/sci-mathematics/octave/octave-2.1.73.ebuild
index cc6465bd9d99..605c7af333d1 100644
--- a/sci-mathematics/octave/octave-2.1.73.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.9 2007/12/25 01:46:56 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73.ebuild,v 1.10 2008/03/02 13:46:24 markusle Exp $
inherit flag-o-matic fortran
@@ -86,6 +86,9 @@ src_compile() {
}
src_install() {
+ # needed to avoid possible sandbox violations by latex
+ export VARTEXFONTS="${T}/fonts"
+
make install DESTDIR="${D}" || die "make install failed"
if use doc; then
octave-install-doc || die "Octave doc install failed"