summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-09 17:57:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-09 17:57:46 +0000
commitbf04a8679383f8469554154df66d2f9cc83e9575 (patch)
treecaccd45701564bf21a514118a7531a93abc213b7 /sci-mathematics/octave-epstk
parentVersion bump. Install standalone.py as viewvc-standalone-server (bug #349881). (diff)
downloadgentoo-2-bf04a8679383f8469554154df66d2f9cc83e9575.tar.gz
gentoo-2-bf04a8679383f8469554154df66d2f9cc83e9575.tar.bz2
gentoo-2-bf04a8679383f8469554154df66d2f9cc83e9575.zip
Version bump. Initial import to the main tree
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave-epstk')
-rw-r--r--sci-mathematics/octave-epstk/ChangeLog29
-rw-r--r--sci-mathematics/octave-epstk/metadata.xml11
-rw-r--r--sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild40
3 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/octave-epstk/ChangeLog b/sci-mathematics/octave-epstk/ChangeLog
new file mode 100644
index 000000000000..0f84ff58e816
--- /dev/null
+++ b/sci-mathematics/octave-epstk/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for sci-mathematics/octave-epstk
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-epstk/ChangeLog,v 1.1 2011/03/09 17:57:46 bicatali Exp $
+
+*octave-epstk-2.3 (09 Mar 2011)
+
+ 09 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +octave-epstk-2.3.ebuild, +metadata.xml:
+ Version bump. Initial import to the main tree
+
+*octave-epstk-2.2 (13 Jan 2010)
+
+ 13 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -octave-epstk-2.1.ebuild, -files/octave-epstk-2.1_PATCH1.patch,
+ +octave-epstk-2.2.ebuild, metadata.xml:
+ Bump. Now based on Debian modifications
+
+ 12 Oct 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ octave-epstk-2.1.ebuild:
+ fix for bug 288586, thanks Juergen Rose for reporting
+ Some QA, rest is commented in the ebuild
+
+*octave-epstk-2.1 (14 Apr 2006)
+
+ 14 Apr 2006; Lucas Chiesa <lucas.chiesa@gmail.com>:
+ +octave-epstk-2.1.ebuild, +metadata.xml, +ChangeLog,
+ +octave-epstk-2.1_PATCH1.patch
+ Initial import. Thanks to Peter Gustafson <petegus@umich.edu>
+ for the ebuild. Closes bug #127475
diff --git a/sci-mathematics/octave-epstk/metadata.xml b/sci-mathematics/octave-epstk/metadata.xml
new file mode 100644
index 000000000000..1e986b205ff0
--- /dev/null
+++ b/sci-mathematics/octave-epstk/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ The epsTk package provides, via a set of functions for octave, a
+ toolkit to create powerful encapsulated postscript (.eps) graphs. Most 2D
+ scientific graphics functions are written. The generated .eps-files are very
+ small and can be imported into other documents without loss of quality.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
new file mode 100644
index 000000000000..962fdc03ba58
--- /dev/null
+++ b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild,v 1.1 2011/03/09 17:57:46 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DEB_PR=2
+DESCRIPTION="Graphical output functions for Matlab and Octave"
+HOMEPAGE="http://www.epstk.de/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/octave
+ app-text/ghostscript-gpl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local p
+ cd eps*
+ for p in $(cat "${WORKDIR}"/debian/patches/series); do
+ epatch "${WORKDIR}"/debian/patches/${p}
+ done
+}
+
+src_install () {
+ insinto /usr/share/octave/site/m/${PN}
+ doins eps*/m/* || die
+ use doc && dohtml -r eps*/doc/*
+ insinto /etc
+ doins debian/epstk.conf || die
+ dodoc debian/README.Debian debian/changelog
+}