summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2008-04-23 23:19:36 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2008-04-23 23:19:36 +0000
commit7f65adfb4191beb2141e76111b56b43cdf8e2e83 (patch)
tree4cffad5499a30ee95ed0501c88c1c1d33b35ae0a /sci-mathematics/mathomatic
parentVersion bump (fixes bug #199672). (diff)
downloadgentoo-2-7f65adfb4191beb2141e76111b56b43cdf8e2e83.tar.gz
gentoo-2-7f65adfb4191beb2141e76111b56b43cdf8e2e83.tar.bz2
gentoo-2-7f65adfb4191beb2141e76111b56b43cdf8e2e83.zip
Version bump.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-14.0.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index cb2f7c784b76..6a9204bcaa3e 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.28 2008/04/14 13:28:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.29 2008/04/23 23:19:36 cryos Exp $
+
+*mathomatic-14.0.0 (23 Apr 2008)
+
+ 23 Apr 2008; Marcus D. Hanwell <cryos@gentoo.org>
+ +mathomatic-14.0.0.ebuild:
+ Version bump.
14 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
mathomatic-12.8.8.ebuild, mathomatic-12.9.1.ebuild:
diff --git a/sci-mathematics/mathomatic/mathomatic-14.0.0.ebuild b/sci-mathematics/mathomatic/mathomatic-14.0.0.ebuild
new file mode 100644
index 000000000000..50cb71a55385
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-14.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-14.0.0.ebuild,v 1.1 2008/04/23 23:19:36 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+
+src_compile() {
+ # respect user flags
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ -e '/^LDFLAGS/s/+= -lm/:= -lm $(LDFLAGS)/' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic primes/matho-{primes,pascal,sumsq} || die
+ dodoc changes.txt README.txt AUTHORS || die
+ doman mathomatic.1 primes/*.1 || die
+ doicon mathomatic.png || die
+ domenu mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}