summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-02-11 08:54:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-02-11 08:54:56 +0000
commit06626baa80cc2e3a19f5c2b835101be733b198d4 (patch)
tree7096de647ebcdca501921022af5c41aad9c3563d /sci-mathematics/glpk/glpk-4.9.ebuild
parentStable on ppc64: bug #122307 (diff)
downloadgentoo-2-06626baa80cc2e3a19f5c2b835101be733b198d4.tar.gz
gentoo-2-06626baa80cc2e3a19f5c2b835101be733b198d4.tar.bz2
gentoo-2-06626baa80cc2e3a19f5c2b835101be733b198d4.zip
Bug #121414, version bump. Also clean up 4.8 ebuild slightly.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sci-mathematics/glpk/glpk-4.9.ebuild')
-rw-r--r--sci-mathematics/glpk/glpk-4.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/glpk-4.9.ebuild b/sci-mathematics/glpk/glpk-4.9.ebuild
new file mode 100644
index 000000000000..a707d27e2618
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.9.ebuild,v 1.1 2006/02/11 08:54:56 robbat2 Exp $
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=sys-devel/gcc-3.2
+ virtual/libc
+ doc? ( virtual/ghostscript )"
+RDEPEND="virtual/libc"
+
+src_compile() {
+ LIBS="${LIBS} -lm" econf --enable-shared || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # INSTALL include some usage docs
+ dodoc AUTHORS ChangeLog INSTALL NEWS README || \
+ die "failed to install docs"
+
+ # 250Kb
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.mod && doins examples/*.tsp || \
+ die "failed to install examples"
+
+ # manual/ is 2.5Mb in size
+ if use doc; then
+ cd "${S}"/doc
+ for i in *.ps; do
+ ps2pdf14 "${i}" || die "failed to convert ps to pdf"
+ done
+ insinto /usr/share/doc/${PF}/manual
+ doins * || die "failed to install manual files"
+ fi
+}