summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 13:00:52 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 13:00:52 +0000
commitfd337ac854fd9976020fd74d17afb70a743d2004 (patch)
treee47dc9fe78b95bb81c827a86231a40d941345fce /sci-libs
parentImport the live ebuild for pyh2o, Python bindings for libh2o. (diff)
downloadgentoo-2-fd337ac854fd9976020fd74d17afb70a743d2004.tar.gz
gentoo-2-fd337ac854fd9976020fd74d17afb70a743d2004.tar.bz2
gentoo-2-fd337ac854fd9976020fd74d17afb70a743d2004.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libh2oxx/ChangeLog7
-rw-r--r--sci-libs/libh2oxx/libh2oxx-9999.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sci-libs/libh2oxx/ChangeLog b/sci-libs/libh2oxx/ChangeLog
index 239face93387..ba428d212045 100644
--- a/sci-libs/libh2oxx/ChangeLog
+++ b/sci-libs/libh2oxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libh2oxx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/ChangeLog,v 1.3 2012/08/31 08:38:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/ChangeLog,v 1.4 2012/12/15 13:00:52 mgorny Exp $
+
+*libh2oxx-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +libh2oxx-9999.ebuild:
+ Import the live ebuild.
31 Aug 2012; Michał Górny <mgorny@gentoo.org> -libh2oxx-0.1.ebuild:
Drop old.
diff --git a/sci-libs/libh2oxx/libh2oxx-9999.ebuild b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
new file mode 100644
index 000000000000..c3120bf40f7a
--- /dev/null
+++ b/sci-libs/libh2oxx/libh2oxx-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/libh2oxx-9999.ebuild,v 1.1 2012/12/15 13:00:52 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="C++ bindings for libh2o"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2oxx/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=sci-libs/libh2o-0.2"
+DEPEND="${RDEPEND}"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}