summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-04-21 21:49:06 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-04-21 21:49:06 +0000
commit61e442071dd0fb71f249634a11bf004706a85613 (patch)
tree0e28e4158e26bdb26ef37b31cd2f40f67cd7c3b2 /sci-libs
parentAdd sse2 to sci-libs/fftw. (diff)
downloadgentoo-2-61e442071dd0fb71f249634a11bf004706a85613.tar.gz
gentoo-2-61e442071dd0fb71f249634a11bf004706a85613.tar.bz2
gentoo-2-61e442071dd0fb71f249634a11bf004706a85613.zip
Add sse2 USE flag, closes bug 83036.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog5
-rw-r--r--sci-libs/fftw/fftw-3.0.1-r1.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 516a5ff423b7..04dbedc70b60 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.9 2005/04/01 17:06:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.10 2005/04/21 21:49:06 cryos Exp $
+
+ 21 Apr 2005; Marcus D. Hanwell <cryos@gentoo.org> fftw-3.0.1-r1.ebuild:
+ Add sse2 USE flag, closes bug 83036.
01 Apr 2005; Aron Griffis <agriffis@gentoo.org> fftw-3.0.1-r1.ebuild:
stable on ia64
diff --git a/sci-libs/fftw/fftw-3.0.1-r1.ebuild b/sci-libs/fftw/fftw-3.0.1-r1.ebuild
index e373f6105e0d..00311409046a 100644
--- a/sci-libs/fftw/fftw-3.0.1-r1.ebuild
+++ b/sci-libs/fftw/fftw-3.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r1.ebuild,v 1.4 2005/04/01 17:06:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r1.ebuild,v 1.5 2005/04/21 21:49:06 cryos Exp $
inherit flag-o-matic eutils gcc
@@ -11,7 +11,7 @@ SRC_URI="http://www.fftw.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="3.0"
KEYWORDS="~alpha amd64 hppa ia64 ~ppc ~ppc-macos ppc64 ~sparc ~x86"
-IUSE="3dnow altivec mpi sse"
+IUSE="3dnow altivec mpi sse sse2"
DEPEND="virtual/libc"
@@ -50,9 +50,11 @@ src_compile() {
#mpi is not a valid flag yet. In this revision it is used merely to block --enable-mpi option
#it might be needed if it is decided that lam is an optional dependence
- if use sse; then
+ if use sse2; then
myconfsingle="$myconfsingle --enable-sse"
myconfdouble="$myconfdouble --enable-sse2"
+ elif use sse; then
+ myconfsingle="$myconfsingle --enable-sse"
elif use 3dnow; then
myconfsingle="$myconfsingle --enable-k7"
fi
@@ -92,8 +94,7 @@ src_install () {
# Install documentation.
cd "${S}-single"
- dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README TODO
- dodoc COPYRIGHT CONVENTIONS
+ dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
cd doc/html
dohtml -r .