summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-04 17:47:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-04 17:47:08 +0000
commit23baa078d7cf92c3cfc0d274c940d18736261145 (patch)
treec8ac393140e2f6f5ff1f83a34565642b10c34c40 /sci-libs
parentStable on ppc wrt bug 204290 (diff)
downloadgentoo-2-23baa078d7cf92c3cfc0d274c940d18736261145.tar.gz
gentoo-2-23baa078d7cf92c3cfc0d274c940d18736261145.tar.bz2
gentoo-2-23baa078d7cf92c3cfc0d274c940d18736261145.zip
Fixed to respect user's CFLAGS. A bit of cleaning, install basic docs.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/shapelib/ChangeLog8
-rw-r--r--sci-libs/shapelib/shapelib-1.2.10-r1.ebuild26
2 files changed, 19 insertions, 15 deletions
diff --git a/sci-libs/shapelib/ChangeLog b/sci-libs/shapelib/ChangeLog
index f5e6152ed4ec..ced1d9baec0f 100644
--- a/sci-libs/shapelib/ChangeLog
+++ b/sci-libs/shapelib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/shapelib
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.8 2007/02/22 01:24:54 jokey Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/ChangeLog,v 1.9 2008/01/04 17:47:08 bicatali Exp $
+
+ 04 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ shapelib-1.2.10-r1.ebuild:
+ Fixed to respect user's CFLAGS. A bit of cleaning, install basic docs.
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
index 87f40e51eeeb..dd4af6d8e417 100644
--- a/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
+++ b/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.1 2006/02/20 00:41:08 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/shapelib/shapelib-1.2.10-r1.ebuild,v 1.2 2008/01/04 17:47:08 bicatali Exp $
inherit eutils toolchain-funcs
@@ -15,25 +15,25 @@ IUSE=""
DEPEND=""
-export MY_LIBDIR=$(get_libdir)
-
src_unpack() {
unpack ${A}
- cd ${S}
- sed \
- -e 's:/usr/local/:${DESTDIR}/usr/:g' \
- -e 's:/usr/lib:/usr/${MY_LIBDIR}:g' \
- -e 's:SHPLIB_VERSION=1.2.9:SHPLIB_VERSION=1.2.10:g' \
- -i Makefile || die
+ sed -i \
+ -e 's:/usr/local/:${DESTDIR}/usr/:g' \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -e 's:SHPLIB_VERSION=1.2.9:SHPLIB_VERSION=1.2.10:g' \
+ -e "s:-g:${CFLAGS}:g" \
+ "${S}"/Makefile || die
}
src_compile() {
emake || die "emake failed"
- make lib || die "make lib failed"
+ emake lib || die "emake lib failed"
}
src_install() {
dobin shp{create,dump,test,add} dbf{create,dump,add} \
- || die "dobin failed"
- make DESTDIR=${D} lib_install || die "lib_install failed"
+ || die "dobin failed"
+ emake DESTDIR="${D}" lib_install || die "emake lib_install failed"
+ dodoc ChangeLog || die
+ dohtml *.html || die
}