summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-03 10:16:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-03 10:16:31 +0000
commit171f748bbc68d385c0f92bba5b642404ec1a14b5 (patch)
tree76d9aea3f660488fb3abc80a2afde52b41504baf /sci-libs
parentCleaning (diff)
downloadgentoo-2-171f748bbc68d385c0f92bba5b642404ec1a14b5.tar.gz
gentoo-2-171f748bbc68d385c0f92bba5b642404ec1a14b5.tar.bz2
gentoo-2-171f748bbc68d385c0f92bba5b642404ec1a14b5.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/minuit/ChangeLog8
-rw-r--r--sci-libs/minuit/files/minuit-5.20.00-gcc43.patch12
-rw-r--r--sci-libs/minuit/metadata.xml10
-rw-r--r--sci-libs/minuit/minuit-5.20.00.ebuild59
4 files changed, 83 insertions, 6 deletions
diff --git a/sci-libs/minuit/ChangeLog b/sci-libs/minuit/ChangeLog
index d7fed290ec9e..dbca73022fc8 100644
--- a/sci-libs/minuit/ChangeLog
+++ b/sci-libs/minuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/minuit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.6 2008/06/01 10:24:45 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.7 2008/07/03 10:16:31 bicatali Exp $
+
+*minuit-5.20.00 (03 Jul 2008)
+
+ 03 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/minuit-5.20.00-gcc43.patch, metadata.xml, +minuit-5.20.00.ebuild:
+ Version bump.
01 Jun 2008; Markus Dittrich <markusle@gentoo.org>
+files/minuit-5.16.00-gcc4.3.patch, minuit-5.16.00.ebuild:
diff --git a/sci-libs/minuit/files/minuit-5.20.00-gcc43.patch b/sci-libs/minuit/files/minuit-5.20.00-gcc43.patch
new file mode 100644
index 000000000000..f19788f12705
--- /dev/null
+++ b/sci-libs/minuit/files/minuit-5.20.00-gcc43.patch
@@ -0,0 +1,12 @@
+--- test/MnSim/GaussRandomGen.h.orig 2008-07-03 11:03:17.000000000 +0100
++++ test/MnSim/GaussRandomGen.h 2008-07-03 11:03:42.000000000 +0100
+@@ -10,7 +10,8 @@
+ #ifndef MN_GaussRandomGen_H_
+ #define MN_GaussRandomGen_H_
+
+-#include <math.h>
++#include <cmath>
++#include <cstdlib>
+
+ namespace ROOT {
+
diff --git a/sci-libs/minuit/metadata.xml b/sci-libs/minuit/metadata.xml
index 95e5125fe32a..b4d71878b525 100644
--- a/sci-libs/minuit/metadata.xml
+++ b/sci-libs/minuit/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>sci</herd>
<longdescription lang="en">
-Minuit provides a C++ library for non-linear optimization,
-and parameter error estimation. Widely used in High Energy Physics,
-originally as a fortran library, it has been entirely re-written from
-scratch in C++. It is now included in ROOT-5 and higher.
-This is the standaloneversion, quick to build and use.
+ Minuit provides a C++ library for non-linear optimization,
+ and parameter error estimation. Widely used in High Energy Physics,
+ originally as a fortran library, it has been entirely re-written from
+ scratch in C++. It is now included in ROOT-5 and higher.
+ This is the stand-alone version, quick to build and use.
</longdescription>
</pkgmetadata>
diff --git a/sci-libs/minuit/minuit-5.20.00.ebuild b/sci-libs/minuit/minuit-5.20.00.ebuild
new file mode 100644
index 000000000000..617e78a84868
--- /dev/null
+++ b/sci-libs/minuit/minuit-5.20.00.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/minuit-5.20.00.ebuild,v 1.1 2008/07/03 10:16:31 bicatali Exp $
+
+inherit eutils
+
+MY_PN=Minuit2
+
+DESCRIPTION="A C++ physics analysis tool for function minimization"
+HOMEPAGE="http://seal.web.cern.ch/seal/MathLibs/Minuit2/html/index.html"
+
+SRC_URI="http://seal.web.cern.ch/seal/MathLibs/${MY_PN}/${MY_PN}-${PV}.tar.gz
+ doc? ( http://seal.cern.ch/documents/minuit/mnusersguide.pdf
+ http://seal.cern.ch/documents/minuit/mntutorial.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # make check only compiles the tests. run them
+ for d in test/Mn*; do
+ cd "${S}"/${d}
+ for t in test_*; do
+ ./${t} || die "${t} failed"
+ done
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/share/doc/${PF}/MnTutorial
+ doins test/MnTutorial/*.{h,cxx}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/mn*.pdf || die "doins failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}