summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-12-06 16:26:11 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-12-06 16:26:11 +0000
commit21bcb1540e468bbdaabbad8ca745064c54b0f2b4 (patch)
tree15caf86a8b94191c0fb866ee56fc9950f0e6c837 /sci-libs/mathgl
parentRespect CC and LDFLAGS, bug #244098 (diff)
downloadgentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.tar.gz
gentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.tar.bz2
gentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.zip
Fixing bug #249627; new USE flag octave.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'sci-libs/mathgl')
-rw-r--r--sci-libs/mathgl/ChangeLog9
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8-fltk.patch20
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8-octave.patch21
-rw-r--r--sci-libs/mathgl/mathgl-1.8-r1.ebuild61
-rw-r--r--sci-libs/mathgl/metadata.xml5
5 files changed, 114 insertions, 2 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index fe34ff2e90db..30a85dd5e1d2 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.1 2008/12/02 16:23:04 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.2 2008/12/06 16:26:11 grozin Exp $
+
+*mathgl-1.8-r1 (06 Dec 2008)
+
+ 06 Dec 2008; Andrey Grozin <grozin@gentoo.org>
+ +files/mathgl-1.8-fltk.patch, +files/mathgl-1.8-octave.patch,
+ metadata.xml, +mathgl-1.8-r1.ebuild:
+ Fixing bug #249627; new USE flag octave.
*mathgl-1.8 (02 Dec 2008)
diff --git a/sci-libs/mathgl/files/mathgl-1.8-fltk.patch b/sci-libs/mathgl/files/mathgl-1.8-fltk.patch
new file mode 100644
index 000000000000..102e13583136
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8-fltk.patch
@@ -0,0 +1,20 @@
+Index: mathgl-1.8/examples/Makefile.am
+===================================================================
+--- mathgl-1.8.orig/examples/Makefile.am
++++ mathgl-1.8/examples/Makefile.am
+@@ -9,11 +9,13 @@ mgl_example_LDADD = $(top_builddir)/mgl/
+ if USE_FLTK
+ bin_PROGRAMS += mgl_fltk_example
+ mgl_fltk_example_SOURCES = fltk_example.cpp
+-mgl_fltk_example_LDADD = $(top_builddir)/widgets/libmgl-fltk.la
++mgl_fltk_example_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
++mgl_fltk_example_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
+
+ check_PROGRAMS += test
+ test_SOURCES = main.cpp
+-test_LDADD = $(top_builddir)/widgets/libmgl-fltk.la
++test_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
++test_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
+ endif
+
+ if USE_GLUT
diff --git a/sci-libs/mathgl/files/mathgl-1.8-octave.patch b/sci-libs/mathgl/files/mathgl-1.8-octave.patch
new file mode 100644
index 000000000000..0ee821b99682
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8-octave.patch
@@ -0,0 +1,21 @@
+Index: mathgl-1.8/configure.ac
+===================================================================
+--- mathgl-1.8.orig/configure.ac
++++ mathgl-1.8/configure.ac
+@@ -231,12 +231,14 @@ AC_ARG_ENABLE(octave,
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-octave) ;;
+ esac],[octave=false])
+ if (test x$langall = xtrue || test x$octave = xtrue) ;then
++ AC_CHECK_PROG([OCTAVE],[octave-config],[octave-config])
+ # find Octave arch
+- OCTAVE=octave
+ AC_MSG_CHECKING([for Octave arch])
+- OCTAVE_ARCH=`$OCTAVE -q --eval 'strcat(octave_config_info("canonical_host_type"), "-", octave_config_info("api_version"))'|sed -e 's/ans = //'`
++ OCTAVE_ARCH=`$OCTAVE -p CANONICAL_HOST_TYPE`-`$OCTAVE -p API_VERSION`
++ OCTAVE_INCFLAGS="-I`$OCTAVE -p OCTINCLUDEDIR`"
+ AC_MSG_RESULT([$OCTAVE_ARCH])
+ AC_SUBST(OCTAVE_ARCH,[$OCTAVE_ARCH])
++ AC_SUBST(OCTAVE_INCFLAGS,[$OCTAVE_INCFLAGS])
+ test_octave=true
+ fi
+ AM_CONDITIONAL(USE_OCTAVE, test x$test_octave = xtrue )
diff --git a/sci-libs/mathgl/mathgl-1.8-r1.ebuild b/sci-libs/mathgl/mathgl-1.8-r1.ebuild
new file mode 100644
index 000000000000..ee579e799a34
--- /dev/null
+++ b/sci-libs/mathgl/mathgl-1.8-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8-r1.ebuild,v 1.1 2008/12/06 16:26:11 grozin Exp $
+EAPI=2
+WX_GTK_VER=2.8
+inherit autotools wxwidgets
+DESCRIPTION="Math Graphics Library"
+IUSE="doc fltk glut hdf5 jpeg octave python qt4 wxwindows"
+HOMEPAGE="http://mathgl.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+RDEPEND="sci-libs/gsl
+ media-libs/libpng
+ virtual/glu
+ glut? ( virtual/glut )
+ fltk? ( x11-libs/fltk )
+ jpeg? ( media-libs/jpeg )
+ hdf5? ( sci-libs/hdf5 )
+ octave? ( sci-mathematics/octave )
+ qt4? ( x11-libs/qt-gui:4 )
+ wxwindows? ( x11-libs/wxGTK:2.8 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/texi2html virtual/texi2dvi )
+ python? ( dev-lang/swig[python] )
+ octave? ( dev-lang/swig[octave] )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-octave.patch
+ epatch "${FILESDIR}"/${P}-fltk.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${ROOT}"usr/share/doc/${PF} \
+ $(use_enable glut) \
+ $(use_enable qt4 qt) \
+ $(use_enable wxwindows wx) \
+ $(use_enable fltk) \
+ $(use_enable jpeg) \
+ $(use_enable hdf5) \
+ $(use_enable python) \
+ $(use_enable octave) \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ # see bug #249627
+ local JOBS
+ use doc && JOBS=-j1
+ emake ${JOBS} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS || die "dodoc failed"
+}
diff --git a/sci-libs/mathgl/metadata.xml b/sci-libs/mathgl/metadata.xml
index 858ebd719418..cd4c771e73ac 100644
--- a/sci-libs/mathgl/metadata.xml
+++ b/sci-libs/mathgl/metadata.xml
@@ -3,8 +3,11 @@
<pkgmetadata>
<herd>sci</herd>
<maintainer>
- <email>grozin@gentoo.org</email>
+ <email>A.G.Grozin@inp.nsk.su</email>
<name>Andrey Grozin</name>
</maintainer>
<longdescription>Math Graphics Library</longdescription>
+ <use>
+ <flag name='octave'>Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
+ </use>
</pkgmetadata>