summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-07-23 06:33:02 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-07-23 06:33:02 +0000
commite5117fee7cd5953ee0f05c2638a6529e95202b4b (patch)
tree294122ab22408ea1589dd32be4741119d277b2ba /sci-libs/gdal
parentadded more local use flags for gdal (diff)
downloadgentoo-2-e5117fee7cd5953ee0f05c2638a6529e95202b4b.tar.gz
gentoo-2-e5117fee7cd5953ee0f05c2638a6529e95202b4b.tar.bz2
gentoo-2-e5117fee7cd5953ee0f05c2638a6529e95202b4b.zip
fixed and updated for use with grass, etc
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/Manifest4
-rw-r--r--sci-libs/gdal/files/digest-gdal-1.2.61
-rw-r--r--sci-libs/gdal/gdal-1.2.6.ebuild128
3 files changed, 132 insertions, 1 deletions
diff --git a/sci-libs/gdal/Manifest b/sci-libs/gdal/Manifest
index baba252f6f81..4508351aba34 100644
--- a/sci-libs/gdal/Manifest
+++ b/sci-libs/gdal/Manifest
@@ -1,4 +1,6 @@
+MD5 dc56f5d75556cdbcd7c4024288ef8fcb metadata.xml 481
+MD5 afc27e8d8a03e2bac017265533a4a0e8 gdal-1.2.6.ebuild 3936
MD5 4823bed30b1b47098e3b92f5a76415d7 ChangeLog 1098
MD5 cffffd06d2205813df3407b5a2fdc341 gdal-1.2.5-r1.ebuild 3209
-MD5 dc56f5d75556cdbcd7c4024288ef8fcb metadata.xml 481
MD5 82ada11f44c42ddedbfa5426ad7991d2 files/digest-gdal-1.2.5-r1 63
+MD5 4d15ffbcc89c38a4e5a7bbbe698207a1 files/digest-gdal-1.2.6 63
diff --git a/sci-libs/gdal/files/digest-gdal-1.2.6 b/sci-libs/gdal/files/digest-gdal-1.2.6
new file mode 100644
index 000000000000..9cfc52edf488
--- /dev/null
+++ b/sci-libs/gdal/files/digest-gdal-1.2.6
@@ -0,0 +1 @@
+MD5 410e581874ce2b94bfa00deb9f2087f6 gdal-1.2.6.tar.gz 4315879
diff --git a/sci-libs/gdal/gdal-1.2.6.ebuild b/sci-libs/gdal/gdal-1.2.6.ebuild
new file mode 100644
index 000000000000..ff7db466478d
--- /dev/null
+++ b/sci-libs/gdal/gdal-1.2.6.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6.ebuild,v 1.1 2005/07/23 06:33:02 nerdboy Exp $
+
+inherit eutils libtool gnuconfig distutils
+
+IUSE="jpeg png geos gif grass jasper netcdf hdf python postgres mysql odbc sqlite ogdi fits debug"
+
+DESCRIPTION="GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE="http://www.remotesensing.org/gdal/index.html"
+SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+# need to get these arches updated on several libs first
+#KEYWORDS="~alpha ~hppa ~ppc64"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ >=media-libs/tiff-3.7.0
+ sci-libs/libgeotiff
+ jpeg? ( media-libs/jpeg )
+ gif? ( media-libs/libungif )
+ png? ( media-libs/libpng )
+ python? ( dev-lang/python )
+ fits? ( sci-libs/cfitsio )
+ ogdi? ( sci-libs/ogdi )
+ || (
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ )
+ || (
+ netcdf? ( sci-libs/netcdf )
+ hdf? ( sci-libs/hdf )
+ )
+ jasper? ( media-libs/jasper )
+ odbc? ( dev-db/unixODBC )
+ geos? ( sci-libs/geos )
+ grass? ( ~sci-geosciences/grass-6.0.0 )
+ sqlite? ( dev-db/sqlite )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize --patch-only
+ gnuconfig_update
+ if useq netcdf && useq hdf; then
+ einfo "Checking is HDF4 compiled with szip..."
+ if grep -c szip /var/db/pkg/sci-libs/hdf-4*/USE; then
+ einfo "Found HDF4 compiled with szip. Nice."
+ else
+ ewarn "HDF4 must be compiled with szip USE flag!"
+ einfo "Emerge HDF with szip USE flag and then emerge GDAL."
+ die "HDF4 not merged with szip use flag"
+ fi
+ fi
+}
+
+src_compile() {
+ distutils_python_version
+ # This package uses old borked automake/autoconf and libtool, so
+ # it doesn't work without ${D} (or with econf and einstall).
+ pkg_conf="--datadir=${D}usr/share/gdal --includedir=${D}usr/include/gdal \
+ --enable-shared --with-gnu-ld --with-pic"
+ [ "${ARCH}" = "x86" ] && pkg_conf="${pkg_conf} --without-libtool"
+ use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
+ $(use_with postgres pg) $(use_with fits cfitsio) \
+ $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
+ $(use_with sqlite) $(use_with jasper) $(use_with odbc)"
+
+ # It can't find this
+ if useq ogdi ; then
+ use_conf="--with-ogdi=/usr/lib ${use_conf}"
+ fi
+
+ if useq gif ; then
+ use_conf="--with-gif=internal ${use_conf}"
+ else
+ use_conf="--with-gif=no ${use_conf}"
+ fi
+
+ if useq debug ; then
+ export CFG=debug
+ fi
+
+ #enable newer Grass support only
+ if useq grass ; then
+ use_conf="--with-grass=/usr/grass60 ${use_conf}"
+ use_conf="--with-libgrass=no ${use_conf}"
+ fi
+
+ if useq python ; then
+ use_conf="--with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
+ ${use_conf}"
+ else
+ use_conf="--with-python=no ${use_conf}"
+ fi
+
+ myconf="${pkg_conf} ${use_conf}"
+
+ ./configure --prefix=${D}usr --exec-prefix=${D}usr \
+ --with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
+ ${myconf}
+
+ # Patch libtool here since it's not created until after configure runs
+ sed -i -e "s:hardcode_into_libs=yes:hardcode_into_libs=no:g" libtool
+ make || die "make failed"
+}
+
+src_install() {
+ # einstall causes sandbox violations on /usr/lib/libgdal.so
+ #einstall || die "einstall failed"
+ make DESTDIR=${D} install
+ dosed "s:${D}usr:/usr:g" /usr/bin/gdal-config
+ dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
+}
+
+pkg_postinst() {
+ einfo "GDAL is most useful with full graphics support enabled via"
+ einfo "USE flags: png, jpeg, and gif. Optional python, fits, ogdi,"
+ einfo "and support for either netcdf or HDF4 is available, as well"
+ einfo "as either mysql or postgres."
+ ewarn
+ einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
+ einfo "Also, this package will check for netcdf before hdf, so if you"
+ einfo "prefer hdf, please emerge hdf with USE=szip prior to emerging"
+ einfo "gdal."
+}