summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-06-09 19:22:52 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-06-09 19:22:52 +0000
commit2e5735b6196440dd7b157b0088e61066b7b6a213 (patch)
treecff081f6f01f96f62897e0c136c0b4f84ed2364d /sci-libs/gdal
parentReplace token ring patch - doh (diff)
downloadgentoo-2-2e5735b6196440dd7b157b0088e61066b7b6a213.tar.gz
gentoo-2-2e5735b6196440dd7b157b0088e61066b7b6a213.tar.bz2
gentoo-2-2e5735b6196440dd7b157b0088e61066b7b6a213.zip
added upstream CVS patch for bug 134498, stable bumps for 1.3.1
(Portage version: 2.1_rc4-r5)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog8
-rw-r--r--sci-libs/gdal/files/gdal-1.3.2-gcc4-stl.patch56
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild4
-rw-r--r--sci-libs/gdal/gdal-1.3.2.ebuild5
4 files changed, 69 insertions, 4 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 0564755ba607..4d7c23ea66e5 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.25 2006/05/26 00:11:02 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.26 2006/06/09 19:22:52 nerdboy Exp $
+
+ 09 Jun 2006; Steve Arnold <nerdboy@gentoo.org>
+ +files/gdal-1.3.2-gcc4-stl.patch, gdal-1.3.2.ebuild, gdal-1.3.1.ebuild:
+ Added upstream CVS patch for bug 134498; thanks to Matteo Spreafico
+ <matteo _at_ fsfe.org> for posting the patch. Stable bump for amd64
+ and ppc (1.3.1).
25 May 2006; Steve Arnold <nerdboy@gentoo.org> gdal-1.3.0-r1.ebuild,
gdal-1.3.1.ebuild, gdal-1.3.2.ebuild:
diff --git a/sci-libs/gdal/files/gdal-1.3.2-gcc4-stl.patch b/sci-libs/gdal/files/gdal-1.3.2-gcc4-stl.patch
new file mode 100644
index 000000000000..331647e0be3e
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.3.2-gcc4-stl.patch
@@ -0,0 +1,56 @@
+--- ogr/ogrsf_frmts/ili/ogrili2layer.cpp 2006-06-08 10:40:06.804746888 +0200
++++ /home/furai/extProjects/Gdal/gdal_unstable/ogr/ogrsf_frmts/ili/ogrili2layer.cpp 2006-06-08 10:35:53.648232528 +0200
+@@ -1,5 +1,5 @@
+ /******************************************************************************
+- * $Id: gdal-1.3.2-gcc4-stl.patch,v 1.1 2006/06/09 19:22:52 nerdboy Exp $
++ * $Id: gdal-1.3.2-gcc4-stl.patch,v 1.1 2006/06/09 19:22:52 nerdboy Exp $
+ *
+ * Project: Interlis 2 Translator
+ * Purpose: Implements OGRILI2Layer class.
+@@ -28,6 +28,9 @@
+ ******************************************************************************
+ *
+ * $Log: gdal-1.3.2-gcc4-stl.patch,v $
+ * Revision 1.1 2006/06/09 19:22:52 nerdboy
+ * added upstream CVS patch for bug 134498, stable bumps for 1.3.1
+ * (Portage version: 2.1_rc4-r5)
+ *
++ * Revision 1.5 2006/06/06 17:49:07 pka
++ * STL compatibility (Bug 1178)
++ *
+ * Revision 1.4 2005/11/21 14:56:31 pka
+ * Fix for call of GetNextFeature without ResetReading (Interlis 2)
+ * Fix for polygonizer crash on Linux with GEOS 2.1.3 (Interlis 1)
+@@ -47,7 +50,7 @@
+ #include "cpl_conv.h"
+ #include "cpl_string.h"
+
+-CPL_CVSID("$Id: gdal-1.3.2-gcc4-stl.patch,v 1.1 2006/06/09 19:22:52 nerdboy Exp $");
++CPL_CVSID("$Id: gdal-1.3.2-gcc4-stl.patch,v 1.1 2006/06/09 19:22:52 nerdboy Exp $");
+
+ /************************************************************************/
+ /* OGRILI2Layer() */
+@@ -73,7 +76,6 @@
+ poFeatureDefn->SetGeomType( eReqType );
+
+ bWriter = bWriterIn;
+- listFeatureIt = 0;
+ }
+
+ /************************************************************************/
+@@ -116,6 +118,7 @@
+
+ OGRErr OGRILI2Layer::SetFeature (OGRFeature *poFeature) {
+ listFeature.push_back(poFeature);
++ if (listFeature.size() == 1) ResetReading();
+ return OGRERR_NONE;
+ }
+
+@@ -132,7 +135,6 @@
+ /************************************************************************/
+
+ OGRFeature *OGRILI2Layer::GetNextFeature() {
+- if (listFeatureIt == 0) listFeatureIt = listFeature.begin();
+ if (listFeatureIt != listFeature.end())
+ return *(listFeatureIt++);
+ return NULL;
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
index 78819a198fbc..83f50f4e9761 100644
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.10 2006/05/26 00:11:02 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.11 2006/06/09 19:22:52 nerdboy Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa ~ppc64"
diff --git a/sci-libs/gdal/gdal-1.3.2.ebuild b/sci-libs/gdal/gdal-1.3.2.ebuild
index bb6df83f5b23..d59ffae9fc4e 100644
--- a/sci-libs/gdal/gdal-1.3.2.ebuild
+++ b/sci-libs/gdal/gdal-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.2.ebuild,v 1.2 2006/05/26 00:11:02 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.2.ebuild,v 1.3 2006/06/09 19:22:52 nerdboy Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
@@ -46,6 +46,9 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-destdir.patch || die "epatch failed"
epatch ${FILESDIR}/${P}-ruby-install.patch || die "epatch failed"
+ if [ $(gcc-major-version) -eq 4 ]; then
+ epatch ${FILESDIR}/${P}-gcc4-stl.patch || die "epatch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then