summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-05-26 00:11:02 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-05-26 00:11:02 +0000
commit1c12db310e96b972e5da375b137925c378db83f4 (patch)
tree024a97ca49bd0e33e43e88459733886b0f6c5926 /sci-libs/gdal
parentrequires ~ppc64 for gdal gml support (diff)
downloadgentoo-2-1c12db310e96b972e5da375b137925c378db83f4.tar.gz
gentoo-2-1c12db310e96b972e5da375b137925c378db83f4.tar.bz2
gentoo-2-1c12db310e96b972e5da375b137925c378db83f4.zip
updated geos dependency for gcc 4; added ~ppc64 to testing versions
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog7
-rw-r--r--sci-libs/gdal/gdal-1.3.0-r1.ebuild9
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild6
-rw-r--r--sci-libs/gdal/gdal-1.3.2.ebuild25
4 files changed, 24 insertions, 23 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index b3b41ae7bbe2..0564755ba607 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.24 2006/05/23 02:09:11 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.25 2006/05/26 00:11:02 nerdboy Exp $
+
+ 25 May 2006; Steve Arnold <nerdboy@gentoo.org> gdal-1.3.0-r1.ebuild,
+ gdal-1.3.1.ebuild, gdal-1.3.2.ebuild:
+ Updated geos dependency for gcc 4; added ~ppc64 to testing versions.
+ See hdf5 ChangeLog for Todo list.
23 May 2006; Steve Arnold <nerdboy@gentoo.org>
+files/gdal-1.3.2-destdir.patch, +files/gdal-1.3.2-ruby-install.patch:
diff --git a/sci-libs/gdal/gdal-1.3.0-r1.ebuild b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
index f9ecfc9259e4..13e2eb88c34f 100644
--- a/sci-libs/gdal/gdal-1.3.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.10 2006/05/22 06:52:51 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.11 2006/05/26 00:11:02 nerdboy Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
-IUSE="jpeg png geos gif jpeg2k netcdf hdf python postgres mysql \
+IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python postgres mysql \
odbc sqlite ogdi fits gml doc debug"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
@@ -27,6 +27,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
fits? ( sci-libs/cfitsio )
ogdi? ( sci-libs/ogdi )
gml? ( dev-libs/xerces-c )
+ hdf5? ( >=sci-libs/hdf5-1.6.4 )
|| (
postgres? ( dev-db/postgresql )
mysql? ( dev-db/mysql )
@@ -37,7 +38,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
)
jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
- geos? ( sci-libs/geos )
+ geos? ( >=sci-libs/geos-2.2.1 )
sqlite? ( >=dev-db/sqlite-3 )
doc? ( app-doc/doxygen )"
@@ -71,7 +72,7 @@ src_compile() {
$(use_with postgres pg) $(use_with fits cfitsio) \
$(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
$(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces)"
+ $(use_with gml xerces) $(use_with hdf5)"
# It can't find this
if useq ogdi ; then
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
index c532ccd44fda..78819a198fbc 100644
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.9 2006/05/22 06:52:51 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.10 2006/05/26 00:11:02 nerdboy Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc x86"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa ~ppc64"
@@ -35,7 +35,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
)
jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
- geos? ( sci-libs/geos )
+ geos? ( >=sci-libs/geos-2.2.1 )
sqlite? ( >=dev-db/sqlite-3 )
doc? ( app-doc/doxygen )"
diff --git a/sci-libs/gdal/gdal-1.3.2.ebuild b/sci-libs/gdal/gdal-1.3.2.ebuild
index 637d844254f7..bb6df83f5b23 100644
--- a/sci-libs/gdal/gdal-1.3.2.ebuild
+++ b/sci-libs/gdal/gdal-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.2.ebuild,v 1.1 2006/05/22 06:52:51 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.2.ebuild,v 1.2 2006/05/26 00:11:02 nerdboy Exp $
inherit eutils libtool gnuconfig distutils toolchain-funcs
@@ -13,12 +13,9 @@ SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa ~ppc64"
-
-#USE_RUBY="1.7"
-#RUBY_ECONF="--with-rubydir=/usr/$(get_libdir)/ruby/site_ruby"
+#KEYWORDS="~alpha ~hppa"
DEPEND=">=sys-libs/zlib-1.1.4
>=media-libs/tiff-3.7.0
@@ -40,7 +37,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
)
jpeg2k? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
- geos? ( sci-libs/geos )
+ geos? ( >=sci-libs/geos-2.2.1 )
sqlite? ( >=dev-db/sqlite-3 )
doc? ( app-doc/doxygen )"
@@ -49,9 +46,6 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-destdir.patch || die "epatch failed"
epatch ${FILESDIR}/${P}-ruby-install.patch || die "epatch failed"
- if [ $(gcc-major-version) -eq 4 ] ; then
- epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
- fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
@@ -84,9 +78,9 @@ src_compile() {
use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
fi
-# if useq mysql ; then
-# use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
-# fi
+ #if useq mysql ; then
+ # use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
+ #fi
if useq gif ; then
use_conf="--with-gif=internal ${use_conf}"
@@ -110,14 +104,15 @@ src_compile() {
econf ${pkg_conf} ${use_conf} || die "econf failed"
# parallel makes fail on the ogr stuff (C++, what can I say?)
- emake || die "emake failed"
+ # also failing with gcc4 in libcsf
+ make || die "make failed"
if useq ruby ; then
cd ${S}/swig
make build || die "make ruby failed"
cd ${S}
fi
if useq doc ; then
- emake docs || die "emake docs failed"
+ make docs || die "make docs failed"
fi
}