summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 21:31:05 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 21:31:05 +0000
commit97d6c4e2d40d28c5f5a68a5dbe18ad3a174efd31 (patch)
tree7d36918c79acd12704568dbee1899748c6a9691e /sci-libs/fcl
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-97d6c4e2d40d28c5f5a68a5dbe18ad3a174efd31.tar.gz
gentoo-2-97d6c4e2d40d28c5f5a68a5dbe18ad3a174efd31.tar.bz2
gentoo-2-97d6c4e2d40d28c5f5a68a5dbe18ad3a174efd31.zip
Convert to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sci-libs/fcl')
-rw-r--r--sci-libs/fcl/ChangeLog9
-rw-r--r--sci-libs/fcl/fcl-0.3.2.ebuild8
-rw-r--r--sci-libs/fcl/fcl-9999.ebuild8
3 files changed, 14 insertions, 11 deletions
diff --git a/sci-libs/fcl/ChangeLog b/sci-libs/fcl/ChangeLog
index 7a11cbdeab91..3cbfe218fe7a 100644
--- a/sci-libs/fcl/ChangeLog
+++ b/sci-libs/fcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fcl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/ChangeLog,v 1.2 2014/12/01 09:06:19 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/ChangeLog,v 1.3 2015/01/29 21:31:05 mgorny Exp $
+
+ 29 Jan 2015; Michał Górny <mgorny@gentoo.org> fcl-0.3.2.ebuild,
+ fcl-9999.ebuild:
+ Convert to CPU_FLAGS_X86.
01 Dec 2014; Alexis Ballier <aballier@gentoo.org> fcl-0.3.2.ebuild,
fcl-9999.ebuild:
@@ -12,4 +16,3 @@
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> +fcl-0.3.2.ebuild,
+fcl-9999.ebuild, +metadata.xml:
initial import, ebuild by me
-
diff --git a/sci-libs/fcl/fcl-0.3.2.ebuild b/sci-libs/fcl/fcl-0.3.2.ebuild
index a7460d2d8bcf..13798cf5d49c 100644
--- a/sci-libs/fcl/fcl-0.3.2.ebuild
+++ b/sci-libs/fcl/fcl-0.3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/fcl-0.3.2.ebuild,v 1.2 2014/12/01 09:06:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/fcl-0.3.2.ebuild,v 1.3 2015/01/29 21:31:05 mgorny Exp $
EAPI=5
@@ -24,7 +24,7 @@ DESCRIPTION="The Flexible Collision Library"
HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
LICENSE="BSD"
SLOT="0"
-IUSE="sse"
+IUSE="cpu_flags_x86_sse"
RDEPEND="
sci-libs/octomap
@@ -41,7 +41,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- "-DFCL_USE_SSE=$(usex sse TRUE FALSE)"
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
)
cmake-utils_src_configure
}
diff --git a/sci-libs/fcl/fcl-9999.ebuild b/sci-libs/fcl/fcl-9999.ebuild
index 19b5effc127b..a6b0df368c7c 100644
--- a/sci-libs/fcl/fcl-9999.ebuild
+++ b/sci-libs/fcl/fcl-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/fcl-9999.ebuild,v 1.2 2014/12/01 09:06:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fcl/fcl-9999.ebuild,v 1.3 2015/01/29 21:31:05 mgorny Exp $
EAPI=5
@@ -24,7 +24,7 @@ DESCRIPTION="The Flexible Collision Library"
HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
LICENSE="BSD"
SLOT="0"
-IUSE="sse"
+IUSE="cpu_flags_x86_sse"
RDEPEND="
sci-libs/octomap
@@ -41,7 +41,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- "-DFCL_USE_SSE=$(usex sse TRUE FALSE)"
+ "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
)
cmake-utils_src_configure
}