summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-03 09:54:08 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-03 09:54:08 +0000
commitb2cc929836da8abdabb6fe3182210e220dedd4ed (patch)
treed149d729303c675295d6f918e407d32daa578509 /sci-libs/cddlib
parentSecurity bump. #455174 (diff)
downloadgentoo-2-b2cc929836da8abdabb6fe3182210e220dedd4ed.tar.gz
gentoo-2-b2cc929836da8abdabb6fe3182210e220dedd4ed.tar.bz2
gentoo-2-b2cc929836da8abdabb6fe3182210e220dedd4ed.zip
sci-libs/cddlib: Version Bump, #455096
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/cddlib')
-rw-r--r--sci-libs/cddlib/ChangeLog10
-rw-r--r--sci-libs/cddlib/cddlib-094g.ebuild44
-rw-r--r--sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch41
-rw-r--r--sci-libs/cddlib/metadata.xml6
4 files changed, 96 insertions, 5 deletions
diff --git a/sci-libs/cddlib/ChangeLog b/sci-libs/cddlib/ChangeLog
index 7c6a31b7b9cf..935611c8eeb5 100644
--- a/sci-libs/cddlib/ChangeLog
+++ b/sci-libs/cddlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cddlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cddlib/ChangeLog,v 1.4 2011/08/13 07:12:13 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cddlib/ChangeLog,v 1.5 2013/02/03 09:54:08 jlec Exp $
+
+*cddlib-094g (03 Feb 2013)
+
+ 03 Feb 2013; Justin Lecher <jlec@gentoo.org> +cddlib-094g.ebuild,
+ +files/cddlib-094g-add-cdd_both_reps-binary.patch, metadata.xml:
+ Version Bump, #455096
13 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> cddlib-094f-r2.ebuild:
Dropped ppc keywords wrt #349167
diff --git a/sci-libs/cddlib/cddlib-094g.ebuild b/sci-libs/cddlib/cddlib-094g.ebuild
new file mode 100644
index 000000000000..6f7940c11438
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094g.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cddlib/cddlib-094g.ebuild,v 1.1 2013/02/03 09:54:08 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="C implementation of the Double Description Method of Motzkin et al."
+HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
+SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-libs/gmp-4.2.2"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+DOCS=( ChangeLog README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-add-cdd_both_reps-binary.patch
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ cp "${FILESDIR}"/cdd_both_reps.c "${S}"/src/ \
+ || die "failed to copy source file"
+ ln -s "${S}"/src/cdd_both_reps.c "${S}"/src-gmp/cdd_both_reps.c \
+ || die "failed to make symbolic link to source file"
+}
+
+src_install() {
+ use doc && DOCS=( ${DOCS[@]} doc/cddlibman.pdf doc/cddlibman.ps )
+
+ autotools-utils_src_install
+}
diff --git a/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch b/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch
new file mode 100644
index 000000000000..3aa5912b7460
--- /dev/null
+++ b/sci-libs/cddlib/files/cddlib-094g-add-cdd_both_reps-binary.patch
@@ -0,0 +1,41 @@
+--- src-gmp/Makefile.am 2009-01-26 09:30:16.000000000 +0000
++++ src-gmp/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2_gmp \
+ testlp1_gmp \
+ testlp2_gmp \
+-testlp3_gmp
++testlp3_gmp \
++cdd_both_reps_gmp
+ #cddmathlink
+
+ scdd_gmp_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_gmp_SOURCES = testlp1.c
+ testlp2_gmp_SOURCES = testlp2.c
+ testlp3_gmp_SOURCES = testlp3.c
++cdd_both_reps_gmp_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src-gmp/libcddgmp.la
+--- src/Makefile.am 2009-01-26 09:30:03.000000000 +0000
++++ src/Makefile.am 2009-10-04 10:36:17.000000000 +0100
+@@ -11,7 +11,8 @@
+ testcdd2 \
+ testlp1 \
+ testlp2 \
+-testlp3
++testlp3 \
++cdd_both_reps
+ #cddmathlink
+
+ scdd_SOURCES = simplecdd.c
+@@ -27,6 +28,7 @@
+ testlp1_SOURCES = testlp1.c
+ testlp2_SOURCES = testlp2.c
+ testlp3_SOURCES = testlp3.c
++cdd_both_reps_SOURCES = cdd_both_reps.c
+ # cddmathlink_SOURCES = cddmathlink.c cddmlio.h cddmlio.c
+
+ LDADD = ../lib-src/libcdd.la
+
diff --git a/sci-libs/cddlib/metadata.xml b/sci-libs/cddlib/metadata.xml
index bd4ad9cac933..2f650f9efbfa 100644
--- a/sci-libs/cddlib/metadata.xml
+++ b/sci-libs/cddlib/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The C-library cddlib is a C implementation of the Double Description
Method of Motzkin et al. for generating all vertices (i.e. extreme points)
and extreme rays of a general convex polyhedron in R^d given by a system
of linear inequalities:
- P = { x=(x1, ..., xd)^T : b - A x >= 0 }
+ P = { x=(x1, ..., xd)^T : b - A x &gt;= 0 }
where A is a given m x d real matrix, b is a given m-vector
and 0 is the m-vector of all zeros.