summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-07-19 14:00:19 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-07-19 14:00:19 +0000
commit6ed435780df123e60d7d0f630da13a340befc13e (patch)
tree46a9eb1913e3be0a94674a82a7a6915d68b52439 /sci-electronics
parentImprove the postinst message, and link to the guide, bug #328671 by Valeo de ... (diff)
downloadgentoo-2-6ed435780df123e60d7d0f630da13a340befc13e.tar.gz
gentoo-2-6ed435780df123e60d7d0f630da13a340befc13e.tar.bz2
gentoo-2-6ed435780df123e60d7d0f630da13a340befc13e.zip
Fix for bug #313359. Thanks Diego for reporting and Xartisius for suggestions. Further fixes for some segfaults
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/pcb/ChangeLog7
-rw-r--r--sci-electronics/pcb/files/pcb-20091103-png.patch20
-rw-r--r--sci-electronics/pcb/pcb-20091103.ebuild16
3 files changed, 39 insertions, 4 deletions
diff --git a/sci-electronics/pcb/ChangeLog b/sci-electronics/pcb/ChangeLog
index 2237bb6b83ae..0af7437556b0 100644
--- a/sci-electronics/pcb/ChangeLog
+++ b/sci-electronics/pcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/pcb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/ChangeLog,v 1.51 2010/02/19 23:37:58 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/ChangeLog,v 1.52 2010/07/19 14:00:19 tomjbe Exp $
+
+ 19 Jul 2010; Thomas Beierlein <tomjbe@gentoo.org> pcb-20091103.ebuild,
+ +files/pcb-20091103-png.patch:
+ Fix for bug #313359. Thanks Diego for reporting and Xartisius for
+ suggestions. Further fixes for some segfaults
*pcb-20091103 (19 Feb 2010)
diff --git a/sci-electronics/pcb/files/pcb-20091103-png.patch b/sci-electronics/pcb/files/pcb-20091103-png.patch
new file mode 100644
index 000000000000..aad951d7b00b
--- /dev/null
+++ b/sci-electronics/pcb/files/pcb-20091103-png.patch
@@ -0,0 +1,20 @@
+--- src/hid/png/png.c.orig 2010-07-19 15:36:17.000000000 +0200
++++ src/hid/png/png.c 2010-07-19 15:37:53.000000000 +0200
+@@ -137,6 +137,8 @@
+ NULL
+ };
+
++#define NUM_FILETYPES (sizeof(filetypes)/sizeof(filetypes[0]) - 1)
++
+ HID_Attribute png_attribute_list[] = {
+ /* other HIDs expect this to be first. */
+ {"outfile", "Graphics output file",
+@@ -176,7 +178,7 @@
+ #define HA_use_alpha 8
+
+ {"format", "Graphics file format",
+- HID_Enum, 0, 0, {2, 0, 0}, filetypes, 0},
++ HID_Enum, 0, 0, {NUM_FILETYPES-1, 0, 0}, filetypes, 0},
+ #define HA_filetype 9
+
+ {"png-bloat", "Amount (in/mm/mil/pix) to add to trace/pad/pin edges (1 = 1/100 mil)",
diff --git a/sci-electronics/pcb/pcb-20091103.ebuild b/sci-electronics/pcb/pcb-20091103.ebuild
index dffce2f7badd..1e58326b3bcb 100644
--- a/sci-electronics/pcb/pcb-20091103.ebuild
+++ b/sci-electronics/pcb/pcb-20091103.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/pcb-20091103.ebuild,v 1.1 2010/02/19 23:37:58 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/pcb/pcb-20091103.ebuild,v 1.2 2010/07/19 14:00:19 tomjbe Exp $
EAPI="2"
-inherit fdo-mime gnome2-utils
+inherit fdo-mime gnome2-utils eutils
DESCRIPTION="GPL Electronic Design Automation: Printed Circuit Board editor"
HOMEPAGE="http://www.gpleda.org/"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/pcb/files/pcb/${P}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="dbus doc gif gtk jpeg m4lib-png motif nelma nls png xrender tk toporouter"
+IUSE="dbus doc gif gtk jpeg m4lib-png motif nelma nls png xrender test tk toporouter"
# toporouter-output USE flag removed for pcb-20091103 (output was disabled always)
# debug USE flag removed for pcb-20091103 (many crashes, should be fixed for next release)
@@ -29,6 +29,10 @@ CDEPEND="gif? ( >=media-libs/gd-2.0.23 )
nls? ( virtual/libintl )
png? ( >=media-libs/gd-2.0.23[png] )
m4lib-png? ( >=media-libs/gd-2.0.23[png] )
+ test? (
+ || ( media-gfx/graphicsmagick[imagemagick] media-gfx/imagemagick )
+ sci-electronics/gerbv
+ )
tk? ( >=dev-lang/tk-8 )"
#toporouter-output? ( x11-libs/cairo )
@@ -60,12 +64,18 @@ src_prepare() {
if use m4lib-png; then
rm -f lib/pcblib-newlib.stamp
fi
+ if ! use png; then
+ sed -i '/^hid_png1/d' tests/tests.list || die
+ fi
sed -i -e 's/example//' -e 's/tutorial//' -e 's/ win32//' Makefile.in || die "sed failed"
sed -i -e 's/DOC=doc/DOC="doc example tutorial"/' configure || die "sed failed"
sed -i -e 's/$(pkgdatadir)/$(docdir)/' {example,tutorial}/Makefile.in || die "sed failed"
# fix bug in pcb-20091103, should be fixed in next release
sed -i -e 's/free (&pd);/free (pd);/' src/hid/lesstif/main.c || die "sed failed"
+
+ # fix segfault during 'pcb -h' if USE=-gif or -jpeg or -png
+ epatch "${FILESDIR}"/${P}-png.patch
}
src_configure() {