summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-04-26 18:07:29 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-04-26 18:07:29 +0000
commit488ccd7056c582dce2b177d008e48facb84e60de (patch)
tree25879cc91f191eb8b3fd5cdfe7a1acf1953b565d /sci-electronics
parentVersion bump for Rails 3.0.7. (diff)
downloadgentoo-2-488ccd7056c582dce2b177d008e48facb84e60de.tar.gz
gentoo-2-488ccd7056c582dce2b177d008e48facb84e60de.tar.bz2
gentoo-2-488ccd7056c582dce2b177d008e48facb84e60de.zip
New ebuild (see bug #241196). Thanks opensource@andmarios.com for providing the starting point.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/irsim/ChangeLog11
-rw-r--r--sci-electronics/irsim/files/irsim-9.7.72-ldflags.patch44
-rw-r--r--sci-electronics/irsim/irsim-9.7.72.ebuild50
-rw-r--r--sci-electronics/irsim/metadata.xml13
4 files changed, 118 insertions, 0 deletions
diff --git a/sci-electronics/irsim/ChangeLog b/sci-electronics/irsim/ChangeLog
new file mode 100644
index 000000000000..0192264b845c
--- /dev/null
+++ b/sci-electronics/irsim/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-electronics/irsim
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/irsim/ChangeLog,v 1.1 2011/04/26 18:07:29 tomjbe Exp $
+
+*irsim-9.7.72 (26 Apr 2011)
+
+ 26 Apr 2011; Thomas Beierlein <tomjbe@gentoo.org> +irsim-9.7.72.ebuild,
+ +files/irsim-9.7.72-ldflags.patch, +metadata.xml:
+ New ebuild (see bug #241196). Thanks opensource@andmarios.com for providing
+ the starting point.
+
diff --git a/sci-electronics/irsim/files/irsim-9.7.72-ldflags.patch b/sci-electronics/irsim/files/irsim-9.7.72-ldflags.patch
new file mode 100644
index 000000000000..d219415eb5e8
--- /dev/null
+++ b/sci-electronics/irsim/files/irsim-9.7.72-ldflags.patch
@@ -0,0 +1,44 @@
+--- tcltk/Makefile.old 2011-04-26 17:40:36.000000000 +0000
++++ tcltk/Makefile 2011-04-26 17:41:05.000000000 +0000
+@@ -26,7 +26,7 @@
+ ${CP} irsimexec $(DESTDIR)${TCLDIR}/irsimexec
+
+ irsimexec: irsimexec.c tclirsim.o
+- ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} irsimexec.c -o irsimexec \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} irsimexec.c -o irsimexec \
+ ${LIBS} ${LIB_SPECS}
+
+ irsim.tcl: irsim.tcl.in
+--- irsim/Makefile.old 2011-04-26 17:46:38.000000000 +0000
++++ irsim/Makefile 2011-04-26 17:47:21.000000000 +0000
+@@ -22,7 +22,7 @@
+ tclirsim${SHDLIB_EXT}: ${EXTRA_LIBS}
+ @echo --- making irsim Tcl library \(tclirsim${SHDLIB_EXT}\)
+ ${RM} tclirsim${SHDLIB_EXT}
+- ${CC} ${CFLAGS} ${CPPFLAGS} -o $@ ${LDDL_FLAGS} ${LD_RUN_PATH} \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o $@ ${LDDL_FLAGS} ${LD_RUN_PATH} \
+ ${EXTRA_LIBS} -lc ${LIBS} ${LD_EXTRA_LIBS}
+
+ $(DESTDIR)${BINDIR}/irsim:
+--- random/Makefile.old 2011-04-26 17:48:46.000000000 +0000
++++ random/Makefile 2011-04-26 17:49:02.000000000 +0000
+@@ -21,7 +21,7 @@
+ random${SHDLIB_EXT}: randwrap.o
+ @echo --- making random Tcl library
+ ${RM} random${SHDLIB_EXT}
+- ${CC} ${CFLAGS} ${CPPFLAGS} -o $@ ${LDDL_FLAGS} randwrap.o \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o $@ ${LDDL_FLAGS} randwrap.o \
+ ${MAC_SHARED} -lc ${LIBS} ${LD_EXTRA_LIBS}
+
+ install-tcl: $(DESTDIR)${TCLDIR}/random${SHDLIB_EXT}
+--- tclsubckt/Makefile.old 2011-04-26 17:50:23.000000000 +0000
++++ tclsubckt/Makefile 2011-04-26 17:50:45.000000000 +0000
+@@ -22,7 +22,7 @@
+ diglib${SHDLIB_EXT}: diglib.o
+ @echo --- making diglib subcircuit shared library
+ ${RM} diglib${SHDLIB_EXT}
+- ${CC} ${CFLAGS} ${CPPFLAGS} -o $@ ${LDDL_FLAGS} diglib.o \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o $@ ${LDDL_FLAGS} diglib.o \
+ ${MAC_SHARED} -lc ${LIBS} ${LD_EXTRA_LIBS}
+
+ install-tcl: $(DESTDIR)${TCLDIR}/diglib${SHDLIB_EXT}
diff --git a/sci-electronics/irsim/irsim-9.7.72.ebuild b/sci-electronics/irsim/irsim-9.7.72.ebuild
new file mode 100644
index 000000000000..7f4119d544ef
--- /dev/null
+++ b/sci-electronics/irsim/irsim-9.7.72.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/irsim/irsim-9.7.72.ebuild,v 1.1 2011/04/26 18:07:29 tomjbe Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="IRSIM is a \"switch-level\" simulator"
+HOMEPAGE="http://opencircuitdesign.com/irsim/"
+SRC_URI="http://opencircuitdesign.com/irsim/archive/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=" dev-lang/tcl
+ dev-lang/tk"
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+src_prepare() {
+ sed -i -e "s: -pg : :" tcltk/Makefile || die
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ # Short-circuit top-level configure script to retain CFLAGS
+ cd scripts
+ CPP="cpp" econf --libdir=/usr/share
+ cd ..
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR=/usr/share/doc/${PF} install || die
+ dodoc README || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You will probably need to add to your ~/.Xdefaults"
+ einfo "the following line:"
+ einfo "irsim.background: black"
+ einfo
+ einfo "This is needed because Gentoo from default sets a"
+ einfo "grey background which makes impossible to see the"
+ einfo "simulation (white line on light gray background)."
+ einfo
+}
diff --git a/sci-electronics/irsim/metadata.xml b/sci-electronics/irsim/metadata.xml
new file mode 100644
index 000000000000..389484aef4c3
--- /dev/null
+++ b/sci-electronics/irsim/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <longdescription>
+ IRSIM is a tool for simulating digital circuits. It is a "switch-level"
+ simulator; that is, it treats transistors as ideal switches. Extracted
+ capacitance and lumped resistance values are used to make the switch a
+ little bit more realistic than the ideal, using the RC time constants
+ to predict the relative timing of events.
+ </longdescription>
+</pkgmetadata>
+