summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-28 09:06:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-28 09:06:22 +0000
commitcc569737e19f519a495dc3a8dca4963097d6cb94 (patch)
treec809fbc818855edfc083cdd97420f03096437563 /sci-chemistry
parentInitial import, new test dependency for dev-ruby/sinatra. (diff)
downloadgentoo-2-cc569737e19f519a495dc3a8dca4963097d6cb94.tar.gz
gentoo-2-cc569737e19f519a495dc3a8dca4963097d6cb94.tar.bz2
gentoo-2-cc569737e19f519a495dc3a8dca4963097d6cb94.zip
Missing instruction for fetch added, Keyworded for ~*-linux, bumped to EAPI=3, LDFLAGS are now respected
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molscript/ChangeLog12
-rw-r--r--sci-chemistry/molscript/files/2.1.2-ldflags.patch22
-rw-r--r--sci-chemistry/molscript/molscript-2.1.2-r1.ebuild62
-rw-r--r--sci-chemistry/molscript/molscript-2.1.2.ebuild10
4 files changed, 102 insertions, 4 deletions
diff --git a/sci-chemistry/molscript/ChangeLog b/sci-chemistry/molscript/ChangeLog
index fbe8819387b4..af2538346939 100644
--- a/sci-chemistry/molscript/ChangeLog
+++ b/sci-chemistry/molscript/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/molscript
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.7 2007/02/20 01:46:09 je_fro Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/ChangeLog,v 1.8 2010/03/28 09:06:22 jlec Exp $
+
+*molscript-2.1.2-r1 (28 Mar 2010)
+
+ 28 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/2.1.2-ldflags.patch, molscript-2.1.2.ebuild,
+ +molscript-2.1.2-r1.ebuild:
+ Missing instruction for fetch added, Keyworded for ~*-linux, bumped to
+ EAPI=3, LDFLAGS are now respected
20 Feb 2007; Jeff Gardner <je_fro@gentoo.org> molscript-2.1.2.ebuild:
Removing old X dep per Bug 167408.
diff --git a/sci-chemistry/molscript/files/2.1.2-ldflags.patch b/sci-chemistry/molscript/files/2.1.2-ldflags.patch
new file mode 100644
index 000000000000..8867bc10a6b5
--- /dev/null
+++ b/sci-chemistry/molscript/files/2.1.2-ldflags.patch
@@ -0,0 +1,22 @@
+diff --git a/Makefile.complete b/Makefile.complete
+index 4ad535a..b565266 100644
+--- a/Makefile.complete
++++ b/Makefile.complete
+@@ -91,7 +91,7 @@ clean:
+
+ #------------------------------------------------------------
+ molscript: $(OBJ) clib/clib.a
+- $(CC) -o molscript $(COPT) $(OBJ) $(YLIB) clib/clib.a \
++ $(CC) $(LDFLAGS) -o molscript $(COPT) $(OBJ) $(YLIB) clib/clib.a \
+ $(GLUTLINK) $(JPEGLINK) $(PNGLINK) $(GIFLINK) $(ZLIBLINK) -lm
+
+ molscript.tab.o: molscript.tab.c molscript.tab.h
+@@ -147,7 +147,7 @@ gif_img.o: gif_img.c gif_img.h global.h graphics.h image.h opengl.h
+
+ #------------------------------------------------------------
+ molauto: molauto.o clib/clib.a
+- $(CC) -o molauto molauto.o clib/clib.a -lm
++ $(CC) $(LDFLAGS) -o molauto molauto.o clib/clib.a -lm
+
+ molauto.o: molauto.c
+
diff --git a/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..0917c932848f
--- /dev/null
+++ b/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2-r1.ebuild,v 1.1 2010/03/28 09:06:22 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Display molecular 3D structures, such as proteins, in both schematic and detailed representations"
+HOMEPAGE="http://www.avatar.se/molscript/"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="glut molscript"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/gd
+ virtual/glut
+ || ( x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+pkg_nofetch() {
+ elog "Please visit ${HOMEPAGE}"
+ elog "and get ${A}."
+ elog "Place it in ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-makefile-shared.patch
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+
+ # Provide glutbitmap.h, because freeglut doesn't have it
+ cp "${FILESDIR}"/glutbitmap.h "${S}"/clib/
+
+ # Stop an incredibly hacky include
+ sed -i -e 's:<../lib/glut/glutbitmap.h>:"glutbitmap.h":g' \
+ "${S}"/clib/ogl_bitmap_character.c
+}
+
+src_compile() {
+ # Prefix of programs it links with
+ export FREEWAREDIR="${EPREFIX}/usr"
+
+ ln -s Makefile.complete Makefile
+
+ emake \
+ CC="$(tc-getCC)" \
+ COPT="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin molscript molauto || die
+ dohtml "${S}"/doc/*.html || die
+}
diff --git a/sci-chemistry/molscript/molscript-2.1.2.ebuild b/sci-chemistry/molscript/molscript-2.1.2.ebuild
index cf436323a443..a0831a71e600 100644
--- a/sci-chemistry/molscript/molscript-2.1.2.ebuild
+++ b/sci-chemistry/molscript/molscript-2.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2.ebuild,v 1.4 2007/02/20 01:46:09 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molscript/molscript-2.1.2.ebuild,v 1.5 2010/03/28 09:06:22 jlec Exp $
inherit toolchain-funcs eutils
@@ -21,6 +21,12 @@ DEPEND="media-libs/jpeg
x11-libs/libX11 )"
RDEPEND="${DEPEND}"
+pkg_nofetch() {
+ elog "Please visit ${HOMEPAGE}"
+ elog "and get ${A}."
+ elog "Place it in ${DISTDIR}"
+}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/fix-makefile-shared.patch