summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-15 11:20:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-15 11:20:06 +0000
commit5d4f880642ace81887a19295715355f08913b85c (patch)
tree805c3d8d87c9bd7598c8983741c6419b581a0462 /sci-chemistry
parentapp-portage/euscan: Bump to python r1 eclasses (diff)
downloadgentoo-2-5d4f880642ace81887a19295715355f08913b85c.tar.gz
gentoo-2-5d4f880642ace81887a19295715355f08913b85c.tar.bz2
gentoo-2-5d4f880642ace81887a19295715355f08913b85c.zip
sci-chemistry/azara: Move to new python r1 eclasses
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/azara/ChangeLog10
-rw-r--r--sci-chemistry/azara/azara-2.8-r5.ebuild97
-rw-r--r--sci-chemistry/azara/metadata.xml10
3 files changed, 110 insertions, 7 deletions
diff --git a/sci-chemistry/azara/ChangeLog b/sci-chemistry/azara/ChangeLog
index bd647e28c02a..1d3902782893 100644
--- a/sci-chemistry/azara/ChangeLog
+++ b/sci-chemistry/azara/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/azara
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.11 2012/02/25 03:04:59 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.12 2013/10/15 11:20:06 jlec Exp $
+
+*azara-2.8-r5 (15 Oct 2013)
+
+ 15 Oct 2013; Justin Lecher <jlec@gentoo.org> +azara-2.8-r5.ebuild,
+ metadata.xml:
+ Move to new python r1 eclasses
25 Feb 2012; Patrick Lauer <patrick@gentoo.org> azara-2.8-r4.ebuild:
Restricting pypy and jython
diff --git a/sci-chemistry/azara/azara-2.8-r5.ebuild b/sci-chemistry/azara/azara-2.8-r5.ebuild
new file mode 100644
index 000000000000..8a0c834ea83f
--- /dev/null
+++ b/sci-chemistry/azara/azara-2.8-r5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.8-r5.ebuild,v 1.1 2013/10/15 11:20:06 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-r1 toolchain-funcs
+
+DESCRIPTION="A suite of programmes to process and view NMR data"
+HOMEPAGE="http://www.bio.cam.ac.uk/azara/"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${PN}/${P}-src.tgz"
+
+LICENSE="AZARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="xpm X"
+
+RDEPEND="
+ x11-libs/libX11
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cat > ENVIRONMENT <<- EOF
+ CC=$(tc-getCC)
+ CFLAGS = ${CFLAGS}
+ LFLAGS = ${LDFLAGS}
+ MATH_LIB = -lm
+ X11_INCLUDE_DIR = -I"${EPREFIX}/usr/X11R6/include"
+ MOTIF_INCLUDE_DIR = -I"${EPREFIX}/usr/include" -I../global
+ X11_LIB_DIR = -L"${EPREFIX}/usr/$(get_libdir)"
+ MOTIF_LIB_DIR = -L"${EPREFIX}/usr/$(get_libdir)"
+ X11_LIB = -lX11
+ MOTIF_LIB = -lXm -lXt
+ SHARED_FLAGS = -shared
+ ENDIAN_FLAG = -DBIG_ENDIAN_DATA -DWRITE_ENDIAN_PAR
+ PIC = -fPIC
+ EOF
+
+ use xpm && echo "XPMUSE=\"XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm\"" >> ENVIRONMENT
+
+ epatch \
+ "${FILESDIR}"/${PV}-prll.patch \
+ "${FILESDIR}"/${PV}-impl-dec.patch \
+ "${FILESDIR}"/${PV}-python.patch \
+ "${FILESDIR}"/${PV}-64bit.patch
+}
+
+src_compile() {
+ local mymake
+ local makeflags
+
+ mymake="${mymake} help nongui"
+ use X && mymake="${mymake} gui"
+
+ emake ${mymake}
+
+ compilation() {
+ cd "${BUILD_DIR}" || die
+ emake DataRows_clean
+ emake \
+ PYTHON_INCLUDE_DIR="-I${EPREFIX}/$(python_get_includedir)" \
+ PYTHON_LIB="-l${EPYTHON}" \
+ DataRows
+ }
+ python_copy_sources
+ python_foreach_impl compilation
+}
+
+src_install() {
+ rm bin/pythonAzara || die
+ if ! use X; then
+ rm bin/plot* || die
+ fi
+
+ dodoc CHANGES* README*
+ dohtml -r html/*
+
+ cd bin || die
+ dobin ${PN}
+ rm ${PN} || die
+ for bin in *; do
+ newbin ${bin} ${bin}-${PN}
+ done
+
+ installation() {
+ cd "${BUILD_DIR}" || die
+ python_domodule lib/DataRows.so
+ }
+ python_foreach_impl installation
+}
+
+pkg_postinst() {
+ einfo "Due to collision we moved all binary to *-${PN}"
+}
diff --git a/sci-chemistry/azara/metadata.xml b/sci-chemistry/azara/metadata.xml
index 18c54916e3b4..c0432fefe855 100644
--- a/sci-chemistry/azara/metadata.xml
+++ b/sci-chemistry/azara/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <maintainer>
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher (jlec)</name>
- </maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher (jlec)</name>
+ </maintainer>
</pkgmetadata>