summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:13:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:13:09 +0000
commit4e5c339fca75f12ae3e528fa5f1ae9455c1e264e (patch)
treeb32d2d0d99bc6438e5edfc7779502b8b3f199f30 /sci-chemistry
parentKeyword ~x86. (diff)
downloadgentoo-2-4e5c339fca75f12ae3e528fa5f1ae9455c1e264e.tar.gz
gentoo-2-4e5c339fca75f12ae3e528fa5f1ae9455c1e264e.tar.bz2
gentoo-2-4e5c339fca75f12ae3e528fa5f1ae9455c1e264e.zip
Bump. Upstream dropped gamess support and the toolbar. (#226915) No more need for append-ldflags.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/ghemical/ChangeLog11
-rw-r--r--sci-chemistry/ghemical/ghemical-2.95.ebuild60
2 files changed, 69 insertions, 2 deletions
diff --git a/sci-chemistry/ghemical/ChangeLog b/sci-chemistry/ghemical/ChangeLog
index d49e68d50c61..f06a8f42b346 100644
--- a/sci-chemistry/ghemical/ChangeLog
+++ b/sci-chemistry/ghemical/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/ghemical
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.24 2007/07/22 07:28:37 dberkholz Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ChangeLog,v 1.25 2008/07/08 07:13:09 dberkholz Exp $
+
+*ghemical-2.95 (08 Jul 2008)
+
+ 08 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +ghemical-2.95.ebuild:
+ Bump. Upstream dropped gamess support and the toolbar. (#226915) No more
+ need for append-ldflags.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; ghemical-2.01.ebuild:
Drop virtual/x11 references.
diff --git a/sci-chemistry/ghemical/ghemical-2.95.ebuild b/sci-chemistry/ghemical/ghemical-2.95.ebuild
new file mode 100644
index 000000000000..87c8c31d7b83
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-2.95.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-2.95.ebuild,v 1.1 2008/07/08 07:13:09 dberkholz Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+
+SRC_URI="http://bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="threads openbabel seamonkey"
+RDEPEND="virtual/glut
+ virtual/glu
+ virtual/opengl
+ sci-chemistry/mpqc
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/pango
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/gtkglext-1.0.5
+ >=gnome-base/libglade-2.4
+ >=sci-libs/libghemical-2.96
+ >=x11-libs/liboglappth-0.96
+ openbabel? ( >=sci-chemistry/openbabel-2 )
+ threads? ( >=dev-libs/glib-2.4 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_compile() {
+
+# With amd64, if you want gamess I recommend adding gamess and gtk-gamess to package.provided for now.
+
+# Change the built-in help browser.
+ if use seamonkey ; then
+ sed -i -e 's|mozilla|seamonkey|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
+ else
+ sed -i -e 's|mozilla|firefox|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
+ fi
+
+ econf \
+ $(use_enable openbabel) \
+ $(use_enable threads) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}