summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-29 10:36:13 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-29 10:36:13 +0000
commit3783406054d74a65c71824f7e1fcf0bb973870ae (patch)
tree7154a5b4c82d9d28606cc712237fcdf53e10f4ac /sci-chemistry
parentVersion bump. (diff)
downloadgentoo-2-3783406054d74a65c71824f7e1fcf0bb973870ae.tar.gz
gentoo-2-3783406054d74a65c71824f7e1fcf0bb973870ae.tar.bz2
gentoo-2-3783406054d74a65c71824f7e1fcf0bb973870ae.zip
sci-chemistry/mustang: Fix for gcc-4.7, #413945
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mustang/ChangeLog6
-rw-r--r--sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch16
-rw-r--r--sci-chemistry/mustang/mustang-3.2.1.ebuild10
3 files changed, 28 insertions, 4 deletions
diff --git a/sci-chemistry/mustang/ChangeLog b/sci-chemistry/mustang/ChangeLog
index 8f89c9dbf9c8..9de17907e869 100644
--- a/sci-chemistry/mustang/ChangeLog
+++ b/sci-chemistry/mustang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/mustang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.12 2012/01/21 16:20:22 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/ChangeLog,v 1.13 2012/04/29 10:36:13 jlec Exp $
+
+ 29 Apr 2012; Justin Lecher <jlec@gentoo.org> mustang-3.2.1.ebuild,
+ +files/mustang-3.2.1-gcc-4.7.patch:
+ Fix for gcc-4.7, #413945
21 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> mustang-3.2.1.ebuild:
x86 stable wrt bug #398541
diff --git a/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
new file mode 100644
index 000000000000..9e5dea85afeb
--- /dev/null
+++ b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
@@ -0,0 +1,16 @@
+ src/superpose_on_core_2.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/superpose_on_core_2.cpp b/src/superpose_on_core_2.cpp
+index ae137de..059dfe3 100644
+--- a/src/superpose_on_core_2.cpp
++++ b/src/superpose_on_core_2.cpp
+@@ -55,6 +55,8 @@ using std::ofstream ;
+ #include "multiple_superposition.h"
+ #include "3D_manip_functions.h"
+
++#include <unistd.h>
++
+ int **core_columns ;
+ int *core_columns_2 , NCORE = 0 ;
+ int **algn_to_seq_hash ;
diff --git a/sci-chemistry/mustang/mustang-3.2.1.ebuild b/sci-chemistry/mustang/mustang-3.2.1.ebuild
index dc80d0851972..1a6b04bb48ad 100644
--- a/sci-chemistry/mustang/mustang-3.2.1.ebuild
+++ b/sci-chemistry/mustang/mustang-3.2.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/mustang-3.2.1.ebuild,v 1.8 2012/01/21 16:20:22 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mustang/mustang-3.2.1.ebuild,v 1.9 2012/04/29 10:36:13 jlec Exp $
EAPI=4
-inherit base toolchain-funcs
+inherit eutils toolchain-funcs
MY_PN="MUSTANG"
SRC_P="${PN}_v${PV}"
MY_P="${MY_PN}_v${PV}"
-DESCRIPTION="MUltiple STructural AligNment AlGorithm."
+DESCRIPTION="MUltiple STructural AligNment AlGorithm"
HOMEPAGE="http://www.csse.monash.edu.au/~karun/Site/mustang.html"
SRC_URI="http://www.csse.unimelb.edu.au/~arun/${PN}/${SRC_P}.tgz"
@@ -21,6 +21,10 @@ IUSE=""
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+}
+
src_compile() {
emake \
CPP=$(tc-getCXX) \