summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-08-21 08:50:50 +0000
committerJustin Lecher <jlec@gentoo.org>2014-08-21 08:50:50 +0000
commit1df492e8620b9697fddd79f14352780816ac550e (patch)
tree5794049bf5bdae52b6bad599615abbb530ea3bda /sci-chemistry
parentOld. (diff)
downloadgentoo-2-1df492e8620b9697fddd79f14352780816ac550e.tar.gz
gentoo-2-1df492e8620b9697fddd79f14352780816ac550e.tar.bz2
gentoo-2-1df492e8620b9697fddd79f14352780816ac550e.zip
sci-chemistry/apbs: Fix build failure with USE=tools, #520126
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.4.1.ebuild3
-rw-r--r--sci-chemistry/apbs/files/apbs-1.4.1-manip.patch63
-rw-r--r--sci-chemistry/apbs/files/apbs-1.4.1-multilib.patch14
4 files changed, 71 insertions, 15 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index c62536ea7a15..d1aed31a4dd0 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.64 2014/08/15 08:50:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.65 2014/08/21 08:50:50 jlec Exp $
+
+ 21 Aug 2014; Justin Lecher <jlec@gentoo.org> apbs-1.4.1.ebuild,
+ +files/apbs-1.4.1-manip.patch, files/apbs-1.4.1-multilib.patch:
+ Fix build failure with USE=tools, #520126
*apbs-1.4.1 (15 Aug 2014)
diff --git a/sci-chemistry/apbs/apbs-1.4.1.ebuild b/sci-chemistry/apbs/apbs-1.4.1.ebuild
index a3201f1faaa3..943640b6747d 100644
--- a/sci-chemistry/apbs/apbs-1.4.1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.4.1.ebuild,v 1.1 2014/08/15 08:50:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.4.1.ebuild,v 1.2 2014/08/21 08:50:50 jlec Exp $
EAPI=5
@@ -45,6 +45,7 @@ S="${WORKDIR}"/${PN}-pdb2pqr-${GITHUB_REV}/${PN}
PATCHES=(
"${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-manip.patch
)
src_prepare() {
diff --git a/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch b/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch
new file mode 100644
index 000000000000..edfeb75b886c
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch
@@ -0,0 +1,63 @@
+ apbs/CMakeLists.txt | 2 +-
+ apbs/tools/CMakeLists.txt | 4 ----
+ apbs/tools/manip/CMakeLists.txt | 4 ++--
+ apbs/tools/mesh/CMakeLists.txt | 4 ++--
+ 4 files changed, 5 insertions(+), 9 deletions(-)
+
+diff --git a/apbs/CMakeLists.txt b/apbs/CMakeLists.txt
+index 8917fc4..5152008 100644
+--- a/apbs/CMakeLists.txt
++++ b/apbs/CMakeLists.txt
+@@ -293,7 +293,7 @@ option(ENABLE_FETK "Enable the finite element solver" OFF)
+
+ if(ENABLE_FETK)
+ message(STATUS "Checking for fetk components")
+- set(FETK_ENALBED 1)
++ set(FETK_ENABLED 1)
+
+ list(APPEND APBS_LIBS "-lstdc++")
+ list(APPEND APBS_LIBS "-L${FETK_PATH}/lib")
+diff --git a/apbs/tools/CMakeLists.txt b/apbs/tools/CMakeLists.txt
+index 1982a3c..da3b8ee 100644
+--- a/apbs/tools/CMakeLists.txt
++++ b/apbs/tools/CMakeLists.txt
+@@ -2,7 +2,3 @@ set(EXECUTABLE_OUTPUT_PATH ${TOOLS_PATH}/bin)
+
+ add_subdirectory(mesh)
+ add_subdirectory(manip)
+-
+-if(ENABLE_PYTHON)
+- add_subdirectory(manip)
+-endif(ENABLE_PYTHON)
+diff --git a/apbs/tools/manip/CMakeLists.txt b/apbs/tools/manip/CMakeLists.txt
+index 937dac7..5768cc5 100644
+--- a/apbs/tools/manip/CMakeLists.txt
++++ b/apbs/tools/manip/CMakeLists.txt
+@@ -4,9 +4,9 @@ set(LIBS "")
+ list(APPEND LIBS "apbs_generic")
+ list(APPEND LIBS "apbs_mg")
+ list(APPEND LIBS "apbs_pmgc")
+-if(FETK_ENALBED)
++if(FETK_ENABLED)
+ list(APPEND LIBS "apbs_fem")
+-endif(FETK_ENALBED)
++endif(FETK_ENABLED)
+
+ message(STATUS "libraries: ${LIBS}")
+
+diff --git a/apbs/tools/mesh/CMakeLists.txt b/apbs/tools/mesh/CMakeLists.txt
+index 1406377..6e6dfb9 100644
+--- a/apbs/tools/mesh/CMakeLists.txt
++++ b/apbs/tools/mesh/CMakeLists.txt
+@@ -4,9 +4,9 @@ set(LIBS "")
+ list(APPEND LIBS "apbs_generic")
+ list(APPEND LIBS "apbs_mg")
+ list(APPEND LIBS "apbs_pmgc")
+-if(FETK_ENALBED)
++if(FETK_ENABLED)
+ list(APPEND LIBS "apbs_fem")
+-endif(FETK_ENALBED)
++endif(FETK_ENABLED)
+
+ message(STATUS "libraries: ${LIBS}")
+
diff --git a/sci-chemistry/apbs/files/apbs-1.4.1-multilib.patch b/sci-chemistry/apbs/files/apbs-1.4.1-multilib.patch
index 78061c76b6c2..a4e2d1761cf4 100644
--- a/sci-chemistry/apbs/files/apbs-1.4.1-multilib.patch
+++ b/sci-chemistry/apbs/files/apbs-1.4.1-multilib.patch
@@ -31,7 +31,7 @@ index 75ddbdd..c46f5e7 100644
set(TABI_LIBRARY_BASENAME ${CMAKE_STATIC_LIBRARY_PREFIX}${TABI}${CMAKE_STATIC_LIBRARY_SUFFIX})
endif()
-
-+
++
+ file(GLOB MODS ${LIBRARY_OUTPUT_PATH}/*.mod)
+
install(
@@ -70,18 +70,6 @@ index 75ddbdd..c46f5e7 100644
SET(HAVE_MC_H YES)
endif()
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 44d20fa..5d5150b 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -23,7 +23,6 @@ macro(add_items TYPE)
- endmacro()
-
-
--
- macro(add_sublibrary LIBRARY)
- set(LIBRARY_NAME "apbs_${LIBRARY}")
- set(LIBRARY_DEPENDENCIES ${APBS_LIBS} ${ARGN})
diff --git a/src/fem/CMakeLists.txt b/src/fem/CMakeLists.txt
index 5a950c2..dc37f48 100644
--- a/src/fem/CMakeLists.txt