summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-28 07:57:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-28 07:57:06 +0000
commit4397e842a62749b89a1648de4130cab1c3ea1787 (patch)
tree4dd13c2925c2ba477c569bc053d671c6551befee /sci-chemistry/xyza2pipe
parentVersion bump. (diff)
downloadgentoo-2-4397e842a62749b89a1648de4130cab1c3ea1787.tar.gz
gentoo-2-4397e842a62749b89a1648de4130cab1c3ea1787.tar.bz2
gentoo-2-4397e842a62749b89a1648de4130cab1c3ea1787.zip
sci-chemistry/xyza2pipe: Version Bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/xyza2pipe')
-rw-r--r--sci-chemistry/xyza2pipe/ChangeLog10
-rw-r--r--sci-chemistry/xyza2pipe/files/xyza2pipe-20121001-gentoo.patch168
-rw-r--r--sci-chemistry/xyza2pipe/metadata.xml8
-rw-r--r--sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild33
4 files changed, 213 insertions, 6 deletions
diff --git a/sci-chemistry/xyza2pipe/ChangeLog b/sci-chemistry/xyza2pipe/ChangeLog
index e4ff1d0b2b58..5669aa8025fb 100644
--- a/sci-chemistry/xyza2pipe/ChangeLog
+++ b/sci-chemistry/xyza2pipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/xyza2pipe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xyza2pipe/ChangeLog,v 1.1 2010/11/29 21:09:09 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xyza2pipe/ChangeLog,v 1.2 2013/11/28 07:57:06 jlec Exp $
+
+*xyza2pipe-20121001 (28 Nov 2013)
+
+ 28 Nov 2013; Justin Lecher <jlec@gentoo.org> +xyza2pipe-20121001.ebuild,
+ +files/xyza2pipe-20121001-gentoo.patch, metadata.xml:
+ Version Bump
*xyza2pipe-20101129 (29 Nov 2010)
diff --git a/sci-chemistry/xyza2pipe/files/xyza2pipe-20121001-gentoo.patch b/sci-chemistry/xyza2pipe/files/xyza2pipe-20121001-gentoo.patch
new file mode 100644
index 000000000000..ec4220dd0695
--- /dev/null
+++ b/sci-chemistry/xyza2pipe/files/xyza2pipe-20121001-gentoo.patch
@@ -0,0 +1,168 @@
+ Makefile | 106 +++++++++++++++++++++++++++++++++++++--------------------------
+ 1 file changed, 63 insertions(+), 43 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 15d4bd3..e738ec2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@
+ # Last modified: Feb/22/2012
+ #
+
+-CFLAGS = -O3
++CFLAGS ?= -O3
+ MFLAGS = -lm
+
+ TARGETS = xyza2pipe ucsf2pipe nv2pipe xeasy2pipe azara2pipe vnmr2pipe xwnmr2pipe\
+@@ -62,89 +62,109 @@ clean:
+ rm -f $(TARGETS) addxyza2pipe
+
+ $(OBJECTS_MATH):
+- $(CC) $*.c -c -o $@ $(CFLAGS) -D__XYZA2PIPE__
++ $(CC) $(CPPFLAGS) -D__XYZA2PIPE__ $(CFLAGS) $*.c -c -o $@
+
+ .o:
+- $(CC) $< -c -o $@ $(CFLAGS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $< -c -o $@
+
+ xyza2pipe: $(OBJECTS_C) $(OBJECTS_XP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2xyza: $(OBJECTS_C) $(OBJECTS_PX)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ ucsf2pipe: $(OBJECTS_C) $(OBJECTS_UP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2ucsf: $(OBJECTS_C) $(OBJECTS_PU)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ nv2pipe: $(OBJECTS_C) $(OBJECTS_NP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2nv: $(OBJECTS_C) $(OBJECTS_PN)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ xeasy2pipe: $(OBJECTS_C) $(OBJECTS_EP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2xeasy: $(OBJECTS_C) $(OBJECTS_PE)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ azara2pipe: $(OBJECTS_C) $(OBJECTS_AP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2azara: $(OBJECTS_C) $(OBJECTS_PA)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ vnmr2pipe: $(OBJECTS_C) $(OBJECTS_VP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ xwnmr2pipe: $(OBJECTS_C) $(OBJECTS_BP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ pipe2proj: $(OBJECTS_C) $(OBJECTS_PJ)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ add2pipe: $(OBJECTS_C) $(OBJECTS_DXP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+ rm -f addxyza2pipe
+ ln -s add2pipe addxyza2pipe
+
+ adducsf2pipe: $(OBJECTS_C) $(OBJECTS_DUP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ addnv2pipe: $(OBJECTS_C) $(OBJECTS_DNP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ addxeasy2pipe: $(OBJECTS_C) $(OBJECTS_DEP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ addazara2pipe: $(OBJECTS_C) $(OBJECTS_DAP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ addvnmr2pipe: $(OBJECTS_C) $(OBJECTS_DVP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
+
+ addxwnmr2pipe: $(OBJECTS_C) $(OBJECTS_DBP)
+- $(CC) $@.c $^ -o $@ \
+- $(CFLAGS) $(MFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $@.c $^ -o $@ \
++ $(MFLAGS)
++ mv -v $@ bin/
diff --git a/sci-chemistry/xyza2pipe/metadata.xml b/sci-chemistry/xyza2pipe/metadata.xml
index dde7ca88a50f..ae9ec7c5f6a4 100644
--- a/sci-chemistry/xyza2pipe/metadata.xml
+++ b/sci-chemistry/xyza2pipe/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
new file mode 100644
index 000000000000..bed6cadc44b2
--- /dev/null
+++ b/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/xyza2pipe/xyza2pipe-20121001.ebuild,v 1.1 2013/11/28 07:57:06 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Cross conversion environment of NMR spectra"
+HOMEPAGE="http://fermi.pharm.hokudai.ac.jp/olivia/api/index.php/Xyza2pipe_src"
+SRC_URI="http://fermi.pharm.hokudai.ac.jp/olivia/documents/xyza2pipe.tgz -> ${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="olivia"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ tc-export CC
+ mkdir bin
+}
+
+src_install() {
+ local i
+ dodoc README FEEDBACK
+ cd bin || die
+ for i in *; do
+ newbin ${i}{,-olivia}
+ done
+}