summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-09-20 21:44:50 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-09-20 21:44:50 +0000
commita5e4cae61ea06f8399455d7b11e0eb5790068272 (patch)
treec89a0b70a303e934d961b6a9a63eaa5ebba587ed /sci-chemistry/vmd
parentMarking madplay-0.15.2b-r1 ppc64 for bug # 189875 (diff)
downloadgentoo-2-a5e4cae61ea06f8399455d7b11e0eb5790068272.tar.gz
gentoo-2-a5e4cae61ea06f8399455d7b11e0eb5790068272.tar.bz2
gentoo-2-a5e4cae61ea06f8399455d7b11e0eb5790068272.zip
Added patch to fix python-2.5 compile issues on amd64 (fixes bug #192902).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog8
-rw-r--r--sci-chemistry/vmd/files/vmd-1.8.6-python-2.5.patch37
-rw-r--r--sci-chemistry/vmd/vmd-1.8.6.ebuild3
3 files changed, 46 insertions, 2 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index cd7f9e797d4d..e9842e40110a 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.16 2007/07/22 07:20:11 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.17 2007/09/20 21:44:50 markusle Exp $
+
+ 20 Sep 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/vmd-1.8.6-python-2.5.patch, vmd-1.8.6.ebuild:
+ Added patch to fix python-2.5 compile issues on amd64 (fixes bug
+ #192902). Thanks much to milan hodoscek <milan@cmm.ki.si> for his
+ patch.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; vmd-1.8.5.ebuild,
vmd-1.8.6.ebuild:
diff --git a/sci-chemistry/vmd/files/vmd-1.8.6-python-2.5.patch b/sci-chemistry/vmd/files/vmd-1.8.6-python-2.5.patch
new file mode 100644
index 000000000000..ad8d0ae9b51a
--- /dev/null
+++ b/sci-chemistry/vmd/files/vmd-1.8.6-python-2.5.patch
@@ -0,0 +1,37 @@
+--- vmd-1.8.6/src/py_atomsel.C 2007-04-08 07:04:03.000000000 +0200
++++ vmd-1.8.6.new/src/py_atomsel.C 2007-09-20 19:30:41.000000000 +0200
+@@ -25,6 +25,10 @@
+ #include "py_commands.h"
+ #include "BondSearch.h"
+
++#if PY_VERSION_HEX < ((2<<24)|(5<<16))
++typedef int Py_ssize_t;
++#endif
++
+ typedef struct {
+ PyObject_HEAD
+ AtomSel *atomSel;
+@@ -915,9 +919,11 @@
+ * Support for mapping protocol
+ */
+
+-static int
+-atomselection_length( PyAtomSelObject *a ) {
+- return a->atomSel->selected;
++
++static Py_ssize_t
++atomselection_length(PyObject *a)
++{
++ return ((PyAtomSelObject *)a)->atomSel->selected;
+ }
+
+ // for integer argument, return True or False if index in in selection
+@@ -935,7 +941,7 @@
+ }
+
+ static PyMappingMethods atomsel_mapping = {
+- (inquiry)atomselection_length,
++ atomselection_length,
+ (binaryfunc)atomselection_subscript,
+ 0
+ };
diff --git a/sci-chemistry/vmd/vmd-1.8.6.ebuild b/sci-chemistry/vmd/vmd-1.8.6.ebuild
index bb30cb8352c3..79718275dac0 100644
--- a/sci-chemistry/vmd/vmd-1.8.6.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6.ebuild,v 1.4 2007/07/22 07:20:11 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6.ebuild,v 1.5 2007/09/20 21:44:50 markusle Exp $
inherit eutils toolchain-funcs python
@@ -41,6 +41,7 @@ src_unpack() {
# apply LINUX-arch patches to vmd configure
epatch "${FILESDIR}"/${P}-config-gentoo.patch
+ epatch "${FILESDIR}"/${P}-python-2.5.patch
# prepare the plugins