summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-25 10:52:40 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-25 10:52:40 +0000
commit15c90b5755565b770ac023788a2a6be07b2efbe2 (patch)
tree2139cff0292c0ee247ca87cb3d6b425ef15a2bee /sci-chemistry/viewmol
parentShorten DESCRIPTION (diff)
downloadgentoo-2-15c90b5755565b770ac023788a2a6be07b2efbe2.tar.gz
gentoo-2-15c90b5755565b770ac023788a2a6be07b2efbe2.tar.bz2
gentoo-2-15c90b5755565b770ac023788a2a6be07b2efbe2.zip
Python ABI fixes, #316183
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/viewmol')
-rw-r--r--sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild b/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild
index 4e2eb952023e..10525f19fa7b 100644
--- a/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild
+++ b/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild,v 1.1 2010/03/10 17:09:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/viewmol/viewmol-2.4.1-r1.ebuild,v 1.2 2010/04/25 10:52:40 jlec Exp $
EAPI="3"
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/viewmol/${P}.src.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
@@ -33,6 +33,10 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${P}/source"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PV}-remove-icc-check.patch
epatch "${FILESDIR}"/${PV}-change-default-paths.patch
@@ -71,9 +75,9 @@ src_compile() {
pushd $(uname -s)
emake viewmol_ tm_ bio_ readgamess_ readgauss_ readmopac_ readpdb_ || die
popd
- ${ERPEFIX}/bin/bash makeTranslations || die
+ "${ERPEFIX}"/bin/bash makeTranslations || die
}
src_install() {
- ./install ${ED}/usr || die
+ ./install "${ED}"/usr || die
}