summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-18 22:00:44 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-18 22:00:44 +0000
commit957357d8e82f4986f2ef5e2e89576c00d8bb5139 (patch)
tree73ddae6df302bfe9dd13435db48e38a1432123b2 /sci-chemistry/pymol-plugins-cealign
parentRaise intltool depend to 0.41.0 wrt #295819, thanks to Diego E. Pettenò for ... (diff)
downloadgentoo-2-957357d8e82f4986f2ef5e2e89576c00d8bb5139.tar.gz
gentoo-2-957357d8e82f4986f2ef5e2e89576c00d8bb5139.tar.bz2
gentoo-2-957357d8e82f4986f2ef5e2e89576c00d8bb5139.zip
Moved in from sci overlay
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol-plugins-cealign')
-rw-r--r--sci-chemistry/pymol-plugins-cealign/ChangeLog13
-rw-r--r--sci-chemistry/pymol-plugins-cealign/metadata.xml8
-rw-r--r--sci-chemistry/pymol-plugins-cealign/pymol-plugins-cealign-0.9.ebuild52
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-cealign/ChangeLog b/sci-chemistry/pymol-plugins-cealign/ChangeLog
new file mode 100644
index 000000000000..6ca4ace0403f
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-cealign/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/pymol-plugins-cealign
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-cealign/ChangeLog,v 1.1 2010/02/18 22:00:44 jlec Exp $
+
+*pymol-plugins-cealign-0.9 (18 Feb 2010)
+
+ 18 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +pymol-plugins-cealign-0.9.ebuild, +metadata.xml:
+ New addition, for further reading:
+ Shindyalov IN, Bourne PE. Protein structure alignment by incremental
+ combinatorial extension (CE) of the optimal path. Protein Eng. 1998
+ Sep;11(9):739-47. PMID: 9796821 [PubMed - indexed for MEDLINE]
+
diff --git a/sci-chemistry/pymol-plugins-cealign/metadata.xml b/sci-chemistry/pymol-plugins-cealign/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-cealign/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/pymol-plugins-cealign/pymol-plugins-cealign-0.9.ebuild b/sci-chemistry/pymol-plugins-cealign/pymol-plugins-cealign-0.9.ebuild
new file mode 100644
index 000000000000..9dbdccab69af
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-cealign/pymol-plugins-cealign-0.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-cealign/pymol-plugins-cealign-0.9.ebuild,v 1.1 2010/02/18 22:00:44 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="The CE algorithm is a fast and accurate protein structure alignment algorithm."
+HOMEPAGE="http://www.pymolwiki.org/index.php/Cealign"
+SRC_URI="http://www.pymolwiki.org/images/0/03/Cealign-${PV}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~amd64 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ dev-python/numpy
+ ~sci-chemistry/pymol-1.2.2"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+S=${WORKDIR}/cealign-0.9
+
+src_prepare() {
+ python_copy_sources
+}
+
+src_install(){
+ mtype=$(uname -m)
+
+ distutils_src_install
+
+ installation() {
+ insinto $(python_get_sitedir)/cealign
+ doins qkabsch.py cealign.py || die
+ }
+ python_execute_function -s installation
+
+ cat >> "${T}"/pymolrc <<- EOF
+ run "${EPREFIX}/$(python_get_sitedir -f)/cealign/qkabsch.py"
+ run "${EPREFIX}/$(python_get_sitedir -f)/cealign/cealign.py"
+ EOF
+
+ insinto ${PYMOL_PATH}
+ doins "${T}"/pymolrc || die
+
+ dodoc CHANGES doc/cealign.pdf || die
+}